GTX 1070 Failing to Fold

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

GTX 1070 Failing to Fold

Postby wheatlexus » Mon Oct 21, 2019 8:36 pm

I have a GTX 1070 that is refusing to fold. I tried restarting and doing a clean reinstall of FAH. I have version 7.5.1 on Windows 10. I am on the latest insider build but I'm not convinced this is the issue because CPU folding works fine.

Here is the debug output:
Code: Select all
20:12:48:WU00:FS01:0x21:*********************** Log Started 2019-10-21T20:12:47Z ***********************
20:12:48:WU00:FS01:0x21:Project: 14196 (Run 5, Clone 405, Gen 4)
20:12:48:WU00:FS01:0x21:Unit: 0x000000080002894b5d92465bae72bd3f
20:12:48:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
20:12:48:WU00:FS01:0x21:Machine: 1
20:12:48:WU00:FS01:0x21:Reading tar file core.xml
20:12:48:WU00:FS01:0x21:Reading tar file integrator.xml
20:12:48:WU00:FS01:0x21:Reading tar file state.xml
20:12:48:WU00:FS01:0x21:Reading tar file system.xml
20:12:48:WU00:FS01:0x21:Digital signatures verified
20:12:48:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
20:12:48:WU00:FS01:0x21:Version 0.0.20
20:12:54:WU00:FS01:0x21:ERROR:exception: Error initializing context: clCreateContext (218)
20:12:54:WU00:FS01:0x21:Saving result file logfile_01.txt
20:12:54:WU00:FS01:0x21:Saving result file log.txt
20:12:54:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
20:12:54:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
20:12:54:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14196 run:5 clone:405 gen:4 core:0x21 unit:0x000000080002894b5d92465bae72bd3f
20:12:54:WU00:FS01:Uploading 7.00KiB to 155.247.166.219
20:12:54:WU00:FS01:Connecting to 155.247.166.219:8080
20:12:54:WU00:FS01:Upload complete
20:12:54:WU00:FS01:Server responded WORK_ACK (400)
20:12:54:WU00:FS01:Cleaning up
20:12:54:WU01:FS01:Connecting to 65.254.110.245:8080
20:12:55:WU01:FS01:Assigned to work server 155.247.166.219
20:12:55:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104 [GeForce GTX 1070] 6463 from 155.247.166.219
20:12:55:WU01:FS01:Connecting to 155.247.166.219:8080
20:12:55:WU01:FS01:Downloading 27.44MiB
20:13:01:WU01:FS01:Download 46.01%
20:13:07:WU01:FS01:Download 76.30%
20:13:12:WU01:FS01:Download complete
20:13:12:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:14196 run:2 clone:326 gen:10 core:0x21 unit:0x0000000e0002894b5d924649dcd1b0b4
20:13:12:WU01:FS01:Starting
20:13:12:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\Kurt\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 01 -suffix 01 -version 705 -lifeline 1164 -checkpoint 15 -gpu-vendor nvidia -opencl-platform 0 -opencl-device 0 -cuda-device 0 -gpu 0
20:13:12:WU01:FS01:Started FahCore on PID 4760
20:13:12:WU01:FS01:Core PID:4932
20:13:12:WU01:FS01:FahCore 0x21 started


Error line:
Code: Select all
20:12:54:WU00:FS01:0x21:ERROR:exception: Error initializing context: clCreateContext (218)


This cycle loops a few times before it gets set to failed. It says the error is initializing OpenCL context, so that leads me to believe it could be an issue with my drivers.
System info reports:
Code: Select all
GPU 0            GP104 [GeForce GTX 1070] 6463
CUDA Device 0    Compute: 6.1 Driver: 10.2
OpenCL Device 0  Compute: 1.2 Driver: 440.52


Anything I can do to fix this? Are these drivers not working properly?
wheatlexus
 
Posts: 4
Joined: Mon Oct 21, 2019 8:14 pm

Re: GTX 1070 Failing to Fold

Postby Shirty » Mon Oct 21, 2019 9:09 pm

If you run GPU-Z is the OpenCL box ticked? If not try downloading the latest driver from the Nvidia site.
Image
Shirty
 
Posts: 25
Joined: Thu Jul 11, 2019 10:19 pm

Re: GTX 1070 Failing to Fold

Postby wheatlexus » Mon Oct 21, 2019 9:30 pm

Shirty wrote:If you run GPU-Z is the OpenCL box ticked? If not try downloading the latest driver from the Nvidia site.

It is checked, along with CUDA and DirectCompute 5.0. Are there any known issues with the latest Nvidia drivers? I am using 440.52 which GeForce Experience says is the latest drivers.
wheatlexus
 
Posts: 4
Joined: Mon Oct 21, 2019 8:14 pm

Re: GTX 1070 Failing to Fold

Postby JimboPalmer » Mon Oct 21, 2019 10:24 pm

I show 436.48 as the latest WHQL Game Ready driver from Nvidia. 10/01/19

not at all sure what you have.

https://www.geforce.com/drivers/results/152007
Last edited by JimboPalmer on Tue Oct 22, 2019 12:26 am, edited 1 time in total.
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 950
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: GTX 1070 Failing to Fold

Postby bruce » Tue Oct 22, 2019 12:18 am

clCreateContext does tend to be a driver problem.

Do you really need game-ready drivers or is it enough to support FAH and standard video? (Many updates simply add a fix for a problem with a specific game and they tend to have a higher risk factor.)

I'm running the studio drivers 430.86 but 431.86 seems to be recommended for your GPU. In any case, you probably would be better off with earlier drivers. NVidia isn't doing as good a job of testing new drivers on all older hardware as they used to. Your problem is possibly 440.xx.
bruce
 
Posts: 22818
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: GTX 1070 Failing to Fold

Postby JimboPalmer » Tue Oct 22, 2019 12:31 am

If doing a clean install of a WHQL certified driver does not fix your issue, we are going to need the CONFIGURATION portion of your log. bruce has a link at the bottom of his posts on how to capture that.

If it does fix it, let us know. We feel more confident when our advice fixes things!
JimboPalmer
 
Posts: 950
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: GTX 1070 Failing to Fold

Postby wheatlexus » Tue Oct 22, 2019 4:24 am

It would appear I was running beta drivers, not really sure why since it wasn't evident in GeForce Experience. I did some research on the performance differences in games between the game ready and studio drivers and there doesn't seem to be much of a difference unless you play the latest releases which I often do not. I ended up switching to the studio drivers (431.86), that fixed the problem. CUDA was rolled back from 10.2 to 10.1 but that seems to be the only change. It's also possible that the latest WHQL driver would work too, but studio was an easier rollback so I'm going to stick with it for now.

Thanks for the help everyone!
wheatlexus
 
Posts: 4
Joined: Mon Oct 21, 2019 8:14 pm

Re: GTX 1070 Failing to Fold

Postby JimboPalmer » Tue Oct 22, 2019 9:12 am

Great! If Nvidia really updates OpenCL, we may have issues in the future. F@H does not directly use CUDA, but the Nvidia OpenCL driver calls CUDA internally.
That part of the Nvidia Driver has been stable for quite some time.
JimboPalmer
 
Posts: 950
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: GTX 1070 Failing to Fold

Postby JimboPalmer » Wed Oct 23, 2019 4:55 pm

And now 440.97 is up as a WHQL driver, still not the version you had.

I download it on to two PC, they are folding fine. (GTX1050TI and GTX 1060)
Last edited by JimboPalmer on Thu Oct 24, 2019 12:07 am, edited 1 time in total.
JimboPalmer
 
Posts: 950
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: GTX 1070 Failing to Fold

Postby wheatlexus » Wed Oct 23, 2019 9:42 pm

Yeah seems like it could have been a bad driver release, and then they released an updated iteration. Hopefully if others get "Error initializing context: clCreateContext (218)" this thread will now show up in search results.
wheatlexus
 
Posts: 4
Joined: Mon Oct 21, 2019 8:14 pm


Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 2 guests

cron