asus nvidia Geforce 730 Silent, fails to start wu

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

asus nvidia Geforce 730 Silent, fails to start wu

Postby promeneur » Fri Apr 17, 2015 9:57 am

OS : Opensuse 13.1 x86_64
driver : nvidia 340.76
nvidia opencl is installed

in gpu.txt there is :
0x10de:0x0fc9:2:3:GK208 [GeForce GT 730]

we can find same info in the "system info" tab

i add a gpu slot

fah fails to start a wu

repeatedly i get :
Code: Select all
...
09:17:49:WU02:FS01:Assigned to work server 140.163.4.233
09:17:49:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GK208 [GeForce GT 730] from 140.163.4.233
09:17:49:WU02:FS01:Connecting to 140.163.4.233:8080
09:17:50:WU02:FS01:Downloading 2.30MiB
09:17:53:WU02:FS01:Download complete
09:17:53:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:10466 run:0 clone:59 gen:157 core:0x17 unit:0x00000113538b3db953822ce4f1d4c935
09:17:53:WU02:FS01:Starting
09:17:53:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 02 -suffix 01 -version 704 -lifeline 2741 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
09:17:53:WU02:FS01:Started FahCore on PID 9648
09:17:53:WU02:FS01:Core PID:9652
09:17:53:WU02:FS01:FahCore 0x17 started
09:17:53:WU02:FS01:0x17:*********************** Log Started 2015-04-17T09:17:53Z ***********************
09:17:53:WU02:FS01:0x17:Project: 10466 (Run 0, Clone 59, Gen 157)
09:17:53:WU02:FS01:0x17:Unit: 0x00000113538b3db953822ce4f1d4c935
09:17:53:WU02:FS01:0x17:CPU: 0x00000000000000000000000000000000
09:17:53:WU02:FS01:0x17:Machine: 1
09:17:53:WU02:FS01:0x17:Reading tar file state.xml
09:17:53:WU02:FS01:0x17:Reading tar file system.xml
09:17:54:WU02:FS01:0x17:Reading tar file integrator.xml
09:17:54:WU02:FS01:0x17:Reading tar file core.xml
09:17:54:WU02:FS01:0x17:Digital signatures verified
09:17:54:WU02:FS01:0x17:ERROR:exception: Bad platformId size.
09:17:54:WU02:FS01:0x17:Saving result file logfile_01.txt
09:17:54:WU02:FS01:0x17:Saving result file log.txt
09:17:54:WU02:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
09:17:54:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
09:17:54:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:10466 run:0 clone:59 gen:157 core:0x17 unit:0x00000113538b3db953822ce4f1d4c935
09:17:54:WU02:FS01:Uploading 1.83KiB to 140.163.4.233
09:17:54:WU02:FS01:Connecting to 140.163.4.233:8080
09:17:54:WU02:FS01:Upload complete
09:17:55:WU02:FS01:Server responded WORK_ACK (400)
09:17:55:WU02:FS01:Cleaning up
...

here is system info :

Code: Select all
08:33:52:************************* Folding@home Client *************************
08:33:52:    Website: http://folding.stanford.edu/
08:33:52:  Copyright: (c) 2009-2014 Stanford University
08:33:52:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
08:33:52:       Args: --child --lifeline 2739 /etc/fahclient/config.xml --run-as
08:33:52:             fahclient --pid-file=/var/run/fahclient.pid --daemon
08:33:52:     Config: /etc/fahclient/config.xml
08:33:52:******************************** Build ********************************
08:33:52:    Version: 7.4.4
08:33:52:       Date: Mar 4 2014
08:33:52:       Time: 12:01:17
08:33:52:    SVN Rev: 4130
08:33:52:     Branch: fah/trunk/client
08:33:52:   Compiler: GNU 4.1.2 20080704 (Red Hat 4.1.2-46)
08:33:52:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
08:33:52:             -fno-unsafe-math-optimizations -msse2
08:33:52:   Platform: linux2 2.6.18-164.11.1.el5
08:33:52:       Bits: 64
08:33:52:       Mode: Release
08:33:52:******************************* System ********************************
08:33:52:        CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
08:33:52:     CPU ID: AuthenticAMD Family 15 Model 107 Stepping 2
08:33:52:       CPUs: 2
08:33:52:     Memory: 7.81GiB
08:33:52:Free Memory: 7.42GiB
08:33:52:    Threads: POSIX_THREADS
08:33:52: OS Version: 3.11
08:33:52:Has Battery: false
08:33:52: On Battery: false
08:33:52: UTC Offset: 2
08:33:52:        PID: 2741
08:33:52:        CWD: /var/lib/fahclient
08:33:52:         OS: Linux 3.11.10-29-desktop x86_64
08:33:52:    OS Arch: AMD64
08:33:52:       GPUs: 1
08:33:52:      GPU 0: NVIDIA:3 GK208 [GeForce GT 730]
08:33:52:       CUDA: Not detected
08:33:52:***********************************************************************


Mod edit: Added Code tags to logs
promeneur
 
Posts: 66
Joined: Tue Aug 07, 2012 11:59 am

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby 7im » Fri Apr 17, 2015 1:38 pm

CUDA: not detected means the PC has a driver issue. Install the latest driver from Nvidia, not a third party.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby promeneur » Fri Apr 17, 2015 3:36 pm

are you sure ?
because if i remove nvidia driver (opensuse packet) the software manager warns me that the fahclient use /usr/.../libcuda.so (not sure of the syntax)

i think fah does not detect nvidia cuda because fah does not know how to detect it with opensuse but it uses it .
promeneur
 
Posts: 66
Joined: Tue Aug 07, 2012 11:59 am

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby 7im » Fri Apr 17, 2015 6:28 pm

Not sure of anything except that if fah doesn't see CUDA, it won't fold on the GPU, and that this is common in Linux. Common enough there are several other topics about this in the forum. Sorry, I tend to be a simple Ubuntu user.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby everyman » Fri Apr 17, 2015 8:15 pm

OpenSuSE has always been a bit more Nvidia-challenged than other distros, at least according to Nvidia. For more information see http://users.suse.com/~sndirsch/nvidia- ... HOWTO.html and the Additional Information tab at http://www.nvidia.com/Download/driverRe ... 1761/en-us.


I hope that helps,


E
"In Theory there is no difference between Theory and Practice. In Practice there is."
everyman
 
Posts: 31
Joined: Fri Aug 08, 2008 4:15 am

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby promeneur » Fri Apr 17, 2015 8:48 pm

i learned this : nvidai packets are no supplied by opensuse but by nvidia itself ! so there is no third party nvidia packet .

another thing . watch the log above ; there is this line :

09:17:53:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 02 -suffix 01

it's about fermi gpu but the 730 one is a kepler gpu !
promeneur
 
Posts: 66
Joined: Tue Aug 07, 2012 11:59 am

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby everyman » Fri Apr 17, 2015 9:05 pm

If it were me, I would uninstall what nvidia drivers you have and try to a manual install by downloading from Nvidia's website. You will need to shut down the X windows system and unload any video drivers in use. See this thread for more info: viewtopic.php?f=80&t=27040


E
everyman
 
Posts: 31
Joined: Fri Aug 08, 2008 4:15 am

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby 7im » Fri Apr 17, 2015 9:26 pm

promeneur wrote:i learned this : nvidai packets are no supplied by opensuse but by nvidia itself ! so there is no third party nvidia packet .

another thing . watch the log above ; there is this line :

09:17:53:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 02 -suffix 01

it's about fermi gpu but the 730 one is a kepler gpu !


Yep. The folder is used for Fermi and above. It's using the correct core. But regardless of where the core comes from, none of the GPU cores will run if the client can't see CUDA. Eman is a Suse user. Follow his advice.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: asus nvidia Geforce 730 Silent, fails to start wu

Postby bollix47 » Fri Apr 17, 2015 11:16 pm

If you decide to install cuda doing so will also install the driver (at least it did with ubuntu).

Look here under linux x86 and you'll see a local package installer for opensuse 13.1 and there's a guide further down the page.
Image
bollix47
 
Posts: 3499
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada


Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron