WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby foldy » Wed Jan 25, 2017 7:56 pm

Hannibal13 wrote:Does this mean I can run install the latest driver on my Windows machine for use with F@H? Not sure what this is saying.

Yes that is what I'm saying, the new latest Windows nvidia 378 driver includes the folding@home fix from previous hotfix driver.
foldy
 
Posts: 1498
Joined: Sat Dec 01, 2012 3:43 pm

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby bruce » Wed Jan 25, 2017 8:11 pm

I guess the question becomes: Does it include the performance degradation noted in the hot-fix driver?
bruce
 
Posts: 22623
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby ComputerGenie » Wed Jan 25, 2017 10:59 pm

bruce wrote:I guess the question becomes: Does it include the performance degradation noted in the hot-fix driver?

Since I had 2 projects that were both ~50% complete I figured it was the best time to compare.
2x GTX1080 @ 2025MHz

My results:
376.48
Project:13500 - TPF: 1:31
Project:11710 - TPF: 2:06

378.49
Project:13500 - TPF: 1:27
Project:11710 - TPF: 2:02
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby foldy » Wed Jan 25, 2017 11:04 pm

Oh, new whql driver 378.49 is little faster than hotfix driver 376.48! And compared to previous good driver 373.06?
foldy
 
Posts: 1498
Joined: Sat Dec 01, 2012 3:43 pm

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby neognomic » Thu Jan 26, 2017 4:31 pm

Yes, using it for windoz 81 and it still fails:
ERROR:exception: Error downloading array interactionCount: clEnqueueReadBuffer (-5)
FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
This AM it continued failing about 6 times then it gave up and "FAILED" the FAH-GPU folding core. Normally, it stutters like that 3 or 4 times but finds a unit, folds and completes.

Operating System: Windows 8.1 Pro, 64-bit
DirectX version: 11.0
GPU processor: GeForce GTX 1060 6GB
Driver version: 376.33

My only questions are:
Were the FAH-GPU WU that have been completed and uploaded any good?
Does anyone know if the new (2 days) nVidia 378.49 driver actually resolves the issue(s)? nVidia claims it is fixed "[Folding @ Home] Work unit errors occur. [200262613/1831430]"
Does this occur for Linux 375.26 driver also?
Last edited by neognomic on Thu Jan 26, 2017 4:51 pm, edited 1 time in total.
Supermicro X8DTH-iF: Dual X5687; 24GB; GTX1060-6G; Corsair RM850X; ... Linux 4.9,x; MS Windows 8.1.
Linux Registered User 212962; Still Folding with Team #12501
...
neognomic
 
Posts: 19
Joined: Thu Nov 13, 2008 9:11 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby Joe_H » Thu Jan 26, 2017 4:41 pm

neognomic wrote:Yes, using it for windoz 81 and it still fails:
ERROR:exception: Error downloading array interactionCount: clEnqueueReadBuffer (-5)
FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
This AM it continued failing about 6 times then it gave up and "FAILED" the FAH-GPU folding core. Normally, it stutters like that 3 or 4 times but finds a unit, folds and completes.

If it fails a few WU's then gets one it can process, that WU is probably using Core_18. Folding fails on Core_21 projects with these versions of the drivers. nVidia did release a hot fix version, 376.48, that has been reported to mostly work with Core_21 projects.

Operating System: Windows 8.1 Pro, 64-bit
DirectX version: 11.0
GPU processor: GeForce GTX 1060 6GB
Driver version: 376.33

My only question are:
Were the FAH-GPU WU that have been completed and uploaded any good?
Does anyone know if the new (2 days) nVidia 378.49 driver actually resolves the issue(s)? nVidia claims it is fixed "[Folding @ Home] Work unit errors occur. [200262613/1831430]"
Does this occur for Linux 375.26 driver also?

The WU's completed for Core_18 projects should have been good. Reports are just coming in for 378.49, so a bit more time is needed before saying it is completely fixed.

The Linux version 375 drivers have been reported to have the same problem with Core_21 projects as the Windows drivers.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 4534
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby neognomic » Thu Jan 26, 2017 5:01 pm

Thank you!
I got the 378.49 and will try it ...

The Linux version 375 drivers have been reported to have the same problem with Core_21 projects as the Windows drivers.

Bummer. Linux is my main OS.
nVidia is so slow with Linux drivers' fixes: the 378.09 is still beta. ...hopefully for not much longer.
neognomic
 
Posts: 19
Joined: Thu Nov 13, 2008 9:11 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby ComputerGenie » Thu Jan 26, 2017 5:55 pm

foldy wrote:Oh, new whql driver 378.49 is little faster than hotfix driver 376.48! And compared to previous good driver 373.06?

I had a saw blade tooth drop a carbide tip, so I didn't get my racks made yet. Over the weekend I'll finish the testing I intended to do today/tomorrow.
To be as apples-to-apples as possible, I'll compare 369.30(Cuda install), 373.06, 376.48, and 378.49.
Will post back as soon as I know...
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby SombraGuerrero » Thu Jan 26, 2017 5:56 pm

Hopefully Nvidia will merge the fix into the final Linux package, because as of the beta, they haven't. As for Windows, yes, the new driver works. It merges in the workaround they've had in since hotfix build 376.48.
SombraGuerrero
 
Posts: 110
Joined: Mon Mar 16, 2009 3:06 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby foldy » Thu Jan 26, 2017 6:36 pm

@ComputerGenie: Testing the different driver versions performance may be obsolete because a new FahCore_21 update is currently in beta and will be released "soon".
foldy
 
Posts: 1498
Joined: Sat Dec 01, 2012 3:43 pm

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby ComputerGenie » Thu Jan 26, 2017 6:51 pm

foldy wrote:@ComputerGenie: Testing the different driver versions performance may be obsolete because a new FahCore_21 update is currently in beta and will be released "soon".

Not a fan of holding my breath waiting for "soon".
That being said, since .18 is still not pushed to all betas, it's worth testing since I'm doing a clean install on this new rig (if for no other reason than "because we can").
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby bruce » Thu Jan 26, 2017 11:51 pm

ComputerGenie wrote:Not a fan of holding my breath waiting for "soon".

This time, I would. The fact that the new core version has been placed in beta is a really good sign -- and the topic for reporting problems has been quiet. Don't forget that this problem severely impacts scientific production -- mostly because FAH can't depend on everybody with a GPU installing the hot-fix. Neverthelss, I'm not involved in the decision to release the workaround ... just observing what's happening.
bruce
 
Posts: 22623
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Not impressed by 378.49

Postby snapshot » Fri Jan 27, 2017 9:25 am

A quick test had a P9178 running at 3:00 per frame where 363.06 gave 2:30 and a P10494 running at 10:30 instead of 9:00. Not surprisingly, I've gone back to 363.06. I'll be interested to see if ComputerGenie sees the same.
Last edited by snapshot on Fri Jan 27, 2017 4:25 pm, edited 1 time in total.
User avatar
snapshot
 
Posts: 113
Joined: Thu Apr 09, 2009 7:25 pm
Location: Wiltshire, UK

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby ComputerGenie » Fri Jan 27, 2017 1:35 pm

bruce wrote:
ComputerGenie wrote:Not a fan of holding my breath waiting for "soon".

This time, I would. ... just observing what's happening.

I'm not trying to imply that it will not happen, but as a programmer, I know what nightmarish setbacks can come from even one "small" fix being needed. Coupling that with what PPD I may get at time x vs what PPD I could get today are separate things.
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: WARNING Do not upgrade to 375/376.xx drivers (for xx<48)

Postby neognomic » Fri Jan 27, 2017 4:58 pm

Joe_H wrote:Folding fails on Core_21 projects with these versions of the drivers.
As I said I would I installed the 378.49 nVidia driver for GTX1060 on Win 8.1. FAH-GPU has been running without errors since then and, from the log, folding only Core 21.

I know that this is probably the wrong place to post that since this is essentially a useless/dead thread but do not see a "378.xx" thread to post 378.49 results. :wink:
neognomic
 
Posts: 19
Joined: Thu Nov 13, 2008 9:11 am

PreviousNext

Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron