All WU's fail on GTX 970

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

All WU's fail on GTX 970

Postby Skillz » Wed Jan 11, 2017 10:17 pm

I've been folding on this rig for a while now without any issues. Recently did a fresh install of Windows 7 Pro on a new SSD and I am having all kinds of issues.

First I installed the latest Nvidia drivers. I think they're 376.33. Had issues, so did some Googling to find the hot fix drive for the 10 Series cards. Installed 176.48. Still have issues so I went and found the old driver I originally had installed on the rig before the SSD upgrade. 373.06. Still no luck at all. Every single WU that's download immediately fails.

I tried using DDU to uninstall previous Nvidia drivers and reinstalled 373.06 again, but started to run into a lot of issues. One was the installer was complaining about not being able to create or access some temp file/directory of some sort. So I got around that error by moving the temp directory location directly to c: and got past it. Now the installer gets as far as installing the graphics drivers, but some things don't complete and it fails. After a restart I am at my native resoultion and MSI Afterburner reports the driver 373.06 installed.

I will make a note that when I uninstalled 376.33 and rebooted Windows would automatically reinstall 376.33 no matter what I did. That's when I went to DDU to have the drivers removed in Safe Mode.

Nothing I seem to do fixes this. I know the cards are fine.

edit
Upon more investigating in the log it seems only x21 is immediately dropped. I am currently folding on one of the cards with core x18.
Skillz
 
Posts: 49
Joined: Sun Feb 10, 2008 8:19 pm

Re: All WU's fail on GTX 970

Postby bruce » Thu Jan 12, 2017 1:25 am

Downloading the drivers from NVidia and executing that file will give you what you're probably missing. Microsoft doesn't believe in installing OpenCL; NVidia does.

In other words, from FAH's perspective, DDU is broken.
bruce
 
Posts: 21880
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: All WU's fail on GTX 970

Postby Skillz » Thu Jan 12, 2017 2:19 am

I'm not sure I am following your suggestion. I downloaded the drivers from Nvidia. Got 376.33. 376.48 and 373.06 all downloaded from Nvidia in that order. All failed. I used DDU as a last resort to try 373.06 one last time, but it resulted in the same result.

According to MSI Afterburner I currently have driver 373.06 installed.
Skillz
 
Posts: 49
Joined: Sun Feb 10, 2008 8:19 pm

Re: All WU's fail on GTX 970

Postby Skillz » Thu Jan 12, 2017 4:58 am

The issue was not installing SP1 on Windows 7. Issue has been resolved.

Running 373.06 driver.
Skillz
 
Posts: 49
Joined: Sun Feb 10, 2008 8:19 pm

Re: All WU's fail on GTX 970

Postby bruce » Thu Jan 12, 2017 7:27 pm

So you're saying the successful sequence goes something like this:
* If necessary, upgrade your OS to at least Windows7 SP1. (We already know that support for WinXP is nonexistent even though it might work.)
* Download the desired version of the drivers from NVidia.
* Run that download. (Rather than use DDU)
* Install FAH software if not already installed.
* (If GPUs.txt doesn't mention your GPU, you'll need to have that file updated.)
* If you have a slot for a GPU that has been removed, delete that slot.
* Add a slot for your GPU unless it was added by the most recent install.
* ENJOY
bruce
 
Posts: 21880
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: All WU's fail on GTX 970

Postby bruce » Thu Jan 12, 2017 7:30 pm

BTW, Windows 10 automatically updates drivers occasionally. If it does, it breaks FAH. I suppose it's using DDU and the profile for NV drivers does not install the files supporting OpenCL. I wonder if that's an issue that Microsoft needs to fix or if it something that NVidia can fix. (Where should we report the problem?)
bruce
 
Posts: 21880
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: All WU's fail on GTX 970

Postby ComputerGenie » Thu Jan 12, 2017 9:45 pm

bruce wrote:... I wonder if that's an issue that Microsoft needs to fix or if it something that NVidia can fix. (Where should we report the problem?)

Especially when it comes to drivers, what they need to fix and what they are willing to fix are, usually, mutually exclusive. :(
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: All WU's fail on GTX 970

Postby SteveWillis » Fri Jan 13, 2017 1:01 am

Yet another reason I'm glad I'm using Linux.
Image

1080 and 1080TI GPUs on Linux Mint
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am

Re: All WU's fail on GTX 970

Postby ChristianVirtual » Fri Jan 13, 2017 3:01 am

SteveWillis wrote:Yet another reason I'm glad I'm using Linux.


While in principle I agree I also have trouble to install drivers in Linux at times ... just raised two posting in nV forums for Linux on it; but getting off topic
ImageImage
Please contribute your logs to http://ppd.fahmm.net
User avatar
ChristianVirtual
 
Posts: 1538
Joined: Tue May 28, 2013 12:14 pm
Location: 日本 東京

Re: All WU's fail on GTX 970

Postby SteveWillis » Fri Jan 13, 2017 12:01 pm

ChristianVirtual wrote:While in principle I agree I also have trouble to install drivers in Linux at times ... just raised two posting in nV forums for Linux on it; but getting off topic


Sure. It took me a while to get it figured out but now it's routine. I posted my method in another recent topic.
https://foldingforum.org/viewtopic.php?f=38&t=29528#p291901


Mod Edit: Changed your URL from pointing to the top of that topic to pointing to the actual post at the bottom.
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am

Re: All WU's fail on GTX 970

Postby Leonardo » Sun Jan 15, 2017 11:27 pm

I thought that newer Nvidia drivers than 373.20 for 9XX and 10XX series Nivida GPUs were not stable for Folding.
Skillz, did you try 373.06?
Image
User avatar
Leonardo
 
Posts: 597
Joined: Tue Dec 04, 2007 5:09 am
Location: Eagle River, Alaska

Re: All WU's fail on GTX 970

Postby Leonardo » Sun Jan 15, 2017 11:59 pm

Nvidia workaround, "hotfix" 376.48 drivers seem to work.
https://foldingforum.org/viewtopic.php?f=80&t=29497
Some reporting here and at EVGA forums that 376.48 will cause a production decrease, as compared to 373.06.

I think I'll stay with 373.06 for a while. Given I don't game, I see no advantage to updating at this point.

UPDATE: Skillz, I apologize. I just re-read your post and see that you have already tried 373.06 and 376.48; and I see that you updated Windows 7.
User avatar
Leonardo
 
Posts: 597
Joined: Tue Dec 04, 2007 5:09 am
Location: Eagle River, Alaska


Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron