overclocking multiple nvidia GPUs on Linux - how to

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

overclocking multiple nvidia GPUs on Linux - how to

Postby SteveWillis » Sun Feb 19, 2017 7:29 pm

I know this forum doesn't support overclocking but figure that the worst that can happen is that I get fussed at and the topic gets deleted. Be aware if you get Bad Work Units you've gone too far.


This works on Linux Mint.
I never was able to get it to work by hand editing xorg.conf. What did work was to execute on the command line which sets it all up for you:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Then edit xorg.conf. For me that was sudo vi /etc/X11/xorg.conf and prepend "#" to each line containing allow-empty-initial-configuration to comment it out.

Reboot.

Then to overclock run:

/usr/bin/nvidia-settings

To restore your settings after a reboot create an executable file that you call from startup applications containing the text below which will set the gpu clock offset and set the gpu to prefer maximum performance. My example sets the offset to 50. Don't set the offset too high in the file for your actual display gpu until you know for sure what you want or you may end up with a system where the display won't work:

nvidia-settings -a [gpu:0]/GpuPowerMizerMode=1
nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[3]=50
nvidia-settings -a [gpu:1]/GPUMemoryTransferRateOffset[3]=900

nvidia-settings -a [gpu:1]/GpuPowerMizerMode=1
nvidia-settings -a [gpu:1]/GPUGraphicsClockOffset[3]=50

nvidia-settings -a [gpu:2]/GpuPowerMizerMode=1
nvidia-settings -a [gpu:2]/GPUGraphicsClockOffset[3]=50

nvidia-settings -a [gpu:3]/GpuPowerMizerMode=1
nvidia-settings -a [gpu:3]/GPUGraphicsClockOffset[3]=50
Last edited by SteveWillis on Sun Mar 26, 2017 2:13 am, edited 1 time in total.
Image

1080 and 1080TI GPUs on Linux Mint
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am

Re: overclocking multiple nvidia GPUs on Linux - how to

Postby ChristianVirtual » Sun Feb 19, 2017 9:00 pm

Which driver version you had success with ?

Tried that/similar in the past but the driver I used didn't seems to pass it through.
ImageImage
Please contribute your logs to http://ppd.fahmm.net
User avatar
ChristianVirtual
 
Posts: 1538
Joined: Tue May 28, 2013 12:14 pm
Location: 日本 東京

Re: overclocking multiple nvidia GPUs on Linux - how to

Postby SteveWillis » Sun Feb 19, 2017 10:00 pm

370.28 on two different PCs. Both Linux Mint 17.3 and 18.
I don't know if it made a difference but I got my driver from
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt-get install nvidia-370
but then I always have to go to driver manager and change to the nouveau driver then back to the 370 driver then reboot. Not sure why it works but it is necessary to get the driver to work.
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am

Re: overclocking multiple nvidia GPUs on Linux - how to

Postby ComputerGenie » Sun Feb 19, 2017 10:21 pm

ChristianVirtual wrote:Which driver version you had success with ?

Tried that/similar in the past but the driver I used didn't seems to pass it through.

I haven't tried it headless, but it works on debian 8 with 375.26 (haven't tried newer than that).
User avatar
ComputerGenie
 
Posts: 242
Joined: Mon Dec 12, 2016 4:06 am

Re: overclocking multiple nvidia GPUs on Linux - how to

Postby SteveWillis » Sun Mar 26, 2017 2:12 am

add this to the OP

nvidia-settings -a [gpu:1]/GPUMemoryTransferRateOffset[3]=900
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am


Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 2 guests

cron