Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

Re: Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

Postby katakaio » Tue Mar 24, 2020 1:01 am

Markus_Laker wrote:CPU folding on a 12-core Threadripper is still a decent contribution to be able to make to the cause. :)


Absolutely!
Rescue_166
Intel Core i5-6500 @ 3.2 GHz
EVGA GeForce RTX 2060 6GB XC Ultra
EVGA GeForce GTX 960 4GB FTW

Intel Core i5-3550 @ 3.3 GHz
EVGA GeForce GTX 750 Ti 2GB FTW
katakaio
 
Posts: 27
Joined: Wed Oct 28, 2009 8:31 pm
Location: Florida

Re: Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

Postby xXbraintrafficXx » Tue Mar 24, 2020 4:00 am

I've been struggling with this same issue on F31 KDE w/ an intel CPU and Nvidia card.
Just resolved it today the clGetDeviceIDs() error.

I had to remove the pre-installed mesa drivers.
Code: Select all
mesa-libOpenCL
mesa-libOpenCL-devel


Reboot and finally saw this:
Code: Select all
02:24:28:           GPUs: 1
02:24:28:          GPU 0: Bus:5 Slot:0 Func:0 NVIDIA:7 GP106 [GeForce GTX 1060 3GB] 3935
02:24:28:  CUDA Device 0: Platform:0 Device:0 Bus:5 Slot:0 Compute:6.1 Driver:10.2
02:24:28:OpenCL Device 0: Platform:0 Device:0 Bus:5 Slot:0 Compute:1.2 Driver:440.64


However, now when starting the FAHClient, FAHCore starts, but soon after displays this error.
Code: Select all
02:24:29:WU01:FS01:FahCore returned: INTERRUPTED (102 = 0x66)
xXbraintrafficXx
 
Posts: 3
Joined: Tue Mar 17, 2020 4:03 am

Re: Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

Postby aclater » Fri Apr 03, 2020 9:02 pm

FAH seems to not handle multiple OpenCL platforms well. Uninstalling POCL and whatever the Intel OpenCL you have installed.

viewtopic.php?f=106&t=32277&start=15#p322015
aclater
 
Posts: 2
Joined: Fri Apr 03, 2020 7:48 pm

Re: Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

Postby bruce » Sun Aug 09, 2020 5:56 pm

Was this issue ever resolved?

The Intel iGPU is currently unsupported but the GT1030 should be although it's not a particularly powerful GPU.
bruce
 
Posts: 20019
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: Fedora 31, Nvidia GT 1030: clGetDeviceIDs() returned -1

Postby JohnChodera » Sun Aug 09, 2020 8:42 pm

> FAH seems to not handle multiple OpenCL platforms well. Uninstalling POCL and whatever the Intel OpenCL you have installed.

We're working on a fix for this in the new client bugfix release!

~ John Chodera // MSKCC
User avatar
JohnChodera
Pande Group Member
 
Posts: 406
Joined: Fri Feb 22, 2013 10:59 pm

Previous

Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron