Problem with Radeon R9 290 [on Ubuntu]

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Problem with Radeon R9 290 [on Ubuntu]

Postby f1234k » Fri Mar 17, 2017 8:35 am

Logs show:

Code: Select all
07:51:22:WU02:FS01:Started FahCore on PID 8749
07:51:22:WU02:FS01:Core PID:8753
07:51:22:WU02:FS01:FahCore 0x21 started
07:51:23:WARNING:WU02:FS01:FahCore returned: UNKNOWN_ENUM (127 = 0x7f)
07:52:22:WU02:FS01:Starting
07:52:22:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/ATI/R600/Core_21.fah/FahCore_21 -dir 02 -suffix 01 -version 704 -lifeline 1869 -checkpoint 15 -gpu 0 -gpu-vendor ati
07:52:22:WU02:FS01:Started FahCore on PID 8837
07:52:22:WU02:FS01:Core PID:8841
07:52:22:WU02:FS01:FahCore 0x21 started
07:52:22:WARNING:WU02:FS01:FahCore returned: UNKNOWN_ENUM (127 = 0x7f)
07:52:22:WARNING:WU02:FS01:Too many errors, failing
07:52:22:WU02:FS01:Sending unit results: id:02 state:SEND error:FAILED project:9191 run:2 clone:44 gen:123 core:0x21 unit:0x000000b7ab40415457cb2ceac60ded68
07:52:22:WU02:FS01:Connecting to 171.64.65.84:8080
07:52:23:WU02:FS01:Server responded WORK_ACK (400)
07:52:23:WU02:FS01:Cleaning up


The output of some useful commands are:

Code: Select all
thomas:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290]
thomas:~$ lsb_release -a
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 16.04.1 LTS
Release:   16.04
Codename:   xenial
thomas:~$ sudo modinfo -F filename `lshw -c video | awk '/configuration: driver/{print $2}' | cut -d= -f2`
/lib/modules/4.4.0-66-generic/kernel/drivers/gpu/drm/radeon/radeon.ko
/lib/modules/4.4.0-66-generic/kernel/drivers/gpu/drm/i915/i915.ko
f1234k
 
Posts: 2
Joined: Fri Mar 17, 2017 7:38 am

Re: Problem with Radeon R9 290 [on Ubuntu]

Postby foldy » Fri Mar 17, 2017 7:04 pm

There is a similar thread, maybe that can help you?
viewtopic.php?f=80&t=29803&p=293947#p293939
foldy
 
Posts: 878
Joined: Sat Dec 01, 2012 3:43 pm

Re: Problem with Radeon R9 290 [on Ubuntu]

Postby f1234k » Sat Mar 18, 2017 9:51 am

This is a reply for Nvidia GTX 9xxx cards.

I have a Radeon R9
f1234k
 
Posts: 2
Joined: Fri Mar 17, 2017 7:38 am

Re: Problem with Radeon R9 290 [on Ubuntu]

Postby foldy » Mon Mar 20, 2017 6:51 am

I guess OpenCL is not working. Did you install the amdgpupro driver?
http://support.amd.com/en-us/kb-article ... stall.aspx
foldy
 
Posts: 878
Joined: Sat Dec 01, 2012 3:43 pm


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron