GPU usage is very low < 0.5%

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

GPU usage is very low < 0.5%

Postby 8lec » Sun Sep 08, 2019 7:07 am

I have a humble rx460 and I cannot get the FAH client to use more of my gpu. It usually uses 0.1-0.3%. ATM most of the work is being done by my cpu
8lec
 
Posts: 5
Joined: Sun Sep 08, 2019 6:53 am

Re: GPU usage is very low < 0.5%

Postby bruce » Sun Sep 08, 2019 3:12 pm

There are several recent discussions about troubles getting working drivers for recent AMD GPUs. Apparently the current drivers have bugs in the OpenCL components so they don't work and fixes don't seem to be a priority for AMD. Older drivers have been successfully used iwth older GPUs and I have not searched for specific information about the rx460.

OpenCL can be downloaded directly from AMD or directly from the Khronos Group. This may help.

Please post your log per the instructions below.
bruce
 
Posts: 22602
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: GPU usage is very low < 0.5%

Postby JimboPalmer » Sun Sep 08, 2019 3:14 pm

If you post the first 200 lines of your log, they should include your configuration. Then we can make better guesses.
viewtopic.php?f=24&t=26036
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 895
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: GPU usage is very low < 0.5%

Postby 8lec » Sun Sep 08, 2019 7:30 pm

Code: Select all
*********************** Log Started 2019-09-08T19:28:30Z ***********************
19:28:30:************************* Folding@home Client *************************
19:28:30:        Website: https://foldingathome.org/
19:28:30:      Copyright: (c) 2009-2018 foldingathome.org
19:28:30:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
19:28:30:           Args: --open-web-control
19:28:30:         Config: D:\Program files\config.xml
19:28:30:******************************** Build ********************************
19:28:30:        Version: 7.5.1
19:28:30:           Date: May 11 2018
19:28:30:           Time: 13:06:32
19:28:30:     Repository: Git
19:28:30:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
19:28:30:         Branch: master
19:28:30:       Compiler: Visual C++ 2008
19:28:30:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
19:28:30:       Platform: win32 10
19:28:30:           Bits: 32
19:28:30:           Mode: Release
19:28:30:******************************* System ********************************
19:28:30:            CPU: Intel(R) Core(TM) i3-6098P CPU @ 3.60GHz
19:28:30:         CPU ID: GenuineIntel Family 6 Model 94 Stepping 3
19:28:30:           CPUs: 4
19:28:30:         Memory: 7.96GiB
19:28:30:    Free Memory: 2.21GiB
19:28:30:        Threads: WINDOWS_THREADS
19:28:30:     OS Version: 6.2
19:28:30:    Has Battery: false
19:28:30:     On Battery: false
19:28:30:     UTC Offset: 4
19:28:30:            PID: 9456
19:28:30:            CWD: D:\Program files
19:28:30:             OS: Windows 10 Home
19:28:30:        OS Arch: AMD64
19:28:30:           GPUs: 1
19:28:30:          GPU 0: Bus:1 Slot:0 Func:0 AMD:5 Baffin XT [Radeon RX 460]
19:28:30:           CUDA: Not detected: Failed to open dynamic library 'nvcuda.dll': The
19:28:30:                 specified module could not be found.
19:28:30:
19:28:30:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:2841.5
19:28:30:  Win32 Service: false
19:28:30:***********************************************************************
19:28:30:<config>
19:28:30:  <!-- Network -->
19:28:30:  <proxy v=':8080'/>
19:28:30:
19:28:30:  <!-- Slot Control -->
19:28:30:  <pause-on-battery v='false'/>
19:28:30:
19:28:30:  <!-- User Information -->
19:28:30:  <passkey v='********************************'/>
19:28:30:  <team v='223518'/>
19:28:30:  <user v='8lec'/>
19:28:30:
19:28:30:  <!-- Folding Slots -->
19:28:30:  <slot id='0' type='CPU'/>
19:28:30:  <slot id='1' type='GPU'/>
19:28:30:</config>
19:28:30:Trying to access database...
19:28:30:Successfully acquired database lock
19:28:30:Enabled folding slot 00: READY cpu:2
19:28:30:Enabled folding slot 01: READY gpu:0:Baffin XT [Radeon RX 460]
19:28:30:WU02:FS00:Starting
19:28:30:WU02:FS00:Running FahCore: "D:\Program files\FAHClient/FAHCoreWrapper.exe" "D:\Program files\cores/cores.foldingathome.org/Win32/x86/Core_a7.fah/FahCore_a7.exe" -dir 02 -suffix 01 -version 705 -lifeline 9456 -checkpoint 15 -np 2
19:28:30:WU02:FS00:Started FahCore on PID 8780
19:28:31:WU02:FS00:Core PID:6088
19:28:31:WU02:FS00:FahCore 0xa7 started
19:28:32:WU01:FS01:Starting
19:28:32:WU01:FS01:Running FahCore: "D:\Program files\FAHClient/FAHCoreWrapper.exe" "D:\Program files\cores/cores.foldingathome.org/Win32/AMD64/ATI/R600/Core_21.fah/FahCore_21.exe" -dir 01 -suffix 01 -version 705 -lifeline 9456 -checkpoint 15 -gpu-vendor amd -opencl-platform 0 -opencl-device 0 -gpu 0
19:28:32:WU01:FS01:Started FahCore on PID 3728
19:28:32:WU01:FS01:Core PID:792
19:28:32:WU01:FS01:FahCore 0x21 started
19:28:33:WU02:FS00:0xa7:*********************** Log Started 2019-09-08T19:28:32Z ***********************
19:28:33:WU02:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
19:28:33:WU02:FS00:0xa7:       Type: 0xa7
19:28:33:WU02:FS00:0xa7:       Core: Gromacs
19:28:33:WU02:FS00:0xa7:    Website: https://foldingathome.org/
19:28:33:WU02:FS00:0xa7:  Copyright: (c) 2009-2018 foldingathome.org
19:28:33:WU02:FS00:0xa7:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
19:28:33:WU02:FS00:0xa7:       Args: -dir 02 -suffix 01 -version 705 -lifeline 8780 -checkpoint 15 -np 2
19:28:33:WU02:FS00:0xa7:     Config: <none>
19:28:33:WU02:FS00:0xa7:************************************ Build *************************************
19:28:33:WU02:FS00:0xa7:    Version: 0.0.17
19:28:33:WU02:FS00:0xa7:       Date: Apr 25 2018
19:28:33:WU02:FS00:0xa7:       Time: 11:02:26
19:28:33:WU02:FS00:0xa7: Repository: Git
19:28:33:WU02:FS00:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
19:28:33:WU02:FS00:0xa7:     Branch: master
19:28:33:WU02:FS00:0xa7:   Compiler: Visual C++ 2008
19:28:33:WU02:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
19:28:33:WU02:FS00:0xa7:   Platform: win32 10
19:28:33:WU02:FS00:0xa7:       Bits: 32
19:28:33:WU02:FS00:0xa7:       Mode: Release
19:28:33:WU02:FS00:0xa7:       SIMD: sse2
19:28:33:WU02:FS00:0xa7:************************************ System ************************************
19:28:33:WU02:FS00:0xa7:        CPU: Unknown
19:28:33:WU02:FS00:0xa7:     CPU ID:
19:28:33:WU02:FS00:0xa7:       CPUs: 4
19:28:33:WU02:FS00:0xa7:     Memory: 7.96GiB
19:28:33:WU02:FS00:0xa7:Free Memory: 2.16GiB
19:28:33:WU02:FS00:0xa7:    Threads: WINDOWS_THREADS
19:28:33:WU02:FS00:0xa7: OS Version: 6.2
19:28:33:WU02:FS00:0xa7:Has Battery: false
19:28:33:WU02:FS00:0xa7: On Battery: false
19:28:33:WU02:FS00:0xa7: UTC Offset: 4
19:28:33:WU02:FS00:0xa7:        PID: 6088
19:28:33:WU02:FS00:0xa7:        CWD: D:\Program files\work
19:28:33:WU02:FS00:0xa7:         OS: Windows 10 Home
19:28:33:WU02:FS00:0xa7:    OS Arch: AMD64
19:28:33:WU02:FS00:0xa7:********************************************************************************
19:28:33:WU02:FS00:0xa7:Project: 14137 (Run 14, Clone 113, Gen 59)
19:28:33:WU02:FS00:0xa7:Unit: 0x000000450002894b5c004726f292f20f
19:28:33:WU02:FS00:0xa7:Digital signatures verified
19:28:33:WU02:FS00:0xa7:Calling: mdrun -s frame59.tpr -o frame59.trr -cpi state.cpt -cpt 15 -nt 2
19:28:33:WU01:FS01:0x21:*********************** Log Started 2019-09-08T19:28:33Z ***********************
19:28:33:WU01:FS01:0x21:Project: 14185 (Run 15, Clone 10, Gen 14)
19:28:33:WU01:FS01:0x21:Unit: 0x000000160002894c5d389650b2f50be6
19:28:33:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
19:28:33:WU01:FS01:0x21:Machine: 1
19:28:33:WU01:FS01:0x21:Digital signatures verified
19:28:33:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
19:28:33:WU01:FS01:0x21:Version 0.0.20
19:28:33:WU01:FS01:0x21:  Found a checkpoint file
19:28:33:WU02:FS00:0xa7:Steps: first=147500000 total=2500000
19:28:37:WU02:FS00:0xa7:Completed 88112 out of 2500000 steps (3%)
19:28:40:WU01:FS01:0x21:Completed 5500000 out of 12500000 steps (44%)
19:28:40:WU01:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
8lec
 
Posts: 5
Joined: Sun Sep 08, 2019 6:53 am

Re: GPU usage is very low < 0.5%

Postby 8lec » Sun Sep 08, 2019 7:35 pm

bruce wrote:There are several recent discussions about troubles getting working drivers for recent AMD GPUs. Apparently the current drivers have bugs in the OpenCL components so they don't work and fixes don't seem to be a priority for AMD. Older drivers have been successfully used iwth older GPUs and I have not searched for specific information about the rx460.

OpenCL can be downloaded directly from AMD or directly from the Khronos Group. This may help.

Please post your log per the instructions below.

Thx for the help, can you send me a link from the Khronos group as I'm unable to find and understand what am I supposed to download. Sorry for the trouble
8lec
 
Posts: 5
Joined: Sun Sep 08, 2019 6:53 am

Re: GPU usage is very low < 0.5%

Postby Joe_H » Sun Sep 08, 2019 8:06 pm

It looks like you have working drivers with OpenCL installed already, there is progress shown on a Core 21 WU. The log also shows that the F@h client has detected OpenCL. Additional log entries would be needed of the GPU WU progress to see how fast it is actually going.

Low GPU utilization is expected for the time period right after starting or restarting a WU as the initial setup of WU data is done on the CPU to prepare it for being [assed onto the GPU for processing. How long that period is will depend on the speed of your CPU. Then there will be periodic dips when checkpoints and sanity checks are done on the WU in progress.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 4528
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: GPU usage is very low < 0.5%

Postby bruce » Sun Sep 08, 2019 9:36 pm

19:28:40:WU01:FS01:0x21:Completed 5500000 out of 12500000 steps (44%)


44% of the GPU WU has been completed in the previous run and it's now restarting from that checkpoint.

Are you judging the progress based on the utilization of the CPU by FAHCore_21 or are you looking at the utilization of the GPU's compute engine?
bruce
 
Posts: 22602
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: GPU usage is very low < 0.5%

Postby Joe_H » Sun Sep 08, 2019 10:37 pm

A thought came to me in connection with you using Windows. Are you getting that 0.5% utilization figure from Taskk Manager? Unless you use that correctly, Task Manager will not give an accurate utilization for a GPU being used for computing such as for F@h.

I don't fold on Windows these days, but others have posted on this aspect of looking at GPU utilization. I can't find a recent post quickly, but someone may recall one. Or use an utility like GPU-Z to see how much utilization folding is making of your GPU.
Joe_H
Site Admin
 
Posts: 4528
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: GPU usage is very low < 0.5%

Postby 8lec » Mon Sep 09, 2019 7:42 am

bruce wrote:
Are you judging the progress based on the utilization of the CPU by FAHCore_21 or are you looking at the utilization of the GPU's compute engine?

I'm looking at the GPU usage in task manager and also trying to listen for the card's fan speed to ramp up
8lec
 
Posts: 5
Joined: Sun Sep 08, 2019 6:53 am

Re: GPU usage is very low < 0.5%

Postby 8lec » Mon Sep 09, 2019 7:50 am

Joe_H wrote:A thought came to me in connection with you using Windows. Are you getting that 0.5% utilization figure from Taskk Manager? Unless you use that correctly, Task Manager will not give an accurate utilization for a GPU being used for computing such as for F@h.

I don't fold on Windows these days, but others have posted on this aspect of looking at GPU utilization. I can't find a recent post quickly, but someone may recall one. Or use an utility like GPU-Z to see how much utilization folding is making of your GPU.

I think you've hit the nail on the head, I'm now using GPU-Z to monitor usage and although it's not constantly using a lot, there are spikes going up to 100% which is good.

Thx for the help everyone, this morning when I turned on my PC, I could even hear the fan ramp up. Problem solved I guess :)
8lec
 
Posts: 5
Joined: Sun Sep 08, 2019 6:53 am

Re: GPU usage is very low < 0.5%

Postby bruce » Mon Sep 09, 2019 4:00 pm

FAH processing on a GPU requires the cooperation of both your CPU and your GPU. The heavy work is done by the GPU, but a small portion of CPU resources are required to move data between Main RAM and the GPU's VRAM. Unfortunately those two types of processing are monitored using different tools.
bruce
 
Posts: 22602
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron