Linux Mint 19.3 and RX 550 - GPU not detected

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

Re: Linux Mint 19.3 and RX 550 - GPU not detected

Postby WhataburgerSr » Wed Feb 12, 2020 3:06 am

Hi everyone,

Sorry for the late update but I gave up and installed Windows 10 Home without registering. We don't use this computer much so we can live with the watermark and limited features. I backed up all of the working files I had and wiped it clean.

With Windows 10, the AMD drivers installed easily and FAH works with the GPU and CPU flawlessly. The viewer shows the demo but I can live without that working as long as it is helping find cures.

For anyone that finds this later, here is a list of other items I tried that did not work:
    Installed a free game from Steam to install additional drivers
    Tried Pop!_OS by System76. This distro is my new favorite as it was the easiest to install, update and get to work.
    Downloaded the AMD drivers again, found every listing for OpenCL and installed it one at a time.
    Installed regular AMD gpu drivers
    Installed AMD gpu pro drivers. And removing previous regular gpu drivers before installing pro. And then reinstalling regular drivers
    Tried the openmesa drivers
    After all of this, I uninstalled and reinstalled FAH, restarted, and it did recognize the GPU with OpenCL

It's time for a drink! :D
WhataburgerSr
 
Posts: 7
Joined: Sat Jan 25, 2020 11:03 pm

Re: Linux Mint 19.3 and RX 550 - GPU not detected

Postby bruce » Wed Feb 12, 2020 6:06 am

From FAH's perspective, OpenCL for Intel is useless ... and might even be a net negative. (FAH doesn't support the Intel GPUs; it does support AMD and nVidia. Since we're a support site for FAH, I don't know what Intel's OpenCL might currently be good for.

If you installed another OpenCL package that's working with your AMD GPU drivers, good.
bruce
 
Posts: 19637
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Previous

Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron