[#1107] ATI FirePro V4800 unsupported

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

[#1107] ATI FirePro V4800 unsupported

Postby tsukumogami » Sat Jan 18, 2014 3:09 am

Hi,

I'm trying to fold on my ATI FirePro V4800 card. As far as I can tell, this card is in the whitelist with ID 0x1002:0x68c8:1:4. This card also support OpenCL. However, when I start FaH client, I can only fold on my CPU, while my GPU is reported as unsupported. Please help me find out what am I doing wrong here.

Thank you.
Last edited by bruce on Fri Feb 07, 2014 5:54 am, edited 1 time in total.
Reason: Added ticket number to title.
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby EXT64 » Sat Jan 18, 2014 5:20 am

What driver version and operating system are you running?
EXT64
 
Posts: 323
Joined: Tue Apr 10, 2012 12:54 am

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Sat Jan 18, 2014 5:37 am

I'm using driver version 8.911.3.1000, windows 7 Professional 64 bit.
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby Joe_H » Sat Jan 18, 2014 2:15 pm

The client is supposed to download the latest GPUs.txt file and use that. But that does not always happen. You can manually download the file and move it to the proper directory, it should get used after a restart of the FAHClient process. Otherwise it is set to be updated automatically about once a month.

Also, besides the driver, is the SDK to support OpenCL installed from the Catalyst package? That is needed as well.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6682
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: ATI FirePro V4800 unsupported

Postby PantherX » Sat Jan 18, 2014 2:24 pm

Welcome to the F@H Forum tsukumogami,

Could you please post the initial section of the log file so that we can see your system configuration and F@H settings (viewtopic.php?f=61&t=16206&p=225958#p225958)?
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Troubleshooting Bad WUs Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6850
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Sat Jan 18, 2014 4:10 pm

Hi,

This is my log file:
Code: Select all
*********************** Log Started 2014-01-18T01:24:43Z ***********************
01:24:43:************************* Folding@home Client *************************
01:24:43:      Website: http://folding.stanford.edu/
01:24:43:    Copyright: (c) 2009-2013 Stanford University
01:24:43:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
01:24:43:         Args: --open-web-control
01:24:43:       Config: C:/Users/Journalist/AppData/Roaming/FAHClient/config.xml
01:24:43:******************************** Build ********************************
01:24:43:      Version: 7.3.6
01:24:43:         Date: Feb 18 2013
01:24:43:         Time: 15:25:17
01:24:43:      SVN Rev: 3923
01:24:43:       Branch: fah/trunk/client
01:24:43:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
01:24:43:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
01:24:43:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
01:24:43:     Platform: win32 XP
01:24:43:         Bits: 32
01:24:43:         Mode: Release
01:24:43:******************************* System ********************************
01:24:43:          CPU: Intel(R) Xeon(R) CPU W3520 @ 2.67GHz
01:24:43:       CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
01:24:43:         CPUs: 4
01:24:43:       Memory: 3.98GiB
01:24:43:  Free Memory: 1.88GiB
01:24:43:      Threads: WINDOWS_THREADS
01:24:43:  Has Battery: false
01:24:43:   On Battery: false
01:24:43:   UTC offset: 7
01:24:43:          PID: 5240
01:24:43:          CWD: C:/Users/Journalist/AppData/Roaming/FAHClient
01:24:43:           OS: Windows 7 Professional
01:24:43:      OS Arch: AMD64
01:24:43:         GPUs: 1
01:24:43:        GPU 0: UNSUPPORTED: FirePro V4800
01:24:43:         CUDA: Not detected
01:24:43:Win32 Service: false
01:24:43:***********************************************************************
01:24:43:<config>
01:24:43:  <!-- Folding Slot Configuration -->
01:24:43:  <power v='full'/>
01:24:43:
01:24:43:  <!-- User Information -->
01:24:43:  <passkey v='********************************'/>
01:24:43:  <team v='79419'/>
01:24:43:  <user v='tsukumogami'/>
01:24:43:
01:24:43:  <!-- Folding Slots -->
01:24:43:  <slot id='0' type='CPU'/>
01:24:43:</config>
01:24:43:Trying to access database...
01:24:43:Successfully acquired database lock
01:24:43:Enabled folding slot 00: READY cpu:4
01:24:43:WU00:FS00:Starting
01:24:43:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Journalist/AppData/Roaming/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 00 -suffix 01 -version 703 -lifeline 5240 -checkpoint 15 -np 4
01:24:43:WU00:FS00:Started FahCore on PID 4732
01:24:45:WU00:FS00:Core PID:5044
01:24:45:WU00:FS00:FahCore 0xa4 started
01:24:46:WU00:FS00:0xa4:
01:24:46:WU00:FS00:0xa4:*------------------------------*
01:24:46:WU00:FS00:0xa4:Folding@Home Gromacs GB Core
01:24:46:WU00:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
01:24:46:WU00:FS00:0xa4:
01:24:46:WU00:FS00:0xa4:Preparing to commence simulation
01:24:46:WU00:FS00:0xa4:- Looking at optimizations...
01:24:46:WU00:FS00:0xa4:- Files status OK
01:24:46:WU00:FS00:0xa4:- Expanded 875228 -> 1434864 (decompressed 163.9 percent)
01:24:46:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=875228 data_size=1434864, decompressed_data_size=1434864 diff=0
01:24:46:WU00:FS00:0xa4:- Digital signature verified
01:24:46:WU00:FS00:0xa4:
01:24:46:WU00:FS00:0xa4:Project: 9006 (Run 84, Clone 33, Gen 37)
01:24:46:WU00:FS00:0xa4:
01:24:46:WU00:FS00:0xa4:Assembly optimizations on if available.
01:24:46:WU00:FS00:0xa4:Entering M.D.
01:24:48:13:127.0.0.1:New Web connection
01:24:52:WU00:FS00:0xa4:Mapping NT from 4 to 4
01:24:52:WU00:FS00:0xa4:Completed 0 out of 250000 steps  (0%)
01:24:55:FS00:Shutting core down
01:24:56:WU00:FS00:FahCore returned: INTERRUPTED (102 = 0x66)
01:25:55:Saving configuration to config.xml
01:25:55:<config>
01:25:55:  <!-- Folding Slot Configuration -->
01:25:55:  <power v='off'/>
01:25:55:
01:25:55:  <!-- User Information -->
01:25:55:  <passkey v='********************************'/>
01:25:55:  <team v='79419'/>
01:25:55:  <user v='tsukumogami'/>
01:25:55:
01:25:55:  <!-- Folding Slots -->
01:25:55:  <slot id='0' type='CPU'/>
01:25:55:</config>
01:28:53:WU00:FS00:Starting
01:28:53:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Journalist/AppData/Roaming/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 00 -suffix 01 -version 703 -lifeline 5240 -checkpoint 15 -np 4
01:28:53:WU00:FS00:Started FahCore on PID 5828
01:28:54:WU00:FS00:Core PID:3144
01:28:54:WU00:FS00:FahCore 0xa4 started
01:28:54:WU00:FS00:0xa4:
01:28:54:WU00:FS00:0xa4:*------------------------------*
01:28:54:WU00:FS00:0xa4:Folding@Home Gromacs GB Core
01:28:54:WU00:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
01:28:54:WU00:FS00:0xa4:
01:28:54:WU00:FS00:0xa4:Preparing to commence simulation
01:28:54:WU00:FS00:0xa4:- Looking at optimizations...
01:28:54:WU00:FS00:0xa4:- Files status OK
01:28:54:WU00:FS00:0xa4:- Expanded 875228 -> 1434864 (decompressed 163.9 percent)
01:28:54:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=875228 data_size=1434864, decompressed_data_size=1434864 diff=0
01:28:54:WU00:FS00:0xa4:- Digital signature verified
01:28:54:WU00:FS00:0xa4:
01:28:54:WU00:FS00:0xa4:Project: 9006 (Run 84, Clone 33, Gen 37)
01:28:54:WU00:FS00:0xa4:
01:28:54:WU00:FS00:0xa4:Assembly optimizations on if available.
01:28:54:WU00:FS00:0xa4:Entering M.D.
01:29:00:WU00:FS00:0xa4:Mapping NT from 4 to 4
01:29:00:WU00:FS00:0xa4:Completed 0 out of 250000 steps  (0%)
01:33:45:<config>
01:33:45:  <!-- Folding Slot Configuration -->
01:33:45:  <power v='full'/>
01:33:45:
01:33:45:  <!-- Network -->
01:33:45:  <proxy v=':8080'/>
01:33:45:
01:33:45:  <!-- User Information -->
01:33:45:  <passkey v='********************************'/>
01:33:45:  <team v='79419'/>
01:33:45:  <user v='tsukumogami'/>
01:33:45:
01:33:45:  <!-- Folding Slots -->
01:33:45:  <slot id='0' type='CPU'/>
01:33:45:</config>
01:33:47:WU00:FS00:0xa4:Completed 5000 out of 250000 steps  (2%)
01:36:08:WU00:FS00:0xa4:Completed 7500 out of 250000 steps  (3%)
01:38:47:WU00:FS00:0xa4:Completed 10000 out of 250000 steps  (4%)
01:41:06:WU00:FS00:0xa4:Completed 12500 out of 250000 steps  (5%)
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Mon Jan 20, 2014 3:42 am

Joe_H wrote:The client is supposed to download the latest GPUs.txt file and use that. But that does not always happen. You can manually download the file and move it to the proper directory, it should get used after a restart of the FAHClient process. Otherwise it is set to be updated automatically about once a month.

Also, besides the driver, is the SDK to support OpenCL installed from the Catalyst package? That is needed as well.


Sorry that I did not notice your comment sooner. I've just checked and my GPU.txt file is up to date.

My Catalyst Pro Control Center is version 2012.0166.1131.20636. How do I determine if this version support OpenCL or not?

Thank you.
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby PantherX » Mon Jan 20, 2014 4:10 am

Can you successfully run FAHBench on your GPU without any issues (viewtopic.php?f=38&t=24225)? Are your GPU temperatures within normal range?
User avatar
PantherX
Site Moderator
 
Posts: 6850
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Mon Jan 20, 2014 4:39 am

I selected openCL and run it on my card ( Redwood). I have the following result on both explicit and implicit solvent: clSetKernelArg.
My card is very cool.
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby PantherX » Mon Jan 20, 2014 5:16 am

On some systems, that error was caused by the Driver version. Have you tried 13.12 or 13.9 on your system?
User avatar
PantherX
Site Moderator
 
Posts: 6850
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Mon Jan 20, 2014 5:36 am

I've just checked AMD website and newest version seems to be 13.152.4, should I update to that version?
tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby PantherX » Mon Jan 20, 2014 5:41 am

Yes, that would be a good start. Hopefully, it will work after the driver update.
User avatar
PantherX
Site Moderator
 
Posts: 6850
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: ATI FirePro V4800 unsupported

Postby tsukumogami » Mon Jan 20, 2014 10:45 am

Hi,

I've updated my driver to version 13.152.4 and I can run fahbench now.
My explicit solvent is : 3.55792 ns/day
My implicit solvent is : 16.9325 ns/day

However, I still cannot fold on my card.

This is my log:

Code: Select all
   

    *********************** Log Started 2014-01-20T09:36:36Z ***********************
    09:36:36:************************* Folding@home Client *************************
    09:36:36:      Website: http://folding.stanford.edu/
    09:36:36:    Copyright: (c) 2009-2013 Stanford University
    09:36:36:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
    09:36:36:         Args:
    09:36:36:       Config: C:/Users/Journalist/AppData/Roaming/FAHClient/config.xml
    09:36:36:******************************** Build ********************************
    09:36:36:      Version: 7.3.6
    09:36:36:         Date: Feb 18 2013
    09:36:36:         Time: 15:25:17
    09:36:36:      SVN Rev: 3923
    09:36:36:       Branch: fah/trunk/client
    09:36:36:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
    09:36:36:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
    09:36:36:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
    09:36:36:     Platform: win32 XP
    09:36:36:         Bits: 32
    09:36:36:         Mode: Release
    09:36:36:******************************* System ********************************
    09:36:36:          CPU: Intel(R) Xeon(R) CPU W3520 @ 2.67GHz
    09:36:36:       CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
    09:36:36:         CPUs: 4
    09:36:36:       Memory: 3.98GiB
    09:36:36:  Free Memory: 2.61GiB
    09:36:36:      Threads: WINDOWS_THREADS
    09:36:36:  Has Battery: false
    09:36:36:   On Battery: false
    09:36:36:   UTC offset: 7
    09:36:36:          PID: 3836
    09:36:36:          CWD: C:/Users/Journalist/AppData/Roaming/FAHClient
    09:36:36:           OS: Windows 7 Professional
    09:36:36:      OS Arch: AMD64
    09:36:36:         GPUs: 1
    09:36:36:        GPU 0: UNSUPPORTED: FirePro V4800
    09:36:36:         CUDA: Not detected
    09:36:36:Win32 Service: false
    09:36:36:***********************************************************************
    09:36:36:<config>
    09:36:36:  <!-- Folding Slot Configuration -->
    09:36:36:  <power v='off'/>
    09:36:36:
    09:36:36:  <!-- Network -->
    09:36:36:  <proxy v=':8080'/>
    09:36:36:
    09:36:36:  <!-- User Information -->
    09:36:36:  <passkey v='********************************'/>
    09:36:36:  <team v='79419'/>
    09:36:36:  <user v='tsukumogami'/>
    09:36:36:
    09:36:36:  <!-- Folding Slots -->
    09:36:36:  <slot id='0' type='CPU'/>
    09:36:36:</config>
    09:36:36:Trying to access database...
    09:36:36:Successfully acquired database lock
    09:36:36:Enabled folding slot 00: PAUSED cpu:4 (paused)
    09:37:16:Removing old file 'configs/config-20140118-012555.xml'
    09:37:16:Saving configuration to config.xml
    09:37:16:<config>
    09:37:16:  <!-- Folding Slot Configuration -->
    09:37:16:  <power v='off'/>
    09:37:16:
    09:37:16:  <!-- Network -->
    09:37:16:  <proxy v=':8080'/>
    09:37:16:
    09:37:16:  <!-- User Information -->
    09:37:16:  <passkey v='********************************'/>
    09:37:16:  <team v='79419'/>
    09:37:16:  <user v='tsukumogami'/>
    09:37:16:
    09:37:16:  <!-- Folding Slots -->
    09:37:16:  <slot id='0' type='CPU'/>
    09:37:16:</config>
    09:37:41:Removing old file 'configs/config-20140118-012954.xml'
    09:37:41:Saving configuration to config.xml
    09:37:41:<config>
    09:37:41:  <!-- Folding Slot Configuration -->
    09:37:41:  <power v='off'/>
    09:37:41:
    09:37:41:  <!-- Network -->
    09:37:41:  <proxy v=':8080'/>
    09:37:41:
    09:37:41:  <!-- User Information -->
    09:37:41:  <passkey v='********************************'/>
    09:37:41:  <team v='79419'/>
    09:37:41:  <user v='tsukumogami'/>
    09:37:41:
    09:37:41:  <!-- Folding Slots -->
    09:37:41:  <slot id='0' type='CPU'/>
    09:37:41:</config>
    09:39:12:WU00:FS00:Starting
    09:39:12:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Journalist/AppData/Roaming/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/Core_a3.fah/FahCore_a3.exe -dir 00 -suffix 01 -version 703 -lifeline 3836 -checkpoint 15 -np 4
    09:39:13:WU00:FS00:Started FahCore on PID 5100
    09:39:13:WU00:FS00:Core PID:5112
    09:39:13:WU00:FS00:FahCore 0xa3 started
    09:39:14:WU00:FS00:0xa3:
    09:39:14:WU00:FS00:0xa3:*------------------------------*
    09:39:14:WU00:FS00:0xa3:Folding@Home Gromacs SMP Core
    09:39:14:WU00:FS00:0xa3:Version 2.27 (Dec. 15, 2010)
    09:39:14:WU00:FS00:0xa3:
    09:39:14:WU00:FS00:0xa3:Preparing to commence simulation
    09:39:14:WU00:FS00:0xa3:- Looking at optimizations...
    09:39:14:WU00:FS00:0xa3:- Files status OK
    09:39:14:WU00:FS00:0xa3:- Expanded 3807926 -> 4136808 (decompressed 108.6 percent)
    09:39:14:WU00:FS00:0xa3:Called DecompressByteArray: compressed_data_size=3807926 data_size=4136808, decompressed_data_size=4136808 diff=0
    09:39:14:WU00:FS00:0xa3:- Digital signature verified
    09:39:14:WU00:FS00:0xa3:
    09:39:14:WU00:FS00:0xa3:Project: 6098 (Run 3, Clone 68, Gen 421)
    09:39:14:WU00:FS00:0xa3:
    09:39:14:WU00:FS00:0xa3:Assembly optimizations on if available.
    09:39:14:WU00:FS00:0xa3:Entering M.D.
    09:39:20:WU00:FS00:0xa3:Using Gromacs checkpoints
    09:39:20:WU00:FS00:0xa3:Mapping NT from 4 to 4
    09:39:21:WU00:FS00:0xa3:Resuming from checkpoint
    09:39:21:WU00:FS00:0xa3:Verified 00/wudata_01.log
    09:39:22:WU00:FS00:0xa3:Verified 00/wudata_01.trr
    09:39:22:WU00:FS00:0xa3:Verified 00/wudata_01.edr
    09:39:22:WU00:FS00:0xa3:Completed 388625 out of 500000 steps  (77%)

tsukumogami
 
Posts: 17
Joined: Thu Oct 17, 2013 3:10 pm

Re: ATI FirePro V4800 unsupported

Postby Rattledagger » Mon Jan 20, 2014 1:37 pm

Well, according to Amd's pages the FirePro V4800 only supports OpenCL-1.1 while the HD-5xxx-series of cards supports OpenCl-1.2, so based on this it's a chance it's lacking some neccessary functionality...

But, if goes by WikiPedia, the FirePro 3D V4800 has the code-name Redwood XT(RV830), this equals the same code-name as HD-5670 and all info except OpenGL & OpenCL is the same between these two cards.
Rattledagger
 
Posts: 128
Joined: Thu Dec 06, 2007 10:48 pm
Location: Norway

Re: ATI FirePro V4800 unsupported

Postby 7im » Mon Jan 20, 2014 3:41 pm

0. Confirm device ID with GPU-Z.
1. Does the greylist contain an entry for this device?
2. Is that device white listed or black listed?
3. Does said device support the required specs to fold?
4. If supported, whitelist it. If not supported, blacklist it.
5. Verify AMD or NV supported driver is installed.

EDIT, added 0 & 5
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 10189
Joined: Thu Nov 29, 2007 5:30 pm
Location: Arizona

Next

Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron