Can't install the latest AMD drivers

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

Can't install the latest AMD drivers

Postby Explozzion » Sat May 31, 2014 12:40 pm

Exactly as the title says, I downloaded the latest Catalyst 14.6 drivers for the oficial website ( 5/27/2014 ). The install process went smoothly and pressed finish, restarted my PC as it has been required of me and when I enter to check what drivers I got they are Catalyst 14.2 from 5/22/2014.. I won a R9 270x MSI OC edition, so Mantle should be accepted by my GPU however I can't install the Mantle driver..
Can anyone help me? I've tryed uninstalling all the AMD Drivers from my PC and reistalling them again, with the new one, and it still says that I have the 5/22/2014 drivers installed even though I pressed on the latest beta drivers .exe.
Looking forward for your reply, Thank you!
Explozzion
 
Posts: 1
Joined: Sat May 31, 2014 12:34 pm

Re: Can't install the latest AMD drivers

Postby 7im » Sat May 31, 2014 3:04 pm

Was fah running okay with the 14.2 drivers? We don't typically recommend beta drivers for this exact reason. 14.4 is known to fold well. Use those, and a driver cleaner.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 10189
Joined: Thu Nov 29, 2007 5:30 pm
Location: Arizona

Re: Can't install the latest AMD drivers

Postby PantherX » Sun Jun 01, 2014 2:43 am

Welcome to the F@H Forum Explozzion,

Please note that F@H doesn't use Mantle, it uses OpenCL (not OpenGL) for the calculations. Do note that we would require the log file for further troubleshooting (viewtopic.php?f=81&t=26036). Moreover, if you are encountering errors with a beta driver, you may get better support over at the AMD Forum (http://forums.amd.com/) since we generally recommend WHQL drivers over Beta ones for folding.
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Troubleshooting Bad WUs Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6850
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron