Issue with AMDGPU and RX 480 on Linux

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Issue with AMDGPU and RX 480 on Linux

Postby parkerlreed » Tue Apr 04, 2017 2:57 am

Arch x86_64
mesa-git 90619.8d919ba384-1
mesa-libgl-git 90619.8d919ba384-1
opencl-mesa-git 90619.8d919ba384-1
foldingathome 7.4.4-3
fahcontrol 7.4.4-3
fahviewer 7.4.4-2

Using the AMDGPU kernel module (OSS)

Code: Select all
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev c7)


I have an XFX RX 480 8GB. It gets detected in Folding@Home but fails to initialize.

Code: Select all
Apr 03 02:31:46 e55 FAHClient[459]: 06:31:46:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:Ellesmere XT [Radeon RX 470/480] from 171.67.108.160
Apr 03 02:31:46 e55 FAHClient[459]: 06:31:46:WU02:FS01:Connecting to 171.67.108.160:8080
Apr 03 02:31:49 e55 FAHClient[459]: 06:31:49:WU02:FS01:Downloading 2.02MiB
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Download complete
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:9839 run:1 clone:99 gen:10 core:0x21 unit:0x0000000bab436ca05890cac6dcc153b6
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Starting
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Running FahCore: /opt/fah/FAHCoreWrapper /opt/fah/cores/fahwebx.stanford.edu/cores/Linux/AMD64/ATI/R600/Core_21.fah/FahCore_21 -dir 02 -suffix 01 -version 704 -lifeline 459 -checkpoint 15 -gpu 0 -gpu-vendor ati
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Started FahCore on PID 2337
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:Core PID:2341
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:FahCore 0x21 started
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:*********************** Log Started 2017-04-03T06:31:51Z ***********************
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Project: 9839 (Run 1, Clone 99, Gen 10)
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Unit: 0x0000000bab436ca05890cac6dcc153b6
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Machine: 1
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Reading tar file core.xml
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Reading tar file integrator.xml
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Reading tar file state.xml
Apr 03 02:31:51 e55 FAHClient[459]: 06:31:51:WU02:FS01:0x21:Reading tar file system.xml
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Digital signatures verified
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Version 0.0.18
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:ERROR:126: Bad platformId size.
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Saving result file logfile_01.txt
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Saving result file log.txt
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:9839 run:1 clone:99 gen:10 core:0x21 unit:0x0000000bab436ca05890cac6dcc153b6
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Uploading 2.15KiB to 171.67.108.160
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Connecting to 171.67.108.160:8080
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Upload complete
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Server responded WORK_ACK (400)
Apr 03 02:31:52 e55 FAHClient[459]: 06:31:52:WU02:FS01:Cleaning up


Every time I search for the bad platformid size I just get results about Nvidia drivers. Nothing about AMD. What could be causing this error?
parkerlreed
 
Posts: 1
Joined: Tue Apr 04, 2017 2:52 am

Re: Issue with AMDGPU and RX 480 on Linux

Postby foldy » Tue Apr 04, 2017 4:34 pm

I guess FAH does not like the mesa drivers. Maybe the official AMD drivers work better?
http://support.amd.com/en-us/kb-article ... Notes.aspx
foldy
 
Posts: 942
Joined: Sat Dec 01, 2012 3:43 pm

Re: Issue with AMDGPU and RX 480 on Linux

Postby toTOW » Sat May 20, 2017 5:14 pm

Yes, for FAH, always the drivers downloaded from the AMD website ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8931
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Issue with AMDGPU and RX 480 on Linux

Postby tictoc » Tue Aug 01, 2017 1:53 am

You will at least need the OpenCL portion of the AMDGPU-PRO driver. If you are running Arch Linux, there is a package in the AUR, that is just the OpenCL bits of the Pro driver. https://aur.archlinux.org/packages/opencl-amd

With that package you can run the amdgpu kernel driver, and use the OpenCL bits of the Pro driver for GPU compute. The last time I tested my RX 480 in F@H, the Linux performance was very nearly on par with the Windows performance.

*Edit* Missed the date in the OP, but the information is still good, and as of right now performance of the RX 480 is very good in Linux. :D
tictoc
 
Posts: 17
Joined: Sun Nov 04, 2012 4:43 pm


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 2 guests

cron