GTX1070 not detected

Post requests to add new GPUs to the official whitelist here.

Moderators: Site Moderators, FAHC Science Team

GTX1070 not detected

Postby Faz » Sun Mar 22, 2020 9:25 pm

My GeForce GTX1070 is not detected and i presume it's caused by not being whitelisted.

The description field is missing using command line 'FAHClient --lspci', so i'll list the standard lspci output aswell

Code: Select all
0x10de:0x1b81:10:0:0:NVIDIA Corporation:

Code: Select all
0a:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1)

Code: Select all
*********************** Log Started 2020-03-20T11:40:11Z ***********************
11:40:11:************************* Folding@home Client *************************
11:40:11:        Website: https://foldingathome.org/
11:40:11:      Copyright: (c) 2009-2018 foldingathome.org
11:40:11:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
11:40:11:           Args: --child --lifeline 1816 /etc/fahclient/config.xml --run-as
11:40:11:                 fahclient --pid-file=/var/run/fahclient.pid --daemon
11:40:11:         Config: /etc/fahclient/config.xml
11:40:11:******************************** Build ********************************
11:40:11:        Version: 7.5.1
11:40:11:           Date: May 11 2018
11:40:11:           Time: 19:59:04
11:40:11:     Repository: Git
11:40:11:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
11:40:11:         Branch: master
11:40:11:       Compiler: GNU 6.3.0 20170516
11:40:11:        Options: -std=gnu++98 -O3 -funroll-loops
11:40:11:       Platform: linux2 4.14.0-3-amd64
11:40:11:           Bits: 64
11:40:11:           Mode: Release
11:40:11:******************************* System ********************************
11:40:11:            CPU: AMD Ryzen 7 3700X 8-Core Processor
11:40:11:         CPU ID: AuthenticAMD Family 23 Model 113 Stepping 0
11:40:11:           CPUs: 16
11:40:11:         Memory: 31.37GiB
11:40:11:    Free Memory: 30.53GiB
11:40:11:        Threads: POSIX_THREADS
11:40:11:     OS Version: 5.3
11:40:11:    Has Battery: false
11:40:11:     On Battery: false
11:40:11:     UTC Offset: 1
11:40:11:            PID: 1818
11:40:11:            CWD: /var/lib/fahclient
11:40:11:             OS: Linux 5.3.0-42-generic x86_64
11:40:11:        OS Arch: AMD64
11:40:11:           GPUs: 0
11:40:11:  CUDA Device 0: Platform:0 Device:0 Bus:10 Slot:0 Compute:6.1 Driver:10.1
11:40:11:OpenCL Device 0: Platform:0 Device:0 Bus:10 Slot:0 Compute:1.2 Driver:435.21
11:40:11:***********************************************************************
11:40:11:<config>
11:40:11:  <!-- Client Control -->
11:40:11:  <fold-anon v='true'/>
11:40:11:
11:40:11:  <!-- Folding Slot Configuration -->
11:40:11:  <gpu v='false'/>
11:40:11:
11:40:11:  <!-- Network -->
11:40:11:  <proxy v=':8080'/>
11:40:11:
11:40:11:  <!-- Slot Control -->
11:40:11:  <power v='full'/>
11:40:11:
11:40:11:  <!-- User Information -->
11:40:11:  <user v='Fazmaster'/>
11:40:11:
11:40:11:  <!-- Folding Slots -->
11:40:11:  <slot id='0' type='CPU'/>
11:40:11:</config>
11:40:11:Switching to user fahclient
11:40:11:Trying to access database...
11:40:11:Successfully acquired database lock
11:40:11:Enabled folding slot 00: READY cpu:16
Faz
 
Posts: 3
Joined: Fri Mar 20, 2020 5:52 pm

Re: GTX1070 not detected

Postby bruce » Sun Mar 22, 2020 9:30 pm

No, the GTX 1070 has been whitelisted since it was first introduced.

Have you installed the proprietary drivers from NVidia?
bruce
 
Posts: 20125
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: GTX1070 not detected

Postby Faz » Sun Mar 22, 2020 9:41 pm

Yes. I am running Ubuntu 18.04 with the 435 drivers from the repository:

Code: Select all
xserver-xorg-video-nvidia-435/bionic-updates,now 435.21-0ubuntu0.18.04.2 amd64  [installiert]
  NVIDIA binary Xorg driver


When running FAHClient for the first time, i was missing a package for OpenCL iirc ocl-icd-opencl-dev.
Faz
 
Posts: 3
Joined: Fri Mar 20, 2020 5:52 pm

Re: GTX1070 not detected

Postby uyaem » Sun Mar 22, 2020 10:48 pm

To make sure I understand your last posting correctly: Is it working now?
Image
CPU: Ryzen 9 3900X (1x21 CPUs) ~ GPU: nVidia GeForce GTX 1660 Super (Asus)
uyaem
 
Posts: 222
Joined: Sat Mar 21, 2020 8:35 pm
Location: Esslingen, Germany

Re: GTX1070 not detected

Postby Faz » Sun Mar 22, 2020 10:57 pm

It is working now.
I restarted another time and was able to add the gpu slot.
Sorry for causing confusion.
Faz
 
Posts: 3
Joined: Fri Mar 20, 2020 5:52 pm


Return to New GPUs (whitelist)

Who is online

Users browsing this forum: No registered users and 3 guests

cron