FAH on ubuntu 17.04

FAH provides a V7 client installer for Debian / Mint / Ubuntu / RedHat / CentOS / Fedora. Installation on other distros may or may not be easy but if you can offer help to others, they would appreciate it.

Moderators: Site Moderators, PandeGroup

Re: FAH on ubuntu 17.04

Postby Nathan_P » Fri Sep 22, 2017 4:29 pm

SteveWillis wrote:Just a suggestion: Linux Mint. The only issues I've ever had were the Python dependency and I had to manually download the current GPUs.txt file. Since I don't even know what you mean by the client going down I assume it has never happened to me. Mint is very user friendly.


Got to agree with this, there will be a mint install guide out soon, once I have got my last rig up and running and tested out my notes.
Image
Nathan_P
 
Posts: 1708
Joined: Wed Apr 01, 2009 9:22 pm
Location: Jersey, Channel islands

Re: FAH on ubuntu 17.04

Postby v00d00 » Fri Sep 22, 2017 8:36 pm

FAH works on all Linux distros, even if you maybe need to do a little legwork. The problem seems more to be people who don't have enough experience in using and administrating Linux systems. I was like some of these people about 15 years ago and had no real clue when a problem struck. But nowadays I don't just see problems, I also see solutions to problems.

For example in the Suse thread. The poster was unable to work out dependencies. By running ldd against FAHClient and FAHControl, it would have told him what was missing. Then going to pkgs.org and searching for the shared objects would have given him the pkgs he needed. Being able to do that comes from experience, googling a lot and maybe doing a little programming on the side.

Similarly if the kernel is causing driver issues, then downgrade it, unless you specifically need a driver that comes with it. Or even easier, see what everyone else is running on here and use the same. It seems no one recommends this version of Ubuntu, but alot are using 14. So install 14. If the system is just a headless folding machine its even easier, and shouldnt take more than 20 mins using a netinstall disk (minimal install and do the post-install setup over ssh).

QuintLeo's issue with slot confusion is similarly easy to fix if you break the problem down. Him blaming it on PG isn't really on. This is the way its always been and its not like PG hide the fact either. If you fold, then their are occasions when problems occur. This forum is their mainly for dealing with those issues. But some issues are easier to fix yourself. Some solutions are found by trial and error. When you have run folding for over 10 years, things get a lot easier to handle and deal with.
Image
User avatar
v00d00
 
Posts: 507
Joined: Sun Dec 02, 2007 4:53 am
Location: In the UK

Previous

Return to Q&A about unsupported distros of Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron