[tuto]7.3.6,opensuse 12.3,installation

FAH provides a V7 client installer for Debian / Mint / Ubuntu / RedHat / CentOS / Fedora. Installation on other distros may or may not be easy but if you can offer help to others, they would appreciate it.

Moderators: Site Moderators, PandeGroup

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby CyberiaJohn » Tue Jan 21, 2014 3:12 am

Ah, looks like I found it. Not where I thought it would be. Here it is.
Code: Select all
*********************** Log Started 2014-01-05T01:10:38Z ***********************
01:10:38:************************* Folding@home Client *************************
01:10:38:    Website: http://folding.stanford.edu/
01:10:38:  Copyright: (c) 2009-2013 Stanford University
01:10:38:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
01:10:38:       Args: --child --lifeline 17290 /etc/fahclient/config.xml --run-as
01:10:38:             fahclient --pid-file=/var/run/fahclient.pid --daemon
01:10:38:     Config: /etc/fahclient/config.xml
01:10:38:******************************** Build ********************************
01:10:38:    Version: 7.3.6
01:10:38:       Date: Feb 18 2013
01:10:38:       Time: 07:24:10
01:10:38:    SVN Rev: 3923
01:10:38:     Branch: fah/trunk/client
01:10:38:   Compiler: GNU 4.1.2 20080704 (Red Hat 4.1.2-48)
01:10:38:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
01:10:38:             -fno-unsafe-math-optimizations -msse2
01:10:38:   Platform: linux2 2.6.18-194.3.1.el5
01:10:38:       Bits: 32
01:10:38:       Mode: Release
01:10:38:******************************* System ********************************
01:10:38:        CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz
01:10:38:     CPU ID: GenuineIntel Family 15 Model 2 Stepping 7
01:10:38:       CPUs: 1
01:10:38:     Memory: 1003.62MiB
01:10:38:Free Memory: 81.13MiB
01:10:38:    Threads: POSIX_THREADS
01:10:38:Has Battery: false
01:10:38: On Battery: false
01:10:38: UTC offset: -8
01:10:38:        PID: 17296
01:10:38:        CWD: /var/lib/fahclient
01:10:38:         OS: Linux 3.7.10-1.1-default i686
01:10:38:    OS Arch: X86
01:10:38:       GPUs: 1
01:10:38:      GPU 0: UNSUPPORTED: NV11 [GeForce2 MX/MX 400]
01:10:38:       CUDA: Not detected
01:10:38:***********************************************************************
01:10:38:<config>
01:10:38:  <!-- Folding Slot Configuration -->
01:10:38:  <power v='light'/>
01:10:38:
01:10:38:  <!-- User Information -->
01:10:38:  <user v='anonymous'/>
01:10:38:
01:10:38:  <!-- Folding Slots -->
01:10:38:</config>
01:10:38:Switching to user fahclient
01:10:38:Trying to access database...
01:10:38:Successfully acquired database lock
01:10:38:Enabled folding slot 00: PAUSED cpu:1 (not configured)
01:15:38:Set client configured
01:15:38:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:15:38:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:15:39:WU00:FS00:News: Welcome to Folding@Home
01:15:39:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:15:39:WU00:FS00:Connecting to assign4.stanford.edu:80
01:15:39:WU00:FS00:News: Welcome to Folding@Home
01:15:39:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:15:39:ERROR:WU00:FS00:Exception: Could not get an assignment
01:15:39:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:15:40:WU00:FS00:News: Welcome to Folding@Home
01:15:40:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:15:40:WU00:FS00:Connecting to assign4.stanford.edu:80
01:15:40:WU00:FS00:News: Welcome to Folding@Home
01:15:40:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:15:40:ERROR:WU00:FS00:Exception: Could not get an assignment
01:16:39:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:16:39:WU00:FS00:News: Welcome to Folding@Home
01:16:39:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:16:39:WU00:FS00:Connecting to assign4.stanford.edu:80
01:16:40:WU00:FS00:News: Welcome to Folding@Home
01:16:40:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:16:40:ERROR:WU00:FS00:Exception: Could not get an assignment
01:18:17:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:18:17:WU00:FS00:News: Welcome to Folding@Home
01:18:17:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:18:17:WU00:FS00:Connecting to assign4.stanford.edu:80
01:18:17:WU00:FS00:News: Welcome to Folding@Home
01:18:17:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:18:17:ERROR:WU00:FS00:Exception: Could not get an assignment
01:20:54:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:20:54:WU00:FS00:News: Welcome to Folding@Home
01:20:54:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:20:54:WU00:FS00:Connecting to assign4.stanford.edu:80
01:20:54:WU00:FS00:News: Welcome to Folding@Home
01:20:54:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:20:54:ERROR:WU00:FS00:Exception: Could not get an assignment
01:25:08:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:25:08:WU00:FS00:News: Welcome to Folding@Home
01:25:08:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:25:08:WU00:FS00:Connecting to assign4.stanford.edu:80
01:25:09:WU00:FS00:News: Welcome to Folding@Home
01:25:09:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:25:09:ERROR:WU00:FS00:Exception: Could not get an assignment
01:32:00:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:32:00:WU00:FS00:News: Welcome to Folding@Home
01:32:00:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:32:00:WU00:FS00:Connecting to assign4.stanford.edu:80
01:32:00:WU00:FS00:News: Welcome to Folding@Home
01:32:00:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:32:00:ERROR:WU00:FS00:Exception: Could not get an assignment
01:43:05:WU00:FS00:Connecting to assign3.stanford.edu:8080
01:43:05:WU00:FS00:News: Welcome to Folding@Home
01:43:05:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
01:43:05:WU00:FS00:Connecting to assign4.stanford.edu:80
01:43:06:WU00:FS00:News: Welcome to Folding@Home
01:43:06:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
01:43:06:ERROR:WU00:FS00:Exception: Could not get an assignment
02:01:02:WU00:FS00:Connecting to assign3.stanford.edu:8080
02:01:02:WU00:FS00:News: Welcome to Folding@Home
02:01:02:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
02:01:02:WU00:FS00:Connecting to assign4.stanford.edu:80
02:01:02:WU00:FS00:News: Welcome to Folding@Home
02:01:02:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
02:01:02:ERROR:WU00:FS00:Exception: Could not get an assignment
02:30:04:WU00:FS00:Connecting to assign3.stanford.edu:8080
02:30:04:WU00:FS00:News: Welcome to Folding@Home
02:30:04:WARNING:WU00:FS00:Failed to get assignment from 'assign3.stanford.edu:8080': Empty work server assignment
02:30:04:WU00:FS00:Connecting to assign4.stanford.edu:80
02:30:05:WU00:FS00:News: Welcome to Folding@Home
02:30:05:WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Empty work server assignment
02:30:05:ERROR:WU00:FS00:Exception: Could not get an assignment
03:03:50:Caught signal SIGTERM(15) on PID 17296
03:03:51:Exiting, please wait. . .
03:03:51:Caught signal SIGINT(2) on PID 17296
03:03:51:WARNING:Next signal will force exit


Mod Edit: Changed Quote Tags To Code Tags - PantherX
CyberiaJohn
 
Posts: 11
Joined: Wed Dec 25, 2013 1:34 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby PantherX » Tue Jan 21, 2014 4:27 am

I think that there might be lack of single CPU Projects and/or your system is 32-bit as opposed to 64-bit. Nonetheless, work is being done to allow single CPUs to contribute but there isn't any ETA (http://folding.stanford.edu/home/cpu-co ... tnerships/).
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Chrome Folding App (Beta) Ӂ Troubleshooting "Bad WUs" Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby CyberiaJohn » Tue Jan 21, 2014 5:41 am

Thanks. I guess I'll keep trying for a while. Then if I have no luck, maybe I'll try to find some other distributed computing effort that still supports 32-bit machines.

I've got this old machine that works perfectly fine, and for various reasons I do not want to (and even, *can*not) upgrade it to a 64-bit machine, so I'm trying to put it to good use other than to play with my Linux once in a while.
CyberiaJohn
 
Posts: 11
Joined: Wed Dec 25, 2013 1:34 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby PantherX » Wed Jan 22, 2014 3:02 am

It seems that there was an issue which was discovered and is now fixed (viewtopic.php?p=257180#p257180). Hopefully, you can now get WUs on your system.
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby CyberiaJohn » Fri Jan 24, 2014 4:13 am

Hmmm ... I'm still having problems. It's perpetually on "connecting."

On my "Configure" tab the client name is "local" and the Hostname or IP is 127.0.0.1. The port is 36330. All these were the defaults when I installed it. Not sure if I was supposed to change anything there???
CyberiaJohn
 
Posts: 11
Joined: Wed Dec 25, 2013 1:34 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby CyberiaJohn » Fri Jan 24, 2014 4:31 am

I just uninstalled and then re-installed it, and it's FINALLY working! Have no idea what I did different this time.

Anyway, thanks for the help!
CyberiaJohn
 
Posts: 11
Joined: Wed Dec 25, 2013 1:34 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby PantherX » Fri Jan 24, 2014 4:33 am

Assuming default options, is the FAHClient service running? If it is, than Advanced Control (AKA FAHControl) should automatically connect with those default settings. If FAHClient isn't running, then you can do it by:
sudo /etc/init.d/FAHClient start

For stopping it, it is:
sudo /etc/init.d/FAHClient stop

If you want to restart, use:
sudo /etc/init.d/FAHClient restart

EDIT -> Glad to see that your issue is resolved. Have left the above information for future reference in case it is needed.
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby CyberiaJohn » Sat Feb 01, 2014 5:50 am

Just FYI, since I got it running the last time, I've since started it twice, and got nothing but the "connecting" message, hanging there doing nothing. So I just did the re-start command you posted above, and now it seems to be working. I hope I don't have to do that every time, but if I do, at least it seems to be working.
CyberiaJohn
 
Posts: 11
Joined: Wed Dec 25, 2013 1:34 am

Re: [tuto]7.3.6,opensuse 12.3,installation

Postby PantherX » Sun Feb 02, 2014 3:04 am

It seems that during the installation, you unchecked the box which allowed the service to auto start. A possible fix is to reinstall it and accept the defaults by keeping the configuration. Alternatively, you can finish all the WUs and purge F@H and do a fresh installation with the default settings.
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Previous

Return to Q&A about unsupported distros of Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron