Debian: FAHControl dependencies severely out of date

FAH provides a V7 client installer for Debian / Mint / Ubuntu / RedHat / CentOS / Fedora. Installation on other distros may or may not be easy but if you can offer help to others, they would appreciate it.

Moderators: Site Moderators, FAHC Science Team

Debian: FAHControl dependencies severely out of date

Postby AthanSpod » Wed Mar 25, 2020 1:32 pm

Whilst the fahclient .deb installs and runs OK (still a systemctl error on startup, but it does actually run), the fahcontrol .deb package won't install on a Debian 10 (buster) system.

Code: Select all
08:29:14 0$ dpkg -i fahcontrol_7.4.4-1_all.deb
Selecting previously unselected package fahcontrol.
(Reading database ... 432287 files and directories currently installed.)
Preparing to unpack fahcontrol_7.4.4-1_all.deb ...
Unpacking fahcontrol (7.4.4-1) ...
dpkg: dependency problems prevent configuration of fahcontrol:
 fahcontrol depends on python-support (>= 0.90.0); however:
  Package python-support is not installed.

dpkg: error processing package fahcontrol (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.31.4-3) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Processing triggers for mime-support (3.62) ...
Errors were encountered while processing:
 fahcontrol

Checking with packages.debian.org that 'python-support' package is listed only in oldoldstable (jessie), so not even in stretch (oldstable) !

Furthermore, the above is on my desktop which seems to have some oldstable packages, as on my server without python-gnome2 installed:
Code: Select all
08:38:29 0$ dpkg -i fahcontrol_7.4.4-1_all.deb
(Reading database ... 363980 files and directories currently installed.)
Preparing to unpack fahcontrol_7.4.4-1_all.deb ...
Unpacking fahcontrol (7.4.4-1) over (7.4.4-1) ...
dpkg: dependency problems prevent configuration of fahcontrol:
 fahcontrol depends on python-support (>= 0.90.0); however:
  Package python-support is not installed.
 fahcontrol depends on python-gnome2; however:
  Package python-gnome2 is not installed.

dpkg: error processing package fahcontrol (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-4) ...
Processing triggers for mime-support (3.62) ...
Errors were encountered while processing:
 fahcontrol

And again packages.debian.org does only list the package for oldstable and oldoldstable.

This leaves fahcontrol in a broken state, and despite files being installed trying to run it results in an error:
Code: Select all
08:02:37 0$ FAHControl
Traceback (most recent call last):
  File "/usr/bin/FAHControl", line 25, in <module>
    from fah import FAHControl, load_fahcontrol_db
ImportError: No module named fah

Code: Select all
08:41:45 0$ dpkg -L fahcontrol
/.
/usr
/usr/share
/usr/share/pyshared
/usr/share/pyshared/FAHControl-7.4.4.egg-info
/usr/share/pyshared/FAHControl-7.4.4.egg-info/SOURCES.txt
/usr/share/pyshared/FAHControl-7.4.4.egg-info/top_level.txt
/usr/share/pyshared/FAHControl-7.4.4.egg-info/requires.txt
/usr/share/pyshared/FAHControl-7.4.4.egg-info/PKG-INFO
/usr/share/pyshared/FAHControl-7.4.4.egg-info/dependency_links.txt
/usr/share/pyshared/fah
/usr/share/pyshared/fah/FAHControl.glade
/usr/share/pyshared/fah/FAHControl_glade.py
/usr/share/pyshared/fah/wraplabel.py
/usr/share/pyshared/fah/util
/usr/share/pyshared/fah/util/OrderedDict.py
/usr/share/pyshared/fah/util/__init__.py
/usr/share/pyshared/fah/util/EntryValidator.py
/usr/share/pyshared/fah/util/SingleApp.py
/usr/share/pyshared/fah/util/PasswordValidator.py
/usr/share/pyshared/fah/db
/usr/share/pyshared/fah/db/Database.py
/usr/share/pyshared/fah/db/Table.py
/usr/share/pyshared/fah/db/__init__.py
/usr/share/pyshared/fah/db/Column.py
/usr/share/pyshared/fah/Icon.py
/usr/share/pyshared/fah/WidgetMap.py
/usr/share/pyshared/fah/ClientConfig.py
/usr/share/pyshared/fah/__init__.py
/usr/share/pyshared/fah/SlotConfig.py
/usr/share/pyshared/fah/FAHControl.py
/usr/share/pyshared/fah/Client.py
/usr/share/pyshared/fah/Connection.py
/usr/share/pyshared/fah/Version.py
/usr/share/doc
/usr/share/doc/fahcontrol
/usr/share/doc/fahcontrol/copyright
/usr/share/doc/fahcontrol/changelog.Debian.gz
/usr/share/doc/fahcontrol/changelog.gz
/usr/share/pixmaps
/usr/share/pixmaps/FAHControl.png
/usr/share/python-support
/usr/share/python-support/fahcontrol.public
/usr/share/applications
/usr/share/applications/FAHControl.desktop
/usr/bin
/usr/bin/FAHControl


I'm not a brilliant programmer but can hammer away on such things until it works, so is there some way to 'join the team' to try and get this fixed ?
AthanSpod
 
Posts: 5
Joined: Wed Mar 25, 2020 9:27 am

Re: Debian: FAHControl dependencies severely out of date

Postby Joe_H » Wed Mar 25, 2020 10:02 pm

There is a GitHub site for the Folding@home software, problem reports can be posted there, but first take a look through the known issues.

However your report is on the 7.4.4 version, the current version is 7.5.1. Some of those dependency issues may have been fixed, others opened up by later versions of Linux since 7.5.1 was released about 2 years ago.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6078
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: Debian: FAHControl dependencies severely out of date

Postby RubixNoob13 » Wed Mar 25, 2020 10:19 pm

I was having this same problem, as of like 3/23/20, the Ubuntu links were still going to the 7.4.4 version of the Linux client.
I am no Linux guru either, but I found this link: https://github.com/FoldingAtHome/fah-issues/issues/1273

Basically, you download a script and run it, passing it the FAHcontrol.deb file. That opens up vim, where you change the python-gnome2 dependency line, replacing "python-gnome2" with "python-gtk2". Save the file, and it makes a FAHcontrol.modfied.deb ("modified" is misspelled from the script as "modfied")

Run the dpkg -i command on the modified deb file, and it worked for me. I'm running Lubuntu 19.10. It's basically Ubuntu, but uses the LXQT desktop instead of the normal one so it's lightweight and runs on older hardware with less bloat.

Hope this helps you!
RubixNoob13
 
Posts: 4
Joined: Sat Mar 21, 2020 4:58 pm
Location: Jackson, TN

Re: Debian: FAHControl dependencies severely out of date

Postby AthanSpod » Wed Mar 25, 2020 11:00 pm

Joe_H wrote:There is a GitHub site for the Folding@home software, problem reports can be posted there, but first take a look through the known issues.

I'll definitley look into that, just in general.

However your report is on the 7.4.4 version, the current version is 7.5.1. Some of those dependency issues may have been fixed, others opened up by later versions of Linux since 7.5.1 was released about 2 years ago.

Ah, this will be an issue with the path I followed to installing. Whilst the links on https://foldingathome.org/alternative-downloads/ indeed have 7.5.1 I'd followed links to the FAQ and found https://foldingathome.org/support/faq/i ... -advanced/ which explicitly lists the following commands:
Code: Select all
wget https://download.foldingathome.org/releases/public/release/fahclient/debian-testing-64bit/v7.4/fahclient_7.4.4_amd64.deb
wget https://download.foldingathome.org/releases/public/release/fahcontrol/debian-testing-64bit/v7.4/fahcontrol_7.4.4-1_all.deb
wget https://download.foldingathome.org/releases/public/release/fahviewer/debian-testing-64bit/v7.4/fahviewer_7.4.4_amd64.deb

I'll switch my server over to 7.5.1 when it's done with its current work unit, and the desktop when I'm booted back into Linux in the morning. Thanks!
AthanSpod
 
Posts: 5
Joined: Wed Mar 25, 2020 9:27 am

Re: Debian: FAHControl dependencies severely out of date

Postby AthanSpod » Wed Mar 25, 2020 11:09 pm

And of course I should note that if FAH set up a proper APT repository for the software this kind of mistake would be a lot harder to make. Automatic updates would be a free bonus.
AthanSpod
 
Posts: 5
Joined: Wed Mar 25, 2020 9:27 am

Re: Debian: FAHControl dependencies severely out of date

Postby AthanSpod » Wed Mar 25, 2020 11:32 pm

RubixNoob13 wrote:I was having this same problem, as of like 3/23/20, the Ubuntu links were still going to the 7.4.4 version of the Linux client.
I am no Linux guru either, but I found this link: https://github.com/FoldingAtHome/fah-issues/issues/1273 <snip>

Thanks, yup, that seems to have worked. I'll know for sure in the morning when my desktop is booted into Linux so I can be sure FAHControl works.
AthanSpod
 
Posts: 5
Joined: Wed Mar 25, 2020 9:27 am

Re: Debian: FAHControl dependencies severely out of date

Postby JeSuisFlaneur » Sat Mar 28, 2020 6:52 pm

I can get neither the 7.5.1-1 nor the 7.5.1 to work, even after modifying the fahcontrol from python-gnome2 to python-gtk2
JeSuisFlaneur
 
Posts: 8
Joined: Tue Mar 24, 2020 10:51 pm

Re: Debian: FAHControl dependencies severely out of date

Postby Runaway1956 » Sat Apr 18, 2020 5:25 pm

Fixed in the latest beta version, 7.69. My package manager no longer complains about FAHControl. viewtopic.php?f=24&t=34466
Image
Runaway1956
 
Posts: 17
Joined: Mon Feb 15, 2016 1:19 pm

Re: Debian: FAHControl dependencies severely out of date

Postby pac1no » Thu Apr 23, 2020 7:13 pm

I facethe same problem. FAHControl complains about python-gnome2 and python-gtk2, which are completely out of date.
Installing those implies breaking the whole system.

I have tried with both 7.6.9 and 7.6.10 with same error
pac1no
 
Posts: 1
Joined: Thu Apr 23, 2020 7:00 pm

Re: Debian: FAHControl dependencies severely out of date

Postby Joe_H » Thu Apr 23, 2020 8:08 pm

Updating the dependencies for Linux was not part of the work done for the recently released updates to the client. Some may have been corrected, but that was not part of the general upgrade. Working on updating to newer versions is to happen in a later release.
Joe_H
Site Admin
 
Posts: 6078
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: Debian: FAHControl dependencies severely out of date

Postby John_D » Sat May 02, 2020 6:38 pm

Um, the client.foldingathome.org installer page might fix, it uses web control instead of fah control. I did not like fighting with FAHControl either, but it works now.
John_D
 
Posts: 33
Joined: Sat Mar 14, 2020 12:32 am


Return to Q&A about unsupported distros of Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron