Ubuntu 18.04 - Need help installing

Moderators: Site Moderators, FAHC Science Team

Ubuntu 18.04 - Need help installing

Postby castlebomb44 » Thu May 03, 2018 2:31 am

Hello,
I have a 64 bit machine and selected the "fahcontrol_7.4.4-1_all.deb" and after I click install and put in my password it still has a dialog box button to install and when I restart its like nothing ever happened..... from what I have been Googleing it looks like I need some version of Python to make the folding at home program work.

What is appropriate python ppa that I need? Or I am really lost and barking up the wrong tree?

Thanks
castlebomb44
 
Posts: 24
Joined: Mon Dec 03, 2007 3:44 am

Re: Ubuntu 18.04 - Need help installing

Postby dieselnut » Mon May 07, 2018 8:36 pm

Can you clarify what you did? I don't follow from you writeup.

Installing on 18.04 is still a crapshoot because of the Python situation. What I did was to install all three .deb packages without the --force-depends flag and just installed the dependencies it was looking for first. Everything is in the repository except for python-support. Since 18.04 comes with Python 3, you have to install Python 2. I did that with

Code: Select all
sudo apt-get install python-minimal


After that I can to install python-gnome2 if I recall

Code: Select all
sudo apt-get install python-ghome2


You can get python-support from here

Code: Select all
wget http://launchpadlibrarian.net/109052632/python-support_1.0.15_all.deb


And then just install it with dpkg -i

Edit: For my setup, I also needed to install another package and its dependencies for the GPU folding to work with the NVidia drivers. Namely:

Code: Select all
sudo apt-get install ocl-icd-opencl-dev


I think that should be all. Having said that, I haven't been able to get my NVidia GPU to fold properly. I don't know what I'm missing, likely related to NVidia drivers, though. Hope this helps.
dieselnut
 
Posts: 6
Joined: Mon May 07, 2018 8:18 pm

Re: Ubuntu 18.04 - Need help installing

Postby SteveWillis » Wed May 09, 2018 1:45 am

If you install the latest beta versions it takes care of the python issue. I know because I just got my third rig up and running today and it wasn't a problem. If it doesn't recognize the gpus be sure and set gpu = true in configure/expert or in config.xml and reboot and it should download the gpus.txt file for you.
Image

1080 and 1080TI GPUs on Linux Mint
SteveWillis
 
Posts: 409
Joined: Fri Apr 15, 2016 1:42 am

Re: Ubuntu 18.04 - Need help installing

Postby castlebomb44 » Wed May 16, 2018 3:53 am

Sorry things were not clearer, I am still new with Linux.

> dieselnut I did what you wrote... and then tried to install the packages from the website.. Didnt seem to work. but,

I used the manual instructions at http://folding.stanford.edu/support/faq ... -advanced/ and that didnt seem to work either, (when I searched from the list of installed applications. I noticed this link of http://folding.stanford.edu/client/ and after I click on it,... it showed me that F@H was indeed working and it somehow found my identity and team info... No idea how that happened.

>SteveWillis Where are the beta versions that you are talking about? I couldnt find them
castlebomb44
 
Posts: 24
Joined: Mon Dec 03, 2007 3:44 am

Re: Ubuntu 18.04 - Need help installing

Postby SteveWillis » Wed May 16, 2018 4:19 am

https://foldingathome.org/beta/ is the latest beta version though I installed the version before that


viewtopic.php?f=104&t=30789
SteveWillis
 
Posts: 409
Joined: Fri Apr 15, 2016 1:42 am


Return to V7.4.4 Public Release Windows/Linux/MacOS X (deprecated)

Who is online

Users browsing this forum: No registered users and 1 guest

cron