Had to delete a WU, advice on settings please

This client will only use a single CPU

Moderators: Site Moderators, PandeGroup

Had to delete a WU, advice on settings please

Postby Bozo » Tue Oct 04, 2011 1:29 pm

After a long abscence I am trying my hand at folding again. Did some reading up and it was apparent the the single console client was the way to go (didnt have gpu or smp clients last time I ran folding).

Set up the same way I always had done in the past and away I went. All was good, submitted a few WU's but then got a much larger unit that frankly I didn't have a snowballs chance in hell of completing within the deadline.

I am running a p4 2.8 pentium at home and although two cores show in task manager I am just running a single instance of the client to keep fan noise down. Previous successful uploads included a 600 point unit and something that was just over 700 points.

I realize that deleting a unit is not a good option but felt in this case i had no choice (never deleted work previously). The unit in question was over 2000 points and despite running for more than the usual amount of hours this pc is on, I had only got up to 4% - looking ahead it became clear I was Not going to finish in time.

I have stopped the service re-ran the setup and the only flag I have set is -verbosity 9
it is now working away on another unit, but I want to check is there any particular setting I should set to be sure i dont receive anything that big again ?

during setup I left almost everything as default eg wu size normal . PC is usually on for long periods of time typically 5hours plus minimum everyday but often a lot more especially at weekends.

I dont want to just be getting the smallest units everytime but the I dont want to live in fear of another huge WU. I guess I have just come back to folding at the same point I left last time, when hardware was struggling on the larger units.

Any advice or comments appreciated.
Bozo
 
Posts: 18
Joined: Mon Oct 03, 2011 10:12 pm

Re: Had to delete a WU, advice on settings please

Postby 7im » Tue Oct 04, 2011 4:43 pm

Larger WU usually have much longer deadlines. What was the deadline on that larger work unit? What was the project #?
Please do not mistake my brevity as dispassion or condescension. I recognize the time you spend reading the forum is time you could use elsewhere, so my short responses save you time. Please do not hesitate to ask for clarification if I was too terse.
User avatar
7im
 
Posts: 13323
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: Had to delete a WU, advice on settings please

Postby Bozo » Tue Oct 04, 2011 5:29 pm

Project: 10722

did have a fair deadline date about a month I think but it was taking between 3 and 4 hours to do 1%. the PC had been on much longer than usual and used for other daily use far less than usual. If I could leave on 24/7 (not an option) I reckon i woul have just let it run.
Bozo
 
Posts: 18
Joined: Mon Oct 03, 2011 10:12 pm

Re: Had to delete a WU, advice on settings please

Postby bruce » Tue Oct 04, 2011 11:27 pm

3 to 4 hrs per % means the WU needs 12 to 17 days of total processing on your hardware. Project 10722 has deadlines of 32 days and 56 days so you probably need run an average of maybe 7 hours a day to get baseline credit or about 11 hrs per day to get a bonus. I'd expect a similar number of hours per day is needed for shorter projects, it just seems different when it's all on the same WU.

I understand that 24x7 is not an option for you. What makes sense for your situation?

Do you have a passkey and have you read the FAQs regarding the Quick Return Bonus?
bruce
Site Admin
 
Posts: 16867
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Had to delete a WU, advice on settings please

Postby Bozo » Wed Oct 05, 2011 11:55 am

I had no idea what is was a few days ago I did get a passkey - to be honest confused with bonus system, happy enough just contributing so not really all that bothered.

Are you saying I actually had up to 56 days? if so i should have just let in run.

what I did find that the log file, unlike all the previous units did not write checkpoints every 15 mins. I found myself staying up an extra hour or so to be sure I stopped client just after it finished another % point rather than wasting the couple of hours it had been running - too much micro mangaging.

Just to be clear I had about 3% done, stayed up until it hit 4% before i closed down pc. This pc had been on all day and evening wheras normally it would only be on from late afternoon (longer at weekend). My way of thinking is that if I was only getting 1-2% for most of the week, occasionaly days with more work done then I was not going to hit 100%. If I actually had up to 56 days I probably could of found a way to do more hours and meet this deadline.

still have log from prevlog file in fah folder (includes end of previous WU)
Code: Select all
[06:25:48]
[06:25:48] + Processing work unit
[06:25:48] Core required: FahCore_a4.exe
[06:25:48] Core found.
[06:25:48] - Autosending finished units... [October 3 06:25:48 UTC]
[06:25:48] Trying to send all finished work units
[06:25:48] + No unsent completed units remaining.
[06:25:48] - Autosend completed
[06:25:48] Working on queue slot 04 [October 3 06:25:48 UTC]
[06:25:48] + Working ...
[06:25:48] - Calling '.\FahCore_a4.exe -dir work/ -suffix 04 -checkpoint 15 -service -forceasm -verbose -lifeline 1224 -version 623'

[06:25:48]
[06:25:48] *------------------------------*
[06:25:48] Folding@Home Gromacs GB Core
[06:25:48] Version 2.27 (Dec. 15, 2010)
[06:25:48]
[06:25:48] Preparing to commence simulation
[06:25:48] - Assembly optimizations manually forced on.
[06:25:48] - Not checking prior termination.
[06:25:48] - Expanded 53027 -> 198744 (decompressed 374.7 percent)
[06:25:48] Called DecompressByteArray: compressed_data_size=53027 data_size=198744, decompressed_data_size=198744 diff=0
[06:25:48] - Digital signature verified
[06:25:48]
[06:25:48] Project: 7018 (Run 0, Clone 2, Gen 44)
[06:25:48]
[06:25:48] Assembly optimizations on if available.
[06:25:48] Entering M.D.
[06:25:55] Using Gromacs checkpoints
[06:25:55] Mapping NT from 1 to 1
[06:25:55] Resuming from checkpoint
[06:25:55] Verified work/wudata_04.log
[06:25:56] Verified work/wudata_04.trr
[06:25:56] Verified work/wudata_04.xtc
[06:25:56] Verified work/wudata_04.edr
[06:25:56] Completed 9300001 out of 10000000 steps  (93%)
[06:55:39] Completed 9400000 out of 10000000 steps  (94%)
[07:24:52] Completed 9500000 out of 10000000 steps  (95%)
[07:53:42] Completed 9600000 out of 10000000 steps  (96%)
[08:22:30] Completed 9700000 out of 10000000 steps  (97%)
[08:51:19] Completed 9800000 out of 10000000 steps  (98%)
[09:20:08] Completed 9900000 out of 10000000 steps  (99%)
[09:48:57] Completed 10000000 out of 10000000 steps  (100%)
[09:48:57] DynamicWrapper: Finished Work Unit: sleep=10000
[09:49:07]
[09:49:07] Finished Work Unit:
[09:49:07] - Reading up to 2048280 from "work/wudata_04.trr": Read 2048280
[09:49:07] trr file hash check passed.
[09:49:07] - Reading up to 213392 from "work/wudata_04.xtc": Read 213392
[09:49:07] xtc file hash check passed.
[09:49:07] edr file hash check passed.
[09:49:07] logfile size: 82522
[09:49:07] Leaving Run
[09:49:09] - Writing 2368666 bytes of core data to disk...
[09:49:09] Done: 2368154 -> 1762203 (compressed to 74.4 percent)
[09:49:10]   ... Done.
[09:49:10] - Shutting down core
[09:49:10]
[09:49:10] Folding@home Core Shutdown: FINISHED_UNIT
[09:49:12] CoreStatus = 64 (100)
[09:49:12] Unit 4 finished with 73 percent of time to deadline remaining.
[09:49:12] Updated performance fraction: 0.761702
[09:49:12] Sending work to server
[09:49:12] Project: 7018 (Run 0, Clone 2, Gen 44)


[09:49:12] + Attempting to send results [October 3 09:49:12 UTC]
[09:49:12] - Reading file work/wuresults_04.dat from core
[09:49:12]   (Read 1762715 bytes from disk)
[09:49:12] Connecting to http://129.74.85.15:8080/
[09:49:40] Posted data.
[09:49:40] Initial: 0000; - Uploaded at ~61 kB/s
[09:49:40] - Averaged speed for that direction ~59 kB/s
[09:49:40] + Results successfully sent
[09:49:40] Thank you for your contribution to Folding@Home.
[09:49:40] + Number of Units Completed: 4

[09:49:44] Trying to send all finished work units
[09:49:44] + No unsent completed units remaining.
[09:49:44] - Preparing to get new work unit...
[09:49:44] + Attempting to get work packet
[09:49:44] - Will indicate memory of 1527 MB
[09:49:44] - Detect CPU. Vendor: GenuineIntel, Family: 15, Model: 4, Stepping: 9
[09:49:44] - Connecting to assignment server
[09:49:44] Connecting to http://assign.stanford.edu:8080/
[09:49:45] Posted data.
[09:49:45] Initial: 43AB; - Successful: assigned to (171.67.108.42).
[09:49:45] + News From Folding@Home: Welcome to Folding@Home
[09:49:45] Loaded queue successfully.
[09:49:45] Connecting to http://171.67.108.42:8080/
[09:49:45] Posted data.
[09:49:45] Initial: 0000; - Receiving payload (expected size: 271418)
[09:49:47] - Downloaded at ~132 kB/s
[09:49:47] - Averaged speed for that direction ~179 kB/s
[09:49:47] + Received work.
[09:49:47] Trying to send all finished work units
[09:49:47] + No unsent completed units remaining.
[09:49:47] + Closed connections
[09:49:47]
[09:49:47] + Processing work unit
[09:49:47] Core required: FahCore_a4.exe
[09:49:47] Core found.
[09:49:47] Working on queue slot 05 [October 3 09:49:47 UTC]
[09:49:47] + Working ...
[09:49:47] - Calling '.\FahCore_a4.exe -dir work/ -suffix 05 -checkpoint 15 -service -forceasm -verbose -lifeline 1224 -version 623'

[09:49:47]
[09:49:47] *------------------------------*
[09:49:47] Folding@Home Gromacs GB Core
[09:49:47] Version 2.27 (Dec. 15, 2010)
[09:49:47]
[09:49:47] Preparing to commence simulation
[09:49:47] - Assembly optimizations manually forced on.
[09:49:47] - Not checking prior termination.
[09:49:47] - Expanded 270906 -> 354128 (decompressed 130.7 percent)
[09:49:47] Called DecompressByteArray: compressed_data_size=270906 data_size=354128, decompressed_data_size=354128 diff=0
[09:49:47] - Digital signature verified
[09:49:47]
[09:49:47] Project: 10722 (Run 0, Clone 1319, Gen 6)
[09:49:47]
[09:49:47] Assembly optimizations on if available.
[09:49:47] Entering M.D.
[09:49:54] Mapping NT from 1 to 1
[09:49:54] Completed 0 out of 7000000 steps  (0%)
[12:25:48] - Autosending finished units... [October 3 12:25:48 UTC]
[12:25:48] Trying to send all finished work units
[12:25:48] + No unsent completed units remaining.
[12:25:48] - Autosend completed
[13:06:48] Completed 70000 out of 7000000 steps  (1%)
[16:24:40] Completed 140000 out of 7000000 steps  (2%)
[18:25:48] - Autosending finished units... [October 3 18:25:48 UTC]
[18:25:48] Trying to send all finished work units
[18:25:48] + No unsent completed units remaining.
[18:25:48] - Autosend completed
[20:18:09] Completed 210000 out of 7000000 steps  (3%)
[23:45:10] Completed 280000 out of 7000000 steps  (4%)
[00:25:48] - Autosending finished units... [October 4 00:25:48 UTC]
[00:25:48] Trying to send all finished work units
[00:25:48] + No unsent completed units remaining.
[00:25:48] - Autosend completed
[00:25:48] Received EVENT= from OS -- shutting down w/ INTERRUPTED signal; events=[CtrlC= Close= Break= Shutdown= LogOff=]
[00:25:48] Folding@home Core Shutdown: INTERRUPTED
[00:25:51] CoreStatus = 66 (102)
[00:25:51] + Shutdown requested by user. Exiting.***** Got a SIGTERM signal (2)
[00:25:51] Killing all core threads
Bozo
 
Posts: 18
Joined: Mon Oct 03, 2011 10:12 pm

Re: Had to delete a WU, advice on settings please

Postby gwildperson » Wed Oct 05, 2011 1:06 pm

Please consult the Project Summaryand look up that project. You will see that it has a Preferred Deadline of 32.00, a Final Deadline of 56.00, and it'is worth 2244.00 points. Becaise it has a nonzero KFactor, it potentially earns a bonus over and above the 2244 pomts.
gwildperson
 
Posts: 744
Joined: Tue Dec 04, 2007 8:36 pm

Re: Had to delete a WU, advice on settings please

Postby Bozo » Wed Oct 05, 2011 1:31 pm

Thats a usefull page :)

i think I got my deadline info from either unit info in the FAH directory or FAH Monitor that I downloaded just to keep an eye on things.

Looks like I may have been premature in deleting unit. Lesson learnt.
I had the text from the best practice guide in mind where it advises to delete unit if it wont finish on time (holds up the science and will be useless) and i wasn't relishing running my pc for hours extra and spend a month on something for no points.

Will have to re-read the section on bonuses - must admit I skimmed it but it went right over my head. At least I did get myself a passkey just in case.
Bozo
 
Posts: 18
Joined: Mon Oct 03, 2011 10:12 pm

Re: Had to delete a WU, advice on settings please

Postby gwildperson » Wed Oct 05, 2011 2:27 pm

You have to complete 10 qualifying WUs using the passkey before the bonus is actually accrued. You can use that time to re-read the FAQ.

In simple terms, completing certain WUs before the Preferred Deadline can earn a significant bonus and the bonus increases depending on how much you beat the deadline.
gwildperson
 
Posts: 744
Joined: Tue Dec 04, 2007 8:36 pm

Re: Had to delete a WU, advice on settings please

Postby Zagen30 » Wed Oct 05, 2011 4:24 pm

The percentage completed messages do not correlate with checkpoints. If you turned the verbosity of the client (how much stuff it writes to the log file) up to its max setting you'd see the client writing checkpoints every 15 minutes (or however often you set checkpoints), and that a checkpoint is not written right when the WU gets to the next percentage completed, so there's no need to wait for it to get to the next % before closing it. The default verbosity level doesn't show the checkpoint writing to avoid clutter.

The general gist of the bonus is that you get extra points for turning it in before the preferred deadline. The more time left between submission and the PD, the larger bonus you get, and the bonus is calculated nonlinearly to further encourage very fast turnaround times.
Image
Zagen30
 
Posts: 1798
Joined: Tue Mar 25, 2008 12:45 am

Re: Had to delete a WU, advice on settings please

Postby Bozo » Wed Oct 05, 2011 10:26 pm

I did have the verbosity set (9) and for the other workunits it always showed the checkpoints. just didn't display for this unit for some reason hence my reluctance to switch off. i didn't change the settings and when run first time had accepted the default (15 mins).

anyway I have now completed another unit (68 points) and am working on another (69)
shoud I add -advmethods flag in or just leave running as is?

thanks for giving me a quick lowdown on bonus 8-)
Bozo
 
Posts: 18
Joined: Mon Oct 03, 2011 10:12 pm


Return to Windows Classic V6.23 Client

Who is online

Users browsing this forum: No registered users and 1 guest