Stuck at connecting

Moderators: Site Moderators, FAHC Science Team

Stuck at connecting

Postby iceman1992 » Tue Sep 18, 2012 7:24 am

Brand new ubuntu 12.04 installation on VMWare player, installed fahclient, fahcontrol, and fahviewer 7.1.52..
I started fahcontrol, and it stays at "Client: local Connecting Inactive".. What do I do?
iceman1992
 
Posts: 527
Joined: Fri Mar 23, 2012 6:16 pm

Re: Stuck at connecting

Postby Jesse_V » Tue Sep 18, 2012 7:33 am

Make sure the option to autostart the client is checked under the Preferences window.
F@h is now the top computing platform on the planet and nothing unites people like a dedicated fight against a common enemy. This virus affects all of us. Lets end it together.
Jesse_V
Site Moderator
 
Posts: 2851
Joined: Mon Jul 18, 2011 5:44 am
Location: Western Washington

Re: Stuck at connecting

Postby iceman1992 » Tue Sep 18, 2012 7:37 am

oh right.. thanks! I unchecked it, I thought it was an option to start the client on boot..
iceman1992
 
Posts: 527
Joined: Fri Mar 23, 2012 6:16 pm

Re: Stuck at connecting

Postby Jesse_V » Tue Sep 18, 2012 3:06 pm

iceman1992 wrote:oh right.. thanks! I unchecked it, I thought it was an option to start the client on boot..

I made a similar mistake a few days ago, it's all good. :)
Jesse_V
Site Moderator
 
Posts: 2851
Joined: Mon Jul 18, 2011 5:44 am
Location: Western Washington

Re: Stuck at connecting

Postby iceman1992 » Tue Sep 18, 2012 5:01 pm

I noticed something that may be a bug.. When I installed fahclient, the installer asked for my username, team number, and passkey.. But then when I start fahcontrol, my username/team/passkey is Anonymous/0/blank..

That happened too when I installed fah on ubuntu virtualbox..
iceman1992
 
Posts: 527
Joined: Fri Mar 23, 2012 6:16 pm

Re: Stuck at connecting

Postby 7im » Tue Sep 18, 2012 5:19 pm

Jesse_V wrote:Make sure the option to autostart the client is checked under the Preferences window.



This may work in Windows, but has nothing to do with Linux. In Linux, the fahclient is run as a service, and starts at boot automatically.

Also, the autostart box in preferences is unchecked by default, as it doesn't apply.

I've installed on several VMs, and have not had a problem getting the user name, etc. passed from the .DEB package installer to the client.

How exactly did you install fah?
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 10189
Joined: Thu Nov 29, 2007 5:30 pm
Location: Arizona

Re: Stuck at connecting

Postby iceman1992 » Tue Sep 18, 2012 5:31 pm

7im wrote:In Linux, the fahclient is run as a service, and starts at boot automatically.
My fah client is not installed as a service, I unchecked the autostart option during installation..

7im wrote:How exactly did you install fah?
Downloaded the file, then ran it, which brought up ubuntu software center, and I clicked install
iceman1992
 
Posts: 527
Joined: Fri Mar 23, 2012 6:16 pm

Re: Stuck at connecting

Postby 7im » Tue Sep 18, 2012 6:02 pm

My mistake. I hadn't seen the new option to not autostart that Joe added. And I can confirm it is broken. When you don't autostart, the user info isn't passed through to the config. Client starts as Anonymous on team 0. New ticket is imminent.

#933 - User info not passed to config when no autostart in Ubuntu from .DEB package
User avatar
7im
 
Posts: 10189
Joined: Thu Nov 29, 2007 5:30 pm
Location: Arizona

Re: Stuck at connecting

Postby iceman1992 » Tue Sep 18, 2012 6:27 pm

Okay thanks :D
iceman1992
 
Posts: 527
Joined: Fri Mar 23, 2012 6:16 pm


Return to V7.1.52 Windows/Linux

Who is online

Users browsing this forum: No registered users and 0 guests

cron