HD 5450 never starts folding- fails

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

Re: HD 5450 never starts folding- fails

Postby Om_Audio » Mon Dec 02, 2013 1:51 am

Thanks for the great info. I will use the bug reporting feature as I was not aware of it and post back. I will sign up for beta too if that could help development.

PS- I do not see any bug reporting option in web or advanced control, can you point it out to me? Thanks.
****NM found it in far upper right of web control- thx
Posts: 19
Joined: Sun Aug 11, 2013 10:23 pm

Re: HD 5450 never starts folding- fails

Postby bruce » Mon Dec 02, 2013 2:14 am

Look for the "bug" icon in web control. (Upper right)
Posts: 20884
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: HD 5450 never starts folding- fails

Postby Om_Audio » Mon Dec 02, 2013 2:16 am

Bug report after I started client and let it sit until GPU slot failed:
http://folding.stanford.edu/bugs/9c70a0 ... 93ffc.html
Posts: 19
Joined: Sun Aug 11, 2013 10:23 pm

Re: HD 5450 never starts folding- fails

Postby Curious » Mon Dec 02, 2013 3:26 pm

bruce wrote:Certainly overclocking, bad drivers, bad power and/or too much heat can cause instability, but they're not the only possibilities. I've seen at least three theories.
3) GPU memory is filling up.

Theory 3 is similar but problems with VRAM allocation may not be properly managed.

In a topic (post #87 bearing date Saturday, June 22, 2013 11:58 AM) PantherX addressed to me responding to my answers a user said he solved his problems on a Fermi card (nVidia GeForce GTX 560 Ti, Win7 64 bit Service Pack 1 - fully up to date, driver 320.18) by downclocking the video card's memory: 20 MHz below stock frequency. His problem began with 8900s WU but he completed earlier WU. Another user (he also had problems with 8900 WUs) solved the same problems on a Titan (not specified his model) in the same way. Once he solved this issues he overclocked his card (mantaining stock voltage) and had no problem.

Their error messages are:
WU##:FS00:0x17:ERROR:exception: Error invoking kernel execFFT: clEnqueueNDRangeKernel (-5)
WU##:FS00:0x17:ERROR:exception: Error invoking kernel gridInterpolateForce: clEnqueueNDRangeKernel (-5)
WU##:FS00:0x17:ERROR:exception: Error invoking kernel calcCenterOfMassMomentum: clEnqueueNDRangeKernel (-5) - ##% completed
WU##:FS00:0x17:ERROR:exception: Error invoking kernel copyDataToBuckets: clEnqueueNDRangeKernel (-5) ##% completed

The first user i mentioned above said he had problems with installation of .NET and with overheating, in addition his system was overclocked. So probabily some of these error messages were due to reason different from the ones you try to understand, but probably error 5 (and error 55 which generate a similar message) is related to clock frequency.

I had problems with 8900 WUs too (moreover every GPU FAH bench i did gave a crash immediately after memory and clock frequency reached their max values, that is immediately after the beginning of the benchmark); so i lowered the memory frequency with MSI Afterburner on my Mobility Radeon HD 5430 in a HP G series notebook (-10, -15, -20, -100 MHz), but this didn't solved the problem, seems my hardware isn't good enough for this kind of work. Hope this will be the solution for Om_Audio who encountered the same error code as mine, Error invoking kernel execFFT: clEnqueueNDRangeKernel (-55), although our two systems are similar (Intel i3 CPU, Cedar GPU, 13.9 Catalyst driver, error -55), but his hardware is better looking at PassMark Software charts, so maybe he has more chances.
Last edited by Curious on Thu Jan 23, 2014 10:51 am, edited 1 time in total.
Posts: 6
Joined: Fri Nov 15, 2013 9:13 pm

Re: HD 5450 never starts folding- fails

Postby prjindigo » Sun Jan 05, 2014 6:44 am

Check firmware version of GPU, it may not be compatible with current OpenCL. Early HD 5000 cards supported the same outdated version as the HD 4000 and will not work.
Posts: 31
Joined: Wed Mar 30, 2011 8:49 am

Re: HD 5450 never starts folding- fails

Postby Om_Audio » Sun Jan 05, 2014 8:19 am

I have since upgraded slightly to a HD6450 and have not tried folding. how do I know if a FW ver is incompatible with OpenCL? A little over my head. Thanks for the reply.
Posts: 19
Joined: Sun Aug 11, 2013 10:23 pm

Re: HD 5450 never starts folding- fails

Postby Curious » Wed Jan 22, 2014 10:29 am

Looking at this Khronos site's page we find out that 5400 series graphics cards support OpenCL v1.1 but require ATI Stream SDK v2.3 (ATI Stream changed name in AMD APP, latest version is 2.9) and in this AMD site Developer section's page is shown that ATI Catalyst™ 10.12 (8.801) are recommended for 5400 series. Although the latter are still available in the internet (but not in the AMD site), the former are not: only v2.6 to v2.9 are available for download in the AMD site, Developer section. So shall we install a later version of SDK, like v2.6, and give it a try?
Posts: 6
Joined: Fri Nov 15, 2013 9:13 pm

Re: HD 5450 never starts folding- fails

Postby Om_Audio » Wed Jan 22, 2014 12:13 pm

For the record I have since upgraded yet again to a newer ATI R7 240 card but would still be willing to test if needed. I may have a spare machine to put the 5450 or 6450 in for FAH testing to help development. I am currently (for the past couple of years in fact) only folding on my 24/7 win xp laptop with a core2duo T5200 in it but at least I am folding. :)
Posts: 19
Joined: Sun Aug 11, 2013 10:23 pm

Re: HD 5450 never starts folding- fails

Postby Curious » Wed Jan 22, 2014 12:41 pm

If you'll give it a try with the 5450, please report here the results because i'm interested in it. But i think without the right combination of SDK and Catalyst driver it will be a sure fail.

I've installed 10.12 and v2.3 (included in Catalyst suite) and found out FAHBench doesn't start: immediately after double clicking on its icon appear for a fraction of second the command prompt then immediately disappear and FAHBench doesn't start. I've tried folding but i get bad work unit (like with later driver) and a new error message (which didn't appear with later driver) FS00:0x17:ERROR:Win32: 0xc0000005: Exception access violation. Even CPU doesn't start folding, although is shown running in folding slot status column.

Moreover when i start GPU-Z i get this error message: ATI OpenCL driver bug detected, skipping OpenCL detection. Uninstall the AMD Stream SDK / OpenCL driver to re-enable this functionality. Seems the fault is on SDK's side this time.

Code: Select all
*********************** Log Started 2014-01-22T15:08:48Z ***********************
15:08:48:************************* Folding@home Client *************************
15:08:48:      Website: http://folding.stanford.edu/
15:08:48:    Copyright: (c) 2009-2013 Stanford University
15:08:48:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
15:08:48:         Args: --open-web-control
15:08:48:       Config: C:/Users/Luca/AppData/Roaming/FAHClient/config.xml
15:08:48:******************************** Build ********************************
15:08:48:      Version: 7.3.6
15:08:48:         Date: Feb 18 2013
15:08:48:         Time: 15:25:17
15:08:48:      SVN Rev: 3923
15:08:48:       Branch: fah/trunk/client
15:08:48:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
15:08:48:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
15:08:48:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
15:08:48:     Platform: win32 XP
15:08:48:         Bits: 32
15:08:48:         Mode: Release
15:08:48:******************************* System ********************************
15:08:48:          CPU: Intel(R) Core(TM) i3 CPU M 350 @ 2.27GHz
15:08:48:       CPU ID: GenuineIntel Family 6 Model 37 Stepping 2
15:08:48:         CPUs: 4
15:08:48:       Memory: 3.87GiB
15:08:48:  Free Memory: 2.49GiB
15:08:48:      Threads: WINDOWS_THREADS
15:08:48:  Has Battery: true
15:08:48:   On Battery: false
15:08:48:   UTC offset: 1
15:08:48:          PID: 1104
15:08:48:          CWD: C:/Users/Luca/AppData/Roaming/FAHClient
15:08:48:           OS: Windows 7 Home Premium
15:08:48:      OS Arch: AMD64
15:08:48:         GPUs: 1
15:08:48:        GPU 0: ATI:4 ManhattanP [AMD Radeon HD 6230]
15:08:48:         CUDA: Not detected
15:08:48:Win32 Service: false
15:08:48:  <!-- Folding Slot Configuration -->
15:08:48:  <power v='full'/>
15:08:48:  <!-- Folding Slots -->
15:08:48:  <slot id='0' type='GPU'/>
15:08:48:  <slot id='1' type='CPU'/>
15:08:48:Trying to access database...
15:08:48:Successfully acquired database lock
15:08:48:Enabled folding slot 00: READY gpu:0:ManhattanP [AMD Radeon HD 6230]
15:08:48:Enabled folding slot 01: READY cpu:3
15:08:48:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Luca/AppData/Roaming/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 00 -suffix 01 -version 703 -lifeline 1104 -checkpoint 15 -np 3
15:08:48:WU00:FS01:Started FahCore on PID 660
15:08:48:WU00:FS01:Core PID:4048
15:08:48:WU00:FS01:FahCore 0xa4 started
15:08:49:WU01:FS00:Connecting to assign-GPU.stanford.edu:80
15:08:49:WU00:FS01:0xa4:Folding@Home Gromacs GB Core
15:08:49:WU00:FS01:0xa4:Version 2.27 (Dec. 15, 2010)
15:08:49:WU00:FS01:0xa4:Preparing to commence simulation
15:08:49:WU00:FS01:0xa4:- Looking at optimizations...
15:08:49:WU00:FS01:0xa4:- Files status OK
15:08:49:WU00:FS01:0xa4:- Expanded 629327 -> 868872 (decompressed 138.0 percent)
15:08:49:WU00:FS01:0xa4:Called DecompressByteArray: compressed_data_size=629327 data_size=868872, decompressed_data_size=868872 diff=0
15:08:49:WU00:FS01:0xa4:- Digital signature verified
15:08:49:WU00:FS01:0xa4:Project: 7812 (Run 2140, Clone 0, Gen 27)
15:08:49:WU00:FS01:0xa4:Assembly optimizations on if available.
15:08:49:WU00:FS01:0xa4:Entering M.D.
15:08:50:WU01:FS00:News: Welcome to Folding@Home
15:08:50:WU01:FS00:Assigned to work server
15:08:50:WU01:FS00:Requesting new work unit for slot 00: READY gpu:0:ManhattanP [AMD Radeon HD 6230] from
15:08:50:WU01:FS00:Connecting to
15:08:51:WU01:FS00:Downloading 4.18MiB
15:08:55:WU00:FS01:0xa4:Mapping NT from 3 to 3
15:08:55:3: Web connection
15:08:57:WU01:FS00:Download 13.47%
15:08:57:WU00:FS01:0xa4:Completed 0 out of 500000 steps  (0%)
15:09:02:WARNING:Exception: 8: Send error: 10053: Connessione interrotta dal software del computer host.
15:09:04:WU01:FS00:Download 25.45%
15:09:11:WU01:FS00:Download 31.44%
15:09:17:WU01:FS00:Download 38.92%
15:09:24:WU01:FS00:Download 44.91%
15:09:30:WU01:FS00:Download 53.89%
15:09:36:WU01:FS00:Download 62.87%
15:09:44:WU01:FS00:Download 68.86%
15:09:50:WU01:FS00:Download 74.85%
15:09:56:WU01:FS00:Download 79.34%
15:10:02:WU01:FS00:Download 83.83%
15:10:08:WU01:FS00:Download 89.82%
15:10:15:WU01:FS00:Download 97.30%
15:10:16:WU01:FS00:Download complete
15:10:16:WU01:FS00:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:8900 run:577 clone:5 gen:54 core:0x17 unit:0x00000056028c126651a6a7196e767050
15:10:17:WU01:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Luca/AppData/Roaming/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_17.fah/FahCore_17.exe -dir 01 -suffix 01 -version 703 -lifeline 1104 -checkpoint 15 -gpu 0 -gpu-vendor ati
15:10:17:WU01:FS00:Started FahCore on PID 584
15:10:17:WU01:FS00:Core PID:3848
15:10:17:WU01:FS00:FahCore 0x17 started
15:10:17:WU01:FS00:0x17:*********************** Log Started 2014-01-22T15:10:17Z ***********************
15:10:17:WU01:FS00:0x17:Project: 8900 (Run 577, Clone 5, Gen 54)
15:10:17:WU01:FS00:0x17:Unit: 0x00000056028c126651a6a7196e767050
15:10:17:WU01:FS00:0x17:CPU: 0x00000000000000000000000000000000
15:10:17:WU01:FS00:0x17:Machine: 0
15:10:17:WU01:FS00:0x17:Reading tar file state.xml
15:10:23:WU01:FS00:0x17:Reading tar file system.xml
15:10:26:WU01:FS00:0x17:Reading tar file integrator.xml
15:10:26:WU01:FS00:0x17:Reading tar file core.xml
15:10:26:WU01:FS00:0x17:Digital signatures verified
15:10:26:WU01:FS00:0x17:Folding@home GPU core17
15:10:26:WU01:FS00:0x17:Version 0.0.52
15:10:26:WU01:FS00:0x17:ERROR:Win32: 0xc0000005: Exception access violation
15:10:26:WU01:FS00:0x17:Saving result file logfile_01.txt
15:10:26:WU01:FS00:0x17:Saving result file log.txt
15:10:26:WU01:FS00:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
15:10:26:WARNING:WU01:FS00:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
15:10:26:WU01:FS00:Sending unit results: id:01 state:SEND error:FAULTY project:8900 run:577 clone:5 gen:54 core:0x17 unit:0x00000056028c126651a6a7196e767050
15:10:26:WU01:FS00:Uploading 1.67KiB to
15:10:26:WU01:FS00:Connecting to
15:10:26:WU02:FS00:Connecting to assign-GPU.stanford.edu:80
15:10:27:WU02:FS00:News: Welcome to Folding@Home
15:10:27:WU02:FS00:Assigned to work server
15:10:27:WU02:FS00:Requesting new work unit for slot 00: READY gpu:0:ManhattanP [AMD Radeon HD 6230] from
15:10:27:WU02:FS00:Connecting to
15:10:28:WU02:FS00:Downloading 4.18MiB
15:10:29:WU01:FS00:Upload complete
15:10:29:WU01:FS00:Server responded WORK_ACK (400)
15:10:29:WU01:FS00:Cleaning up
15:10:34:WU02:FS00:Download 14.96%
15:10:40:WU02:FS00:Download 25.43%

I've also tried latest SDK (2.9) with the driver version specified for it but no success at all with FAHBench: Error invoking kernel execFFT: clEnqueueNDRangeKernel (-55). Surfing the internet i've found out error code -55 is refferred to as invalid work item size, this is Khronos page with more details but i haven't enough knowledge so i get nowhere fast.
Last edited by Curious on Fri Jan 24, 2014 11:53 am, edited 2 times in total.
Posts: 6
Joined: Fri Nov 15, 2013 9:13 pm

Re: HD 5450 never starts folding- fails

Postby bruce » Thu Jan 23, 2014 8:04 pm

I have a 5450 which I did get to work, though I have no memory of driver version / SDK version. I never used it very much. As far as folding was concerned, it was terribly slow and allocating a CPU to it caused a bigger points loss to SMP than I gained by folding with the GPU. I was ready to try it again since I have a spare slot on a Linux system, but couldn't get it to play nice with the AMD that's in that system.

If you do find a good use for it, I'd like to hear about it.
Posts: 20884
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: HD 5450 never starts folding- fails

Postby Curious » Fri Jan 24, 2014 12:04 pm

I'm going to try SDK v2.4 with the driver version specified for it, after having disabled hardware acceleration in Chrome, IE and AMD CCC (can't disable on operative system side since it is Win 7). Hope to have some good news soon.

I don't expect much from it because my CPU too is low level and take several days of continuous work for completing a WU, so will do the GPU if it will start folding; i'm not concerned about point since my hardware is really entry level.

If ever you will remember something about your 5000 series configuration please write it here, it may be useful for me.

Hope to have good news soon.

No success at all with 2.4 and 2.5 (driver reccomended: 11.4 and 11.7): started FAH Bench with Implicit only and the display immediately freezed, but the driver haven't been restored, after a few minutes of patience with fan spinning fast but no response from the display i've rebooted through the power button. I suppose the only way to follow is to try all the combination of SDK and Catalyst reccomended in the AMD developer site.
Catalyst 11.12 and 12.4 installers (driver version reccomended for SDK version 2.6 and 2.7) don't show 2.6 and 2.7 in the install list but there is AMD APP SDK Runtime (v.10.0.831.4 and v.10.0.923.1). With 11.12 installed FAHBench crashed but, unlike with 11.4 and 11.7, the dispaly driver was restored and no manual reboot was needed: seems this happen only from 11.12 onward. I didn't gave it a try with 12.4, 12.10 and 13.6 beta v2 (reccomended for SDK 2.7, 2.8 and 2.8.1). 13.11 beta with 2.9 installed separately (not through Catalyst, but using specific SDK v2.9 installer) didn't work.

I wonder if i should try also SDK versions earlier than 2.3, the one that Khronos page suggest to use with Mobility 5000 series.
Posts: 6
Joined: Fri Nov 15, 2013 9:13 pm


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 1 guest