error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Moderators: Site Moderators, PandeGroup

Re: error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Postby tgarrett » Fri Mar 02, 2018 12:47 am

I'm having the exact same problems with "bad platformId size" on an RX 560, an RX 570, and an RX 580. I know my OpenCL is functional at some level because I mine cryptocurrency with these cards also.

All the threads I have seen on this topic revert to saying "get your drivers from AMD." I am on the latest official 17.50 drivers with Ubuntu 16.04, which is an officially supported platform per AMD.

I am a programmer myself, and I suspect the problem lies in a bad interpretation of OpenCL platform information by the F@H client/core. I just haven't had any time to dig deeper. For now, I'm mining on all my GPUs and folding on my CPU.
tgarrett
 
Posts: 1
Joined: Fri Feb 23, 2018 1:10 pm

Re: error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Postby bruce » Sat Mar 03, 2018 6:17 am

There are a number of topics on this forum with the error "bad platformId size." Many of these topics include things that have been done to solve the issues. In fact, quite a few mention 16.04 where a re-installation of cllib seems to be a key step. I'm not sufficiently knowledgeable in how the executable locates the proper library, but that's very likely the problem.
bruce
 
Posts: 21402
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Postby lacuzon » Wed Mar 07, 2018 10:05 am

Searching "bad platformId size" points to 12 pages of resulsts. Have you some links to share ?

I'm still wondering if anyone is successfully folding with a AMD RX580 on Linux ?
lacuzon
 
Posts: 10
Joined: Sat Feb 17, 2018 2:02 pm

Re: error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Postby bruce » Wed Mar 07, 2018 5:42 pm

lacuzon wrote:I'm still wondering if anyone is successfully folding with a AMD RX580 on Linux ?

I don't know any way to tell unless somebody with one replies.
Searching "bad platformId size" points to 12 pages of resulsts. Have you some links to share?
The problem has been solved by re-installation of software, not by avoiding a particular GPU.
bruce
 
Posts: 21402
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: error "Bad work unit" with AMD RX580 + Ubuntu 16.04

Postby Viper666 » Sun Mar 25, 2018 9:06 pm

you have to install AMD GPU Pro from AMD's web site, it provide opencl support, the linux free drivers will not work on FAH, the latest driver also has rocm support you dont want rocm, just opencl


instruction https://support.amd.com/en-us/kb-articles/Pages/Installation-Instructions-for-amdgpu-Graphics-Stacks.aspx Install the Complete Graphics and Compute stack

./amdgpu-pro-install -y --opencl=legacy
the above is the proper command,

driver https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.50-511655.tar.xz
ImageImage
Powered by AMD and Open SUSe 11.2 ----The New servers have nothing to do with fixing the stats problem !
User avatar
Viper666
 
Posts: 223
Joined: Fri Dec 14, 2007 9:57 pm

Previous

Return to V7.4.4 Public Release Windows/Linux/MacOS X (deprecated)

Who is online

Users browsing this forum: No registered users and 1 guest

cron