opencl-index=-1

Moderators: Site Moderators, PandeGroup

Re: opencl-index=-1

Postby DocJonz » Sun Jun 10, 2018 3:06 pm

Strange - it was complete enough to Fold on the GPUs, but not complete enough for the log file to be correct ...

I set up a new install of Ubuntu 18.04 LTS, and the drivers were from the Ubuntu graphics-drivers PPA (sudo add-apt-repository ppa:graphics-drivers/ppa), and running the proprietary nVidia 396 driver. (I've been using this repository for nVidia drivers for Folding for a number of years).
User avatar
DocJonz
 
Posts: 355
Joined: Thu Dec 06, 2007 6:31 pm
Location: United Kingdom

Re: opencl-index=-1

Postby bollix47 » Sun Jun 10, 2018 4:17 pm

I experienced much the same thing after an update on 18.04 that included numerous nvidia software and I was also using the same ppa. i.e. opencl stopped working properly.
Reinstalling ocl-icd-opencl-dev fixed it up for me too. :ewink:

I now do not use that ppa but after a clean install of 18.04 I just install the drivers (currently 390) from Software & Updates > Additional Drivers and after a reboot I install ocl-icd-opencl-dev before I install the folding software. Hopefully the normal repositories updates won't cause the same mess that the additional repository did although I'm sure they will fix that soon.
bollix47
 
Posts: 3470
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: opencl-index=-1

Postby DocJonz » Sun Jun 10, 2018 4:38 pm

Interesting experience about the driver ppa - I'll make a note of that.
Anyway, this was the first machine to transition to Ubuntu 18.04, so I installed it on a test machine. Now everything seems to be up and running as it should be that means, when I transition all the other Linux Folding machines, the process should be a piece of cake :D
User avatar
DocJonz
 
Posts: 355
Joined: Thu Dec 06, 2007 6:31 pm
Location: United Kingdom

Re: opencl-index=-1

Postby rogeryoung » Mon Jun 11, 2018 12:34 am

I am new to folding like 2 days and I got things running but web browser keeps blinking in and out and I get open cl error for both web and Advanced control so its kind of pointless for me fold if all i get is error and the forums don't even know what to do.
rogeryoung
 
Posts: 1
Joined: Sat Jun 09, 2018 4:23 pm

Re: opencl-index=-1

Postby Joe_H » Mon Jun 11, 2018 4:01 pm

rogeryoung wrote:I am new to folding like 2 days and I got things running but web browser keeps blinking in and out and I get open cl error for both web and Advanced control so its kind of pointless for me fold if all i get is error and the forums don't even know what to do.


Welcome to the folding support forum.

Actually, members of the forum do know what to do about most errors, in this case a complete install of OpenCL support is required. The details change depending on which OS is being used, and in the case of Linux, which version and distro.

If you could post the details of your system and the specific errors you see in a new topic, you should get suggestions on how to correct the problems. The Welcome to the Forum topic has information on what information is needed and how to post it.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 4391
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: opencl-index=-1

Postby Aurum » Sat Sep 29, 2018 11:02 pm

[quote="bollix47"]@DocJonz
Open a terminal and try the following after which restart the client and see if the opencl lines look better:
Code: Select all
sudo apt install ocl-icd-opencl-dev
Thanks bollix47. That seems to have fixed my problem as well. I just did new install of Linux 19 Mint Tara with latest 396.54 Nvidia drivers. When I installed by double clicking fahclient_7.5.1_amd64.deb & fahcontrol_7.5.1-1_all.deb it said it needed to also install 24 packages. I'm a Linux neophyte but maybe it does not identify the correct dependencies.
BOINC is Better!!! Image
User avatar
Aurum
 
Posts: 301
Joined: Sat Oct 03, 2015 3:15 pm
Location: The Great Basin

Re: opencl-index=-1

Postby Theodore » Fri Mar 01, 2019 12:43 pm

I think this post should be a sticky.
In my time here, I've needed it 3x; and seen 2 others ask for this.
Theodore
 
Posts: 74
Joined: Sun Feb 10, 2019 2:07 pm

Re: opencl-index=-1

Postby Vester » Thu Mar 07, 2019 11:36 pm

Concur that this topic should be a sticky. I spent hours last week trying to install FAH on Ubuntu, OpenSUSE, and Fedora.
Vester
 
Posts: 37
Joined: Sun Dec 02, 2007 4:29 pm
Location: Fair Play, SC

Re: opencl-index=-1

Postby MeeLee » Fri Mar 08, 2019 5:47 am

I wonder why they don't add it by default in the installation (.deb) file?
MeeLee
 
Posts: 84
Joined: Tue Feb 19, 2019 10:16 pm

Re: opencl-index=-1

Postby bruce » Fri Mar 08, 2019 5:27 pm

MeeLee wrote:I wonder why they don't add it by default in the installation (.deb) file?


The FAH installer probably should install OpenCL if it's not present, but that would only work when you're doing an install. At least in Windows, there's already a pending bug report wondering what FAH should do about Microsoft's policy of UNinstalling OpenCL whenever they update the NVidia drivers.
bruce
 
Posts: 22116
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Previous

Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 1 guest

cron