Ubuntu 18.04 / 16.04 with AMD Rx 570s

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 9:29 am

I have had no success with getting my 6 AMD Radeon RX 570's to do anything useful with the folding at home client on linux. I have tried several versions of the amd drivers and 2 versions of ubuntu linux. This machine was originally an ethereum mining rig, and the claymore miner works just fine using the cards, while FAH doesn't seem to do much at all, just complain about a missing OpenCL device. Not sure what else to do here, it feels like the card drivers were properly installed, since claymore is working, so either FAH just doesn't work with this hardware / driver combination for some reason -- Or I am missing something obvious. It sure would be a shame to not be able to repurpose this mining rig for folding.
Code: Select all
09:15:23:WU01:FS01:FahCore 21: Downloading 3.23MiB
09:15:24:WU01:FS01:FahCore 21: Download complete
09:15:24:WU01:FS01:Valid core signature
09:15:24:WU01:FS01:Unpacked 7.94MiB to cores/cores.foldingathome.org/Linux/AMD64/ATI/R600/Core_21.fah/FahCore_21
09:15:24:WU01:FS01:Starting
09:15:24:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
09:15:24:WU01:FS01:Starting
09:15:24:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
09:16:25:WU01:FS01:Starting
09:16:25:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
^C
john@folder:~$ ls
amdgpu-pro-18.50-708488-ubuntu-18.04         Desktop    Downloads                  fahcontrol_7.5.1-1_all.deb  Music     Public     Videos
amdgpu-pro-18.50-708488-ubuntu-18.04.tar.xz  Documents  fahclient_7.5.1_amd64.deb  fahviewer_7.5.1_amd64.deb   Pictures  Templates
john@folder:~$ cat /etc/fahclient/config.xml
<config>
  <!-- Client Control -->
  <fold-anon v='true'/>

  <!-- Folding Slot Configuration -->
  <gpu v='true'/>

  <!-- Slot Control -->
  <power v='full'/>

  <!-- User Information -->
  <passkey v='XXXXXXXXXXXXX'/>
  <team v='XXXXX'/>
  <user v='XXXXX'/>

  <!-- Folding Slots -->
  <slot id='0' type='CPU'/>
  <slot id='1' type='GPU'/>
</config>
john@folder:~$ /etc/init.d/FAHClient log
09:15:24:WU01:FS01:FahCore 21: Download complete
09:15:24:WU01:FS01:Valid core signature
09:15:24:WU01:FS01:Unpacked 7.94MiB to cores/cores.foldingathome.org/Linux/AMD64/ATI/R600/Core_21.fah/FahCore_21
09:15:24:WU01:FS01:Starting
09:15:24:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
09:15:24:WU01:FS01:Starting
09:15:24:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
09:16:25:WU01:FS01:Starting
09:16:25:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually
09:17:34:WU00:FS00:0xa7:Completed 7500 out of 250000 steps (3%)
^C
user@folder:~$ ls
amdgpu-pro-18.50-708488-ubuntu-18.04         Desktop    Downloads                  fahcontrol_7.5.1-1_all.deb  Music     Public     Videos
amdgpu-pro-18.50-708488-ubuntu-18.04.tar.xz  Documents  fahclient_7.5.1_amd64.deb  fahviewer_7.5.1_amd64.deb   Pictures  Templates
Last edited by NullPtrException on Sat Jan 05, 2019 4:44 pm, edited 1 time in total.
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby ProDigit » Sat Jan 05, 2019 12:49 pm

Does it work on WIndows?
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby bruce » Sat Jan 05, 2019 4:09 pm

To use any GPU, FAH requires OpenCL drivers. Sometimes they're installed when you install the video drivers; sometimes not. Occasionally (rarely), they'll already be installed with the OS. Sometimes you'll need to install the OpenCL developer package for your OS.

(Unfortunately the message about setting 'opencl-index' manually is misleading.)
bruce
 
Posts: 22146
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 4:46 pm

ProDigit wrote:Does it work on WIndows?

I can take any of my cards and plug them into a windows machine, and it works fine. I have 4 570s on 2 different windows boxes running just fine. Now to get this working on linux. I have pulled a single card onto another linux machine just trying to get it working to simplify things.
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 4:51 pm

bruce wrote:To use any GPU, FAH requires OpenCL drivers. Sometimes they're installed when you install the video drivers; sometimes not. Occasionally (rarely), they'll already be installed with the OS. Sometimes you'll need to install the OpenCL developer package for your OS.

(Unfortunately the message about setting 'opencl-index' manually is misleading.)


So, I don't see anyone talking about how to install opencl after installing the amd-radeon drivers. There are shitload of package files that the amdgpu-pro install puts on the machine, several with opencl in the name, I would think that opencl support has been added:

Code: Select all
john@folder:~/amdgpu-pro-18.50-708488-ubuntu-18.04$ ls|grep opencl
libopencl1-amdgpu-pro_18.50-708488_amd64.deb
libopencl1-amdgpu-pro_18.50-708488_i386.deb
opencl-amdgpu-pro_18.50-708488_amd64.deb
opencl-amdgpu-pro-dev_18.50-708488_amd64.deb
opencl-amdgpu-pro-icd_18.50-708488_amd64.deb
opencl-orca-amdgpu-pro-icd_18.50-708488_amd64.deb
opencl-orca-amdgpu-pro-icd_18.50-708488_i386.deb
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 4:55 pm

I found mention of a clinfo util, which I installed via apt. I installed an openCL mesa icd package and that utility now works. FAH still doesn't work though.
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 4:57 pm

And it looks like FahCore_21 binary is properly pointed to an OpenCL lib on my system:

Code: Select all
john@folder:~/amdgpu-pro-18.50-708488-ubuntu-18.04$ ldd /var/lib/fahclient/cores/cores.foldingathome.org/Linux/AMD64/ATI/R600/Core_21.fah/FahCore_21
   linux-vdso.so.1 (0x00007ffed9f9a000)
   libOpenCL.so.1 => /opt/amdgpu-pro/lib/x86_64-linux-gnu/libOpenCL.so.1 (0x00007f0a73f7e000)
   libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f0a73d5f000)
   libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f0a73b5b000)
   librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f0a73953000)
   libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f0a735ca000)
   libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f0a7322c000)
   libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f0a73014000)
   libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f0a72c23000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f0a74185000)
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby bruce » Sat Jan 05, 2019 5:02 pm

When you add hardware, you need to do a clean reinstall of FAHClient so it repeats the hardware setup steps.
bruce
 
Posts: 22146
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 5:13 pm

bruce wrote:When you add hardware, you need to do a clean reinstall of FAHClient so it repeats the hardware setup steps.


Yeah, I have done that several times. Not adding new hardware on this machine, I just put a single card in it, and installed FAHclient. I just did it again for kicks. The config always comes up with just the CPU every time.

I did see this interesting tidbit in the system info, which I hadn't noticed before:

Code: Select all
OpenCL Not detected: clGetDeviceIDs() returned -1
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby bruce » Sat Jan 05, 2019 5:20 pm

Where did you get the drivers for that new card? Ubuntu'd default drivers don't support all of nVidia's features. Search for extra (proprietary) drivers. (Then reinstall FAHClient. Then post the first page of FAH's log.)
bruce
 
Posts: 22146
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby NullPtrException » Sat Jan 05, 2019 5:25 pm

bruce wrote:Where did you get the drivers for that new card? Ubuntu'd default drivers don't support all of nVidia's features. Search for extra (proprietary) drivers. (Then reinstall FAHClient)


I got them for the AMD website -- Pretty clear which ones you are supposed to install there. Driver install and re-install of FAHclient is not going to work. It should certainly be all that is required, I agree. I have definitely installed proprietary drivers and re-installed FAH over and over in different variations, trying different versions (older/newer) of the drivers and even different versions of the OS. Installing the drivers just isn't enough for FAH as far as I can tell. I don't think there is anything else for me to install.
NullPtrException
 
Posts: 7
Joined: Sat Jan 05, 2019 9:20 am

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby bollix47 » Sat Jan 05, 2019 5:26 pm

Try installing opencl:
Code: Select all
sudo apt install ocl-icd-opencl-dev

You might want to reboot the computer after doing the above in case FAHClient needs to restart.
This may not help but it won't hurt to try ... usually opencl is included with the driver that AMD offers but it's been a long time since I used an AMD GPU so they may have changed their bundling practice.
bollix47
 
Posts: 3474
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby ProDigit » Sun Jan 06, 2019 2:38 am

what version of Linux are you running? 32 or 64 bit?
I know some versions are supported, but the majority of Linux distributions aren't.
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby toTOW » Sun Jan 06, 2019 10:04 pm

bollix47's suggestion is often the solution to OpenCL issues on Linux ... ;)
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8644
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Ubuntu 18.04 / 16.04 with AMD Rx 570s

Postby acedogblast » Wed Jan 30, 2019 8:37 pm

Is there any update for this? I have an rx 470 with the amdgpu-pro 18.50 drivers with opencl installed. I am certain openCL does work as I have tested with clinfo, darktable, and blender but Folding@Home does not. Here is my log
Code: Select all
*********************** Log Started 2019-01-29T23:03:16Z ***********************
23:03:16:************************* Folding@home Client *************************
23:03:16:    Website: https://foldingathome.org/
23:03:16:  Copyright: (c) 2009-2018 foldingathome.org
23:03:16:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
23:03:16:       Args: --child --lifeline 897 /etc/fahclient/config.xml --run-as fahclient
23:03:16:             --pid-file=/var/run/fahclient.pid --daemon
23:03:16:     Config: /etc/fahclient/config.xml
23:03:16:******************************** Build ********************************
23:03:16:    Version: 7.5.1
23:03:16:       Date: May 11 2018
23:03:16:       Time: 19:59:04
23:03:16: Repository: Git
23:03:16:   Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
23:03:16:     Branch: master
23:03:16:   Compiler: GNU 6.3.0 20170516
23:03:16:    Options: -std=gnu++98 -O3 -funroll-loops
23:03:16:   Platform: linux2 4.14.0-3-amd64
23:03:16:       Bits: 64
23:03:16:       Mode: Release
23:03:16:******************************* System ********************************
23:03:16:        CPU: Intel(R) Celeron(R) CPU N3050 @ 1.60GHz
23:03:16:     CPU ID: GenuineIntel Family 6 Model 76 Stepping 3
23:03:16:       CPUs: 2
23:03:16:     Memory: 3.72GiB
23:03:16:Free Memory: 3.23GiB
23:03:16:    Threads: POSIX_THREADS
23:03:16: OS Version: 4.15
23:03:16:Has Battery: false
23:03:16: On Battery: false
23:03:16: UTC Offset: -5
23:03:16:        PID: 899
23:03:16:        CWD: /var/lib/fahclient
23:03:16:         OS: Linux 4.15.0-44-generic x86_64
23:03:16:    OS Arch: AMD64
23:03:16:       GPUs: 1
23:03:16:      GPU 0: Bus:2 Slot:0 Func:0 AMD:5 Ellesmere XT [Radeon RX 470/480/570/580]
23:03:16:       CUDA: Not detected: Failed to open dynamic library 'libcuda.so':
23:03:16:             libcuda.so: cannot open shared object file: No such file or
23:03:16:             directory
23:03:16:     OpenCL: Not detected: clGetPlatformIDs() returned -1001
23:03:16:***********************************************************************
23:03:16:<config>
23:03:16:  <!-- Client Control -->
23:03:16:  <fold-anon v='true'/>
23:03:16:
23:03:16:  <!-- User Information -->
23:03:16:  <team v='51238'/>
23:03:16:  <user v='acedogblast'/>
23:03:16:
23:03:16:  <!-- Folding Slots -->
23:03:16:  <slot id='1' type='GPU'/>
23:03:16:</config>
23:03:16:Switching to user fahclient
23:03:16:Trying to access database...
23:03:16:Successfully acquired database lock
23:03:16:Enabled folding slot 01: READY gpu:0:Ellesmere XT [Radeon RX 470/480/570/580]
^[[91m23:03:16:ERROR:No compute devices matched GPU #0 AMD:5 Ellesmere XT [Radeon RX 470/480/570/580].  You may need to update your $
23:03:16:WU01:FS01:Starting
^[[91m23:03:16:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:03:17:WU01:FS01:Starting
^[[91m23:03:17:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:04:17:WU01:FS01:Starting
23:03:16:         OS: Linux 4.15.0-44-generic x86_64
23:03:16:    OS Arch: AMD64
23:03:16:       GPUs: 1
23:03:16:      GPU 0: Bus:2 Slot:0 Func:0 AMD:5 Ellesmere XT [Radeon RX 470/480/570/580]
23:03:16:       CUDA: Not detected: Failed to open dynamic library 'libcuda.so':
23:03:16:             libcuda.so: cannot open shared object file: No such file or
23:03:16:             directory
23:03:16:     OpenCL: Not detected: clGetPlatformIDs() returned -1001
23:03:16:***********************************************************************
23:03:16:<config>
23:03:16:  <!-- Client Control -->
23:03:16:  <fold-anon v='true'/>
23:03:16:
23:03:16:  <!-- User Information -->
23:03:16:  <team v='51238'/>
23:03:16:  <user v='acedogblast'/>
23:03:16:
23:03:16:  <!-- Folding Slots -->
23:03:16:  <slot id='1' type='GPU'/>
23:03:16:</config>
23:03:16:Switching to user fahclient
23:03:16:Trying to access database...
23:03:16:Successfully acquired database lock
23:03:16:Enabled folding slot 01: READY gpu:0:Ellesmere XT [Radeon RX 470/480/570/580]
^[[91m23:03:16:ERROR:No compute devices matched GPU #0 AMD:5 Ellesmere XT [Radeon RX 470/480/570/580].  You may need to update your $
23:03:16:WU01:FS01:Starting
^[[91m23:03:16:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:03:17:WU01:FS01:Starting
^[[91m23:03:17:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:04:17:WU01:FS01:Starting
^[[91m23:04:17:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:05:54:WU01:FS01:Starting
^[[91m23:05:54:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:08:31:WU01:FS01:Starting
^[[91m23:08:31:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:12:34:Lost lifeline PID 897, exiting
23:12:35:Clean exit

^[[91m23:04:17:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually^[[$
23:05:54:WU01:FS01:Starting
acedogblast
 
Posts: 1
Joined: Wed Jan 30, 2019 8:29 pm


Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 0 guests

cron