Please add more support/optimization for Radeon VII

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, PandeGroup

Please add more support/optimization for Radeon VII

Postby Klose_Rinz » Sat Feb 23, 2019 10:28 am

Radeon VII cannot be detected, even in the client of latest version.
When open the client, it reports error.

says "On client \"local\" 127.0.0.1:36330: \nOption 'gpu-index' has no default and is not set. \niter should be a GtkTreeIter", and in "Configure"

Name: AMD Radeon VII
Device ID: 1002 66AF-1002 081E (GPU-Z)

log.txt
Code: Select all
*********************** Log Started 2019-02-23T09:54:58Z ***********************
09:54:58:************************* Folding@home Client *************************
09:54:58:        Website: https://foldingathome.org/
09:54:58:      Copyright: (c) 2009-2018 foldingathome.org
09:54:58:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
09:54:58:           Args: --open-web-control
09:54:58:         Config: C:\Users\Klose Rinz\AppData\Roaming\FAHClient\config.xml
09:54:58:******************************** Build ********************************
09:54:58:        Version: 7.5.1
09:54:58:           Date: May 11 2018
09:54:58:           Time: 13:06:32
09:54:58:     Repository: Git
09:54:58:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
09:54:58:         Branch: master
09:54:58:       Compiler: Visual C++ 2008
09:54:58:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
09:54:58:       Platform: win32 10
09:54:58:           Bits: 32
09:54:58:           Mode: Release
09:54:58:******************************* System ********************************
09:54:58:            CPU: AMD Ryzen Threadripper 1950X 16-Core Processor
09:54:58:         CPU ID: AuthenticAMD Family 23 Model 1 Stepping 1
09:54:58:           CPUs: 32
09:54:58:         Memory: 31.90GiB
09:54:58:    Free Memory: 12.24GiB
09:54:58:        Threads: WINDOWS_THREADS
09:54:58:     OS Version: 6.2
09:54:58:    Has Battery: false
09:54:58:     On Battery: false
09:54:58:     UTC Offset: 8
09:54:58:            PID: 13480
09:54:58:            CWD: C:\Users\Klose Rinz\AppData\Roaming\FAHClient
09:54:58:             OS: Windows 10 Enterprise
09:54:58:        OS Arch: AMD64
09:54:58:           GPUs: 0
09:54:58:           CUDA: Not detected: Failed to open dynamic library 'nvcuda.dll':
09:54:58:                 找不到指定的模块。
09:54:58:
09:54:58:OpenCL Device 0: Platform:0 Device:0 Bus:67 Slot:0 Compute:1.2 Driver:2766.5
09:54:58:  Win32 Service: false
09:54:58:***********************************************************************
09:54:59:<config>
09:54:59:  <!-- Folding Core -->
09:54:59:  <checkpoint v='3'/>
09:54:59:  <core-priority v='low'/>
09:54:59:
09:54:59:  <!-- Network -->
09:54:59:  <proxy v=':8080'/>
09:54:59:
09:54:59:  <!-- Slot Control -->
09:54:59:  <power v='full'/>
09:54:59:
09:54:59:  <!-- User Information -->
09:54:59:  <passkey v='********************************'/>
09:54:59:  <team v='3213'/>
09:54:59:  <user v='Klose_Rinz'/>
09:54:59:
09:54:59:  <!-- Folding Slots -->
09:54:59:  <slot id='0' type='GPU'/>
09:54:59:</config>
09:54:59:Trying to access database...
09:54:59:Successfully acquired database lock
09:54:59:ERROR:Exception: No available GPUs
09:54:59:ERROR:No valid folding configuration
09:54:59:ERROR:Exception: Option 'gpu-index' has no default and is not set.
09:54:59:WARNING:WU00:No longer matches Slot 0's configuration and there are no other matching slots, dumping
09:54:59:WU00:FS00:Sending unit results: id:00 state:SEND error:DUMPED project:14137 run:38 clone:314 gen:2 core:0xa7 unit:0x000000020002894b5c6e8f10b30d8eda
09:54:59:WU00:FS00:Connecting to 155.247.166.219:8080
09:54:59:WU01:FS00:Connecting to 65.254.110.245:8080
09:55:01:WU01:FS00:Assigned to work server 171.67.108.158
09:55:01:WU01:FS00:Requesting new work unit for slot
09:55:01:ERROR:WU01:FS00:Exception: Option 'gpu-index' has no default and is not set.
09:55:01:WU00:FS00:Server responded WORK_ACK (400)
09:55:01:WU00:FS00:Cleaning up
09:55:01:WU01:FS00:Connecting to 65.254.110.245:8080
09:55:04:WU01:FS00:Assigned to work server 155.247.166.219
09:55:04:WU01:FS00:Requesting new work unit for slot
09:55:04:ERROR:WU01:FS00:Exception: Option 'gpu-index' has no default and is not set.
09:56:01:WU01:FS00:Connecting to 65.254.110.245:8080
09:56:03:WU01:FS00:Assigned to work server 155.247.166.219
09:56:04:WU01:FS00:Requesting new work unit for slot
09:56:04:ERROR:WU01:FS00:Exception: Option 'gpu-index' has no default and is not set.
09:57:38:WU01:FS00:Connecting to 65.254.110.245:8080
09:57:40:WU01:FS00:Assigned to work server 155.247.166.220
09:57:41:WU01:FS00:Requesting new work unit for slot
09:57:41:ERROR:WU01:FS00:Exception: Option 'gpu-index' has no default and is not set.


Device Info(Lspci)
Code: Select all
C:\Software\Hardware Tools\FAHClient>FAHClient.exe --lspci
VendorID:DeviceID:PCI Bus:PCI Slot:PCI function:Vendor Name:Description
0x12d8:0xb608:11:3:0:Pericom Semiconductor:PCI Express ??????????????
0x12ab:0x0371:13:0:0:Yuan Yuan Enterprise Co., Ltd.:Game Capture 4K60 Pro
0x1022:0x145c:17:0:3:Advanced Micro Devices, Inc. [AMD]:???? USB xHCI ????????????
0x12ab:0x0371:12:0:0:Yuan Yuan Enterprise Co., Ltd.:Game Capture 4K60 Pro
0x1022:0x145a:68:0:0:Advanced Micro Devices, Inc. [AMD]:AMD PCI
0x1002:0x14a1:66:0:0:Advanced Micro Devices, Inc. [AMD/ATI]:PCI Express ??????????????
0x8086:0x0953:9:0:0:Intel Corporation:Intel(R) Solid-State Drive P3700/P3600/P3500/P3520/750 Series
0x1022:0x1466:0:24:6:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1466:0:25:6:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x12d8:0xb608:10:0:0:Pericom Semiconductor:PCI Express ??????????????
0x12ab:0x0371:14:0:0:Yuan Yuan Enterprise Co., Ltd.:Game Capture 4K60 Pro
0x1022:0x1450:0:0:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:1:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:2:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:3:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:4:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:7:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1452:0:8:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1454:0:7:1:Advanced Micro Devices, Inc. [AMD]:PCI Express ??????
0x1022:0x1454:0:8:1:Advanced Micro Devices, Inc. [AMD]:PCI Express ??????
0x1095:0x3112:0:6:0:Silicon Image, Inc.:???? SATA AHCI ??????
0x1022:0x1463:0:24:3:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1463:0:25:3:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x790e:0:20:3:Advanced Micro Devices, Inc. [AMD]:PCI ???? ISA ??
0x1022:0x1451:64:0:2:Advanced Micro Devices, Inc. [AMD]:AMD IOMMU Device
0x1022:0x1453:64:3:1:Advanced Micro Devices, Inc. [AMD]:PCI Express ??????
0x1b21:0x2142:8:0:0:ASMedia Technology Inc.:???? USB xHCI ????????????
0x1022:0x1460:0:24:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x1460:0:25:0:Advanced Micro Devices, Inc. [AMD]:PCI ???????? CPU ??
0x1022:0x43b4:2:0:0:Advanced Micro Devices, Inc. [AMD]:PCI Express ??????????????
0x1022:0x145a:17:0:0:Advanced Micro Devices, Inc. [AMD]:AMD PCI
0x1022:0x43b6:1:0:1:Advanced Micro Devices, Inc. [AMD]:???? SATA AHCI ??????
0x1022:0x1456:68:0:2:Advanced Micro Devices, Inc. [AMD]:AMD PSP 3.0 Device
0x1022:0x43b4:2:2:0:Advanced Micro Devices, Inc. [AMD]:PCI Express ??????????????
0x0000:0xd107:7:0:0:09:37:29:ERROR:Exception: Win32: 0xc0000005: Exception access violation


It should be this one:
0x1002:0x14a1:66:0:0:Advanced Micro Devices, Inc. [AMD/ATI]:PCI Express ??????????????

When I add following info in GPUs.txt,the client works,but gpu clock and mem clock is changing always, seems not in full load.
0x1002:0x66A0:1:5:Vega 20 [Radeon Instinct]
0x1002:0x66A1:1:5:Vega 20
0x1002:0x66A2:1:5:Vega 20
0x1002:0x66A3:1:5:Vega 20
0x1002:0x66A7:1:5:Vega 20 [Radeon Pro Vega 20]
0x1002:0x66AF:1:5:Vega 20 [Radeon VII]
Klose_Rinz
 
Posts: 2
Joined: Sat Feb 23, 2019 9:46 am

Re: Please add more support/optimization for Radeon VII

Postby toTOW » Sat Feb 23, 2019 6:56 pm

Please read other posts before posting, support for Radeon VII has already been requested and added : viewtopic.php?f=83&t=31390
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8766
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Please add more support/optimization for Radeon VII

Postby foldy » Sat Feb 23, 2019 8:49 pm

You can download latest GPUs.txt manually https://apps.foldingathome.org/GPUs.txt
and put it in C:\Users\Klose Rinz\AppData\Roaming\FAHClient
Then restart FAHClient.
foldy
 
Posts: 1498
Joined: Sat Dec 01, 2012 3:43 pm

Re: Please add more support/optimization for Radeon VII

Postby bruce » Sun Feb 24, 2019 7:28 am

GPUs.txt will be refreshed automatically if it happens to be missing when FAHClient is restarted.
bruce
 
Posts: 22623
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Please add more support/optimization for Radeon VII

Postby Klose_Rinz » Sun Feb 24, 2019 4:32 pm

Thanks.
I have already added the list into GPUs.txt.
The client works,and I found that gpu clock and mem clock depends on the different PROJECT. It seems to be OK for most PROJECT.
Klose_Rinz
 
Posts: 2
Joined: Sat Feb 23, 2019 9:46 am


Return to New Donors start here

Who is online

Users browsing this forum: No registered users and 0 guests

cron