Difficulties getting started (Linux)

Moderators: Site Moderators, FAHC Science Team

Difficulties getting started (Linux)

Postby Nichtraucher » Fri Mar 20, 2020 8:30 pm

Hello peeps :-)


1.) My computer is really old - does it make sense to run FAH? I was hoping to contribute even if it won't be much. The specs are:

Code: Select all
System:    Host: benni Kernel: 4.4.0-176-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18 Sarah
Machine:   Mobo: ASUSTeK model: M2NS-NVM v: 1.XX
           Bios: Phoenix v: ASUS M2NS-NVM 0401 date: 09/28/2006
CPU:       Dual core AMD model unknown (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 10448
           clock speeds: max: 3100 MHz 1: 2600 MHz 2: 2600 MHz
Graphics:  Card: NVIDIA C61 [GeForce 6100 nForce 405] bus-ID: 00:0d.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 6100 nForce 405/integrated/SSE2
           GLX Version: 2.1.2 NVIDIA 304.135 Direct Rendering: Yes
Audio:     Card NVIDIA MCP61 High Definition Audio driver: snd_hda_intel bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-176-generic
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth port: ec00 bus-ID: 00:07.0
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: 6a:e5:e3:1d:6e:00
Drives:    HDD Total Size: 160.0GB (86.8% used)
           ID-1: /dev/sda model: ST3160215ACE size: 160.0GB
Partition: ID-1: / size: 19G used: 9.6G (56%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 120G used: 111G (99%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: 41.0C gpu: 0.0:
           Fan Speeds (in rpm): cpu: 1313 sys-1: 0
Info:      Processes: 186 Uptime: 2:50 Memory: 3910.4/7950.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35


2) I've got difficulties to get the whole thing running - initially, the installation didn't go through but that no longer seems to be the problem (?). FAH doesn't appear in the menu, just the viewer. I got it to start with
Code: Select all
sudo /etc/init.d/FAHClient start
The status shows up as "Connected" and Protein as "Loading" but that's about it.

Any help is much appreciated! :-)
Nichtraucher
 
Posts: 2
Joined: Thu Mar 19, 2020 9:39 pm

Re: Difficulties getting started (Linux)

Postby lazyacevw » Fri Mar 20, 2020 9:50 pm

Let's try to reinstall:

## Download fahclient, fahcontrol, and optionally fahviewer for Mint from https://foldingathome.org/start-folding/ and save to your desktop
## Double click on each package, one at a time and have Package Installer install the packages. If it says reinstall instead of install, go ahead and chose reinstall.

Now check again and let us know if you can find FAHControl in your start menu and can run it.
lazyacevw
 
Posts: 36
Joined: Tue Mar 17, 2020 9:12 pm

Re: Difficulties getting started (Linux)

Postby Nichtraucher » Sat Mar 21, 2020 5:36 pm

Thank you! I got them all installed but everything is greyed out until I start the client from the command line. It seems to work now - It just took a while to find a work unit. I'm not sure if this is related, but I'm getting error messages related to fahclient when I'm using apt-get such as these:

Code: Select all
/var/lib/dpkg/info/fahclient.postinst: Zeile 69: insserv: Kommando nicht gefunden.
dpkg: Fehler beim Bearbeiten des Paketes fahclient (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 fahclient
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Wiederherstellung wird versucht:
fahclient (7.5.1) wird eingerichtet ...
/var/lib/dpkg/info/fahclient.postinst: Zeile 69: insserv: Kommando nicht gefunden.
dpkg: Fehler beim Bearbeiten des Paketes fahclient (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 fahclient


I tried to solve this by removing and re-installing fahclient. The installation went through smoothly but I'm still getting these errors.

1) Now how do I start crunching without having to start fahclient from the command line?
2) I'm not sure if I can complete the work unit in time - is it possible to receive work units that are more suitable for my machine?
Nichtraucher
 
Posts: 2
Joined: Thu Mar 19, 2020 9:39 pm

Re: Difficulties getting started (Linux)

Postby lazyacevw » Tue Mar 24, 2020 3:54 am

I'm not quite sure as I unfortunately don't know much German. Try this:

sudo apt clean
sudo apt update
sudo apt upgrade
sudo apt install -f

I've noticed when I first installed the client that I had to start it from the command line, just as you did. Every time since then and even after reboots. I have not had to do it again. I just open the controller and start folding.
lazyacevw
 
Posts: 36
Joined: Tue Mar 17, 2020 9:12 pm

Re: Difficulties getting started (Linux)

Postby tim » Tue Mar 24, 2020 4:23 pm

otherwise you could try: https://github.com/FoldingAtHome/fah-is ... -340875034

ansonsten könntest du hier noch gucken: https://github.com/FoldingAtHome/fah-is ... -340875034 da ist unten einer mit nem ähnlichen Fehler
tim
 
Posts: 8
Joined: Mon Mar 23, 2020 4:03 am


Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 0 guests

cron