Moderators: Site Moderators, FAHC Science Team

Re: opencl-index=-1

Postby turo@home » Thu Mar 26, 2020 12:42 am

Hi there,

First post in the forum.

This thread is very didactic.
It solved two problems for me:
Initially, I wasn't able to fold on gpu due to wrong slot. As explained. -1 didn't found the proper one. Changing the slot manually fixed.
Then, doing the things right, the complete install of fixed the log errors, and now FAH finds the slot properly when slot=-1 for gpu.
My OS is solus OS, propietary nvidia drivers (440.64)

In solus the command is as follows:
Code: Select all
sudo eopkg install ocl-icd-devel

Awesome community. Thanks a lot!
Posts: 1
Joined: Thu Mar 26, 2020 12:34 am

Re: opencl-index=-1

Postby Schmich » Thu Mar 26, 2020 2:08 am

Changing opencl-index to 0 and restarting the client also helped me :D I got a WU right away.

I thought I put the gpu-index and cuda to 0 as well but I see them as -1 after the client restart (opencl is 0).

Longer version: I also had "FS01:Failed to start core: OpenCL device matching slot 1 not found, try setting 'opencl-index' manually".
What didn't work: updating to the latest Nvidia driver (I had the second to last).
Have not tired: restarting the PC. I have to much work open on my computer to restart.

Windows 10
AMD 1700
RTX 2080
Latest driver & FAH client.

The fix about changing the Index I think just makes FAH use CUDA instead of OpenCL. I'm 100% sure it was using CUDA. When I tried to reset the index to -1 it said:
"WU00:FS01:Failed to start core: Option 'opencl-index' has no default and is not set."

Edit: Reinstalling FAH (+ deleting data) doesn't help. GPU-Z says OpenCL is installed. I think I'll just continue with CUDA until the next GPU driver update. If that doesn't work, I'll try DDU and reinstall the drivers from scratch.
Posts: 7
Joined: Sun Apr 10, 2011 7:31 pm


Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 2 guests