AMD 7950 3GB Linux Mint 19.3 no open cl

It seems that a lot of GPU problems revolve around specific versions of drivers. Though AMD has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, FAHC Science Team

AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Thu Apr 23, 2020 9:43 pm

My f@h client in linux mint 19.3 cinnamon is saying that no opencl is detected and no WU's are being sent to the GPU.
I am on the newest MESA drivers for my 7950 gpu.

How do I download or enable open CL so that my GPU will start working in f@h?

Specs:
Intel G3220 CPU (cpu folding is working great)
AMD HD 7950 3GB GPU latest mesa drivers.
8GB DDR3 Ram
1 TB HDD
Linux Mint 19.3 Cinnamon w/latest updates

Really want to get this GPU fully working with f@h (all of my other clients are getting GPU WU's).

Your assistance is greatly appreciated.
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby Joe_H » Thu Apr 23, 2020 11:23 pm

You need to be using the AMD proprietary drivers and OpenCL support packages. A number of people have posted on the details, a search should turn those up. Or someone more familiar with Mint will give you a pointer.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6540
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby STR1D3R_2 » Thu Apr 23, 2020 11:43 pm

-
Last edited by STR1D3R_2 on Mon May 04, 2020 6:21 pm, edited 1 time in total.
Image
STR1D3R_2
 
Posts: 15
Joined: Thu Apr 02, 2020 4:03 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Thu Apr 23, 2020 11:58 pm

Here is what I get when I enter that into a terminal.

sudo apt install ocl-icd-opencl-dev

Building dependency tree
Reading state information... Done
ocl-icd-opencl-dev is already the newest version (2.2.11-1ubuntu1).
The following packages were automatically installed and are no longer required:
libaudclient2 libclang-common-9-dev libllvm9 libllvm9:i386
libomxil-bellagio0 libva2:i386 libvdpau1:i386 libxmmsclient6 libxnvctrl0
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


I like Mint 19.3, I really don't want to go back to Windows.
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:07 am

From the log:

23:06:41:WU00:FS01:0x22:Folding@home GPU Core22 Folding@home Core
23:06:41:WU00:FS01:0x22:Version 0.0.2
23:06:41:WU00:FS01:0x22:ERROR:exception: There is no registered Platform called "OpenCL"
23:06:41:WU00:FS01:0x22:Saving result file ../logfile_01.txt
23:06:41:WU00:FS01:0x22:Saving result file science.log
23:06:41:WU00:FS01:0x22:Folding@home Core Shutdown: BAD_WORK_UNIT
23:06:41:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:06:41:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14545 run:0 clone:795 gen:23 core:0x22 unit:0x000000200d5262775e80e2244ed77662
23:06:42:WU00:FS01:Uploading 7.00KiB to 13.82.98.119
23:06:42:WU00:FS01:Connecting to 13.82.98.119:8080
23:06:42:WU02:FS01:Connecting to 65.254.110.245:80
23:06:42:WARNING:WU02:FS01:Failed to get assignment from '65.254.110.245:80': No WUs available for this configuration
23:06:42:WU02:FS01:Connecting to 18.218.241.186:80
23:06:42:WARNING:WU02:FS01:Failed to get assignment from '18.218.241.186:80': No WUs available for this configuration
23:06:42:WU02:FS01:Connecting to 65.254.110.245:80
23:06:43:WARNING:WU02:FS01:Failed to get assignment from '65.254.110.245:80': No WUs available for this configuration
23:06:43:WU02:FS01:Connecting to 18.218.241.186:80
23:06:43:WU02:FS01:Assigned to work server 13.82.98.119
23:06:43:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:Tahiti PRO [Radeon R9 280/HD 7900/8950] from 13.82.98.119
23:06:43:WU02:FS01:Connecting to 13.82.98.119:8080
23:06:49:WU00:FS01:Upload complete
23:06:49:WU00:FS01:Server responded WORK_ACK (400)
23:06:49:WU00:FS01:Cleaning up
23:06:50:ERROR:WU02:FS01:Exception: Server did not assign work unit
23:06:51:WU02:FS01:Connecting to 65.254.110.245:80
23:06:51:WARNING:WU02:FS01:Failed to get assignment from '65.254.110.245:80': No WUs available for this configuration
23:06:51:WU02:FS01:Connecting to 18.218.241.186:80
23:06:51:WARNING:WU02:FS01:Failed to get assignment from '18.218.241.186:80': No WUs available for this configuration
23:06:51:WU02:FS01:Connecting to 65.254.110.245:80
23:06:52:WARNING:WU02:FS01:Failed to get assignment from '65.254.110.245:80': No WUs available for this configuration
23:06:52:WU02:FS01:Connecting to 18.218.241.186:80
23:06:52:WARNING:WU02:FS01:Failed to get assignment from '18.218.241.186:80': No WUs available for this configuration
23:06:52:ERROR:WU02:FS01:Exception: Could not get an assignment
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:12 am

Another log entry,

3:11:42:ERROR:WU00:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
23:11:43:WU00:FS01:Starting
23:11:43:ERROR:WU00:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually

How do I set the opencl index manually?
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby STR1D3R_2 » Fri Apr 24, 2020 12:28 am

-
Last edited by STR1D3R_2 on Mon May 04, 2020 6:22 pm, edited 2 times in total.
STR1D3R_2
 
Posts: 15
Joined: Thu Apr 02, 2020 4:03 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:34 am

Here is my driver info:

Device-1: AMD Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] vendor: PC Partner Limited
driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:679a
Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: AMD TAHITI (DRM 2.50.0 5.3.0-46-generic LLVM 10.0.0)
v: 4.5 Mesa 20.0.5 - kisak-mesa PPA direct render: Yes
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:38 am

It's frustrating....I really want this GPU to work!! I am a linux noob, so that doesn't help either.
I appreciate everyone's help
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby STR1D3R_2 » Fri Apr 24, 2020 12:40 am

-
Last edited by STR1D3R_2 on Mon May 04, 2020 6:22 pm, edited 2 times in total.
STR1D3R_2
 
Posts: 15
Joined: Thu Apr 02, 2020 4:03 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:41 am

I've tried -1, 0, 1, 2 and 3, thus far nothing.

Yes this is an AMD HD 7950 3 GB
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby Joe_H » Fri Apr 24, 2020 12:51 am

I don't know if this is an issue with the 7950, but for the previous two series, the HD 5000 and HD 6000, AMD removed OpenCL support from the most recent drivers to support them. So if they did this on the 7950 also, then you might have to step back to an older driver version.
Joe_H
Site Admin
 
Posts: 6540
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 12:53 am

Thanks Joe, can you help me and let me know how to do that?
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby Joe_H » Fri Apr 24, 2020 2:46 am

For this you will need to find someone very familiar with Mint and installing drivers. From a little e web searching, version 18.50 will still support the card with working OpenCL. There might be a version newer than that, but that was the most recent I found quickly.

The source gave not too much detail on installation, and this was on a Ubuntu 18.04 system. The install this person mentioned also included needing a kernel setting. Whether this is still possible to install on this recent version of Mint, not certain.
Joe_H
Site Admin
 
Posts: 6540
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: AMD 7950 3GB Linux Mint 19.3 no open cl

Postby poppster » Fri Apr 24, 2020 3:23 pm

Thanks Joe. I appreciate the insight. I wish I knew more about linux to fix this myself.

I would imagine I am on the newest Kernel, so I don't know how to load an older kernel. Also, steam works well. It appears to play games just fine? Maybe it's a f@h client issue? How else can I test the GPU?
poppster
 
Posts: 21
Joined: Thu Apr 23, 2020 9:36 pm

Next

Return to Problems with AMD/ATI drivers

Who is online

Users browsing this forum: No registered users and 0 guests

cron