How to stop FAH from starting automatically?

Moderators: Site Moderators, FAHC Science Team

How to stop FAH from starting automatically?

Postby therium » Mon May 18, 2020 10:10 am

How do I start FAH 7.5.1 on Windows 10 from starting automatically on boot up? I've looked in the system startup area on control panel and it's not there. I cannot find a Startup folder either.

Thank you!

Here's the first part of my log:

Code: Select all
*********************** Log Started 2020-05-18T09:06:15Z ***********************
09:06:15:************************* Folding@home Client *************************
09:06:15:        Website: https://foldingathome.org/
09:06:15:      Copyright: (c) 2009-2018 foldingathome.org
09:06:15:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
09:06:15:           Args: --open-web-control
09:06:15:         Config: C:\Users\PC\AppData\Roaming\FAHClient\config.xml
09:06:15:******************************** Build ********************************
09:06:15:        Version: 7.5.1
09:06:15:           Date: May 11 2018
09:06:15:           Time: 13:06:32
09:06:15:     Repository: Git
09:06:15:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
09:06:15:         Branch: master
09:06:15:       Compiler: Visual C++ 2008
09:06:15:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
09:06:15:       Platform: win32 10
09:06:15:           Bits: 32
09:06:15:           Mode: Release
09:06:15:******************************* System ********************************
09:06:15:            CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
09:06:15:         CPU ID: GenuineIntel Family 6 Model 58 Stepping 9
09:06:15:           CPUs: 4
09:06:15:         Memory: 15.97GiB
09:06:15:    Free Memory: 12.13GiB
09:06:15:        Threads: WINDOWS_THREADS
09:06:15:     OS Version: 6.2
09:06:15:    Has Battery: false
09:06:15:     On Battery: false
09:06:15:     UTC Offset: -4
09:06:15:            PID: 7412
09:06:15:            CWD: C:\Users\PC\AppData\Roaming\FAHClient
09:06:15:             OS: Windows 10 Enterprise
09:06:15:        OS Arch: AMD64
09:06:15:           GPUs: 1
09:06:15:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 GP106 [GeForce GTX 1060 3GB] 3935
09:06:15:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:10.2
09:06:15:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:441.66
09:06:15:  Win32 Service: false
09:06:15:***********************************************************************
09:06:15:<config>
09:06:15:  <!-- Folding Slot Configuration -->
09:06:15:  <cause v='CANCER'/>
09:06:15:
09:06:15:  <!-- Network -->
09:06:15:  <proxy v=':8080'/>
09:06:15:
09:06:15:  <!-- Slot Control -->
09:06:15:  <power v='MEDIUM'/>
09:06:15:
09:06:15:  <!-- User Information -->
09:06:15:  <passkey v='********************************'/>
09:06:15:  <team v='40965'/>
09:06:15:  <user v='Therium'/>
09:06:15:
09:06:15:  <!-- Folding Slots -->
09:06:15:  <slot id='0' type='CPU'/>
09:06:15:  <slot id='1' type='GPU'/>
09:06:15:</config>
09:06:15:Trying to access database...
09:06:15:Successfully acquired database lock
09:06:15:Enabled folding slot 00: READY cpu:2
09:06:15:Enabled folding slot 01: READY gpu:0:GP106 [GeForce GTX 1060 3GB] 3935
09:06:15:WU01:FS00:Starting
09:06:15:WU01:FS00:Running FahCore: e:\Apps\FAHClient/FAHCoreWrapper.exe C:\Users\PC\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/v7/win/64bit/avx/Core_a7.fah/FahCore_a7.exe -dir 01 -suffix 01 -version 705 -lifeline 7412 -checkpoint 15 -np 2
09:06:15:WU01:FS00:Started FahCore on PID 5652
09:06:15:WU01:FS00:Core PID:8764
therium
 
Posts: 13
Joined: Fri Mar 21, 2014 11:48 am
Location: West Michigan

Re: How to stop FAH from starting automatically?

Postby Neil-B » Mon May 18, 2020 10:32 am

If you mean how do I "stop" then this thread might give you what you need … Second post in the thread - https://foldingforum.org/viewtopic.php?f=61&t=35204&p=333766&hilit=pause+on+start#p333766 … Hope that helps :)
1: 2x Xeon E5-2697v3@2.60GHz, 512GB DDR4 LRDIMM, SSD Raid, Win10 Ent, Quadro K420 1GB, FAH 7.6.13
2: Xeon E3-1505Mv5@2.80GHz, 32GB DDR4, NVME, Win10 Pro, Quadro M1000M 2GB, FAH 7.6.13
3: i7-960@3.20GHz, 12GB DDR3, SSD, Win10 Pro, GTX 750Ti 2GB, FAH 7.6.13
Neil-B
 
Posts: 1342
Joined: Sun Mar 22, 2020 6:52 pm
Location: UK

Re: How to stop FAH from starting automatically?

Postby therium » Mon May 18, 2020 5:02 pm

Thank you, but I don't want to start the program then pause it. I don't want any part of the program to start when I reboot the PC, but I don't really want to uninstall the program totally.
therium
 
Posts: 13
Joined: Fri Mar 21, 2014 11:48 am
Location: West Michigan

Re: How to stop FAH from starting automatically?

Postby PantherX » Mon May 18, 2020 8:07 pm

You have two options:

Option 1 (Quick but not tested)
Open up Task Manager
Click on Start-up Tab
Right click on "HideConsole.exe" and select "Disable"
This will prevent the client from starting up during reboot.

Option 2 (Long but works)
Uninstall F@H but do not delete data
Reinstall F@H and during the installation, change it to manual start-up instead of automatic start-up which is the default.

May I ask what's your use-case for this?
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Troubleshooting Bad WUs Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6578
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: How to stop FAH from starting automatically?

Postby calxalot » Mon May 18, 2020 10:48 pm

Or, in FAHControl, add client option pause-on-start true.
calxalot
Site Moderator
 
Posts: 405
Joined: Sat Dec 08, 2007 2:33 am
Location: San Francisco

Re: How to stop FAH from starting automatically?

Postby Neil-B » Mon May 18, 2020 10:50 pm

All ready offered that to op earlier in thread .. has stated that is not what is wanted.
Neil-B
 
Posts: 1342
Joined: Sun Mar 22, 2020 6:52 pm
Location: UK

Re: How to stop FAH from starting automatically?

Postby bollix47 » Tue May 19, 2020 12:37 am

Windows uses a shortcut in it's Startup folder to start folding.
You can remove that shortcut.
Hold down the windows key and press the r key which should bring up a run box.
Type shell:startup and press Enter ... Windows File Manager should open up and you should see the folding@home shortcut.
Either move the shortcut elsewhere if you think you'll need it in the future or just delete it.
bollix47
 
Posts: 2870
Joined: Sun Dec 02, 2007 6:04 am
Location: Canada

Re: How to stop FAH from starting automatically?

Postby bruce » Tue May 19, 2020 3:10 am

Neil-B wrote:All ready offered that to op earlier in thread .. has stated that is not what is wanted.


I'm not sure why not.... FAHClient will do absolutely nothing if all the slots are paused.

Anyway, there's another option. Reinstall and unselect the Start Automatically on Reboot or whatever it's called.
bruce
 
Posts: 19836
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: How to stop FAH from starting automatically?

Postby Not_a_Number » Thu May 21, 2020 5:52 pm

If FaH was installed as a service

-press windows key-r on the keyboard and type in "services.msc"
-in Services Manager Locate the Folding at Home service (I don't know the display name)
-click on stop
-right click on the service
-choose properties from the context menu
-set startup type to "Manual
-click Ok

In addition to the solutions posted by Panther-X and bollix47 you can download the autoruns utility from sysinternals.com.
-Run autoruns.exe or autoruns64.exe, whichever is appropriate to your system
-Locate the Folding@Home.lnk in the Logons tab section and uncheck the box

This essentially does the same as disabling the startup via Task Manager. Autoruns gives you access to much startup functions.

BTW: a quick way to launch the Task Manager is to press ctrl-shift-esc
Not_a_Number
 
Posts: 8
Joined: Thu Apr 30, 2020 1:38 am


Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest

cron