Cores with -1 not detected correctly?

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, FAHC Science Team

Cores with -1 not detected correctly?

Postby SDI-89 » Fri Jul 03, 2020 8:55 am

Hello together,
In this log i can see that 64 cores are detected. But in the Slot with the -1 configuration only 32 cores are used.
Can anyone tell me why? And what do I have to do for best performance?

Code: Select all
07:47:02:WU01:FS00:0xa7:*********************** Log Started 2020-07-03T07:47:02Z ***********************
07:47:03:WU01:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
07:47:03:WU01:FS00:0xa7:       Type: 0xa7
07:47:03:WU01:FS00:0xa7:       Core: Gromacs
07:47:03:WU01:FS00:0xa7:       Args: -dir 01 -suffix 01 -version 706 -lifeline 2224 -checkpoint 15 -np
07:47:03:WU01:FS00:0xa7:             16
07:47:03:WU01:FS00:0xa7:************************************ CBang *************************************
07:47:03:WU01:FS00:0xa7:       Date: Oct 26 2019
07:47:03:WU01:FS00:0xa7:       Time: 01:38:25
07:47:03:WU01:FS00:0xa7:   Revision: c46a1a011a24143739ac7218c5a435f66777f62f
07:47:03:WU01:FS00:0xa7:     Branch: master
07:47:03:WU01:FS00:0xa7:   Compiler: Visual C++ 2008
07:47:03:WU01:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
07:47:03:WU01:FS00:0xa7:   Platform: win32 10
07:47:03:WU01:FS00:0xa7:       Bits: 64
07:47:03:WU01:FS00:0xa7:       Mode: Release
07:47:03:WU01:FS00:0xa7:************************************ System ************************************
07:47:03:WU01:FS00:0xa7:        CPU: Intel(R) Xeon(R) Gold 6244 CPU @ 3.60GHz
07:47:03:WU01:FS00:0xa7:     CPU ID: GenuineIntel Family 6 Model 85 Stepping 7
07:47:03:WU01:FS00:0xa7:       CPUs: 64
07:47:03:WU01:FS00:0xa7:     Memory: 1.50TiB
07:47:03:WU01:FS00:0xa7:Free Memory: 2.45GiB
07:47:03:WU01:FS00:0xa7:    Threads: WINDOWS_THREADS
07:47:03:WU01:FS00:0xa7: OS Version: 6.2
07:47:03:WU01:FS00:0xa7:Has Battery: false
07:47:03:WU01:FS00:0xa7: On Battery: false
07:47:03:WU01:FS00:0xa7: UTC Offset: 2
07:47:03:WU01:FS00:0xa7:        PID: 2844
07:47:03:WU01:FS00:0xa7:        CWD: C:\Users\Administrator\AppData\Roaming\FAHClient\work
07:47:03:WU01:FS00:0xa7:******************************** Build - libFAH ********************************
07:47:03:WU01:FS00:0xa7:    Version: 0.0.18
07:47:03:WU01:FS00:0xa7:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
07:47:03:WU01:FS00:0xa7:  Copyright: 2019 foldingathome.org
07:47:03:WU01:FS00:0xa7:   Homepage: https://foldingathome.org/
07:47:03:WU01:FS00:0xa7:       Date: Oct 26 2019
07:47:03:WU01:FS00:0xa7:       Time: 01:52:30
07:47:03:WU01:FS00:0xa7:   Revision: c1e3513b1bc0c16013668f2173ee969e5995b38e
07:47:03:WU01:FS00:0xa7:     Branch: master
07:47:03:WU01:FS00:0xa7:   Compiler: Visual C++ 2008
07:47:03:WU01:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
07:47:03:WU01:FS00:0xa7:   Platform: win32 10
07:47:03:WU01:FS00:0xa7:       Bits: 64
07:47:03:WU01:FS00:0xa7:       Mode: Release
07:47:03:WU01:FS00:0xa7:************************************ Build *************************************
07:47:03:WU01:FS00:0xa7:       SIMD: avx_256
07:47:03:WU01:FS00:0xa7:********************************************************************************
07:47:03:WU01:FS00:0xa7:Project: 16806 (Run 8, Clone 673, Gen 13)
07:47:03:WU01:FS00:0xa7:Unit: 0x0000001282ed0b915eb41bf043828239
07:47:03:WU01:FS00:0xa7:Digital signatures verified
07:47:03:WU01:FS00:0xa7:Calling: mdrun -s frame13.tpr -o frame13.trr -cpi state.cpt -cpt 15 -nt 16
07:47:03:WU01:FS00:0xa7:Steps: first=6500000 total=500000
07:47:03:WU01:FS00:0xa7:Completed 109782 out of 500000 steps (21%)
07:47:08:WU01:FS00:0xa7:Completed 110000 out of 500000 steps (22%)
07:48:44:WU01:FS00:0xa7:Completed 115000 out of 500000 steps (23%)
07:50:20:WU01:FS00:0xa7:Completed 120000 out of 500000 steps (24%)
07:51:05:Saving configuration to config.xml
SDI-89
 
Posts: 8
Joined: Mon Mar 30, 2020 2:16 pm

Re: Cores with -1 not detected correctly?

Postby ajm » Fri Jul 03, 2020 9:19 am

The standard configuration of CPU cores/threads is starting to date quite a bit. It was designed for a time when CPUs had only very few cores and the result with the latest CPUs is less than optimal. In your case, according to your log, the slot is actually using 16 threads:

Code: Select all
07:47:03:WU01:FS00:0xa7:Calling: mdrun -s frame13.tpr -o frame13.trr -cpi state.cpt -cpt 15 -nt 16


The -nt indicates how many threads (or CPUs as FAH calls them) are used.

You can change that in Advanced Control. Configure -> Slots -> double click "cpu" -> enter the number of threads/CPUs you want to use in the CPUs section (instead of "-1") -> OK -> Save. If you choose a number higher than the number presently used by a WU, it will become effective only for the next WU.

Now, it is not advisable yet (to my knowledge, but it is changing quite rapidly these days) to enter a number higher than 32, as only few WUs can really use them. It is better to split the threads among several slots, eg maybe 1x32, 1x24, 1x6, or 2x24 and 1X12. This in order to keep a few cores free for GPU management (count 1 thread per "normal" PGU and rather 2, or one core, for high-end GPUs). You have to avoid prime numbers and some of their multiples. 5 or 7 won't work at all, for example, and FAH will automatically reduce them. And some WUs don't accept multiples of primes like 10 or 15. The safest is to chose numbers divisible by 2 and 3.
Last edited by ajm on Fri Jul 03, 2020 9:21 am, edited 1 time in total.
ajm
 
Posts: 552
Joined: Sat Mar 21, 2020 6:22 am
Location: Lucerne, Switzerland

Re: Cores with -1 not detected correctly?

Postby JimboPalmer » Fri Jul 03, 2020 9:21 am

My understanding is that while there is no limit in Linux, most versions of Windows have a 32 core limit per process. You can define two CPU slots of 32 each. (or 4 slots of 16 threads each)
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 2018
Joined: Mon Feb 16, 2009 5:12 am
Location: Greenwood MS USA

Re: Cores with -1 not detected correctly?

Postby SDI-89 » Fri Jul 03, 2020 9:35 am

Thank you for the answer.
I changed it to 1x32 1x24 1x8.

There is no GPU installed that can be used :)
SDI-89
 
Posts: 8
Joined: Mon Mar 30, 2020 2:16 pm

Re: Cores with -1 not detected correctly?

Postby Neil-B » Fri Jul 03, 2020 5:02 pm

To be honest 2x32 would be better for the science (and therefore points) .. My 32/56 slot is pretty much always busy (at 32) - occasionally it has been "downstepped" by the AS to 12 when there has been a lack of WUs for larger core slots (maybe 10 times in total over multiple thousands of WUs) - although I have always run client-type as advanced (or more recently beta having joined the beta team) .. I use a 32/56 slot and a 24/56 slot and no GPU and have found that the lack of any "headroom" hasn't impacted my throughput so 2x32 should work well for you if you want to give it a go :)
1: 2x Xeon E5-2697v3@2.60GHz, 512GB DDR4 LRDIMM, SSD Raid, Win10 Ent, Quadro K420 1GB, FAH 7.6.13
2: Xeon E3-1505Mv5@2.80GHz, 32GB DDR4, NVME, Win10 Pro, Quadro M1000M 2GB, FAH 7.6.13
3: i7-960@3.20GHz, 12GB DDR3, SSD, Win10 Pro, GTX 750Ti 2GB, FAH 7.6.13
Neil-B
 
Posts: 1342
Joined: Sun Mar 22, 2020 6:52 pm
Location: UK

Re: Cores with -1 not detected correctly?

Postby _r2w_ben » Fri Jul 03, 2020 10:32 pm

Xeon Gold 6244 is 8C/16T so this must be a 4S server. Either 2x32 or 4x16 should give the best results depending on Windows scheduling and how much time is spent syncing threads on different sockets.
_r2w_ben
 
Posts: 278
Joined: Wed Apr 23, 2008 4:11 pm


Return to New Donors start here

Who is online

Users browsing this forum: No registered users and 1 guest

cron