Specific GM107 is unsupported - why?

A forum for discussing FAH-related hardware choices and info on actual products (not speculation).

Moderator: Site Moderators

Forum rules
Please read the forum rules before posting.
Post Reply
Foliant
Posts: 104
Joined: Wed May 13, 2020 4:39 pm
Location: Bavaria

Specific GM107 is unsupported - why?

Post by Foliant »

Hello,

after long time beeing absent, I decidet to configure a crap-rig for the upcoming season of some unused photovoltaik energy.

I stoated all of my GTX750(Ti) together but for the Manli branded one I did get a 'unsupported' Message.
Image

The two other GM107 are folding well within time, so I wonder if the Manli branded one has specific issues leading to an exclusion.
24/7
1x i5 3470 @2Cores
1x GTX750 (GM107)
2x GTX750Ti (GM107)
Joe_H
Site Admin
Posts: 7843
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp2
Location: W. MA

Re: Specific GM107 is unsupported - why?

Post by Joe_H »

It is possible that the Manli branded GTX 750ti was assigned yet another PCI ID number that did not get entered into the GPUs.txt file. Nvidia often does that with each new variant getting another ID even if using the same basic hardware. Directions for finding the PCI ID number are available here - viewtopic.php?p=262894#p262894. If you could do that and post it, we can see about getting it added to the list if not already there. Otherwise additional information may be needed to figure out why the card is not being recognized as usable.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Foliant
Posts: 104
Joined: Wed May 13, 2020 4:39 pm
Location: Bavaria

Re: Specific GM107 is unsupported - why?

Post by Foliant »

--lspci seems not to be included in the open Beta (Im using 8.3.4)
If it gets added, the guide should also be updated with the new "fah-client", where the old was "FAHClient".

Anyway

Code: Select all

lspci --nn |grep VGA
should also tell enough:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
Youre right, a quick check tells me this ID isnt in the gpus.txt
24/7
1x i5 3470 @2Cores
1x GTX750 (GM107)
2x GTX750Ti (GM107)
Joe_H
Site Admin
Posts: 7843
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp2
Location: W. MA

Re: Specific GM107 is unsupported - why?

Post by Joe_H »

That ID should be there. Searching the text version - https://apps.foldingathome.org/GPUs.txt - shows this line:

Code: Select all

0x10de:0x1380:2:4:GM107 [GeForce GTX 750 Ti] 1389
The v8 client uses a gpus.json file. I checked the file on one of my systems, the entry is there for the GTX 750 Ti:

Code: Select all

 {"vendor": 4318, "device": 4992, "type": 2, "species": 4, "description": "GM107 [GeForce GTX 750 Ti] 1389"}
Only difference is that the .json file has the hexadecimal numbers converted to decimal, 4992 equals 0x1380.

So something else is going on there to leave the GPU disabled.

As a clarification, v8.3.4 does show up on the beta download page. They will have an official announcement of the public beta soon and fuller support should be coming here with that.
toTOW
Site Moderator
Posts: 6283
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France
Contact:

Re: Specific GM107 is unsupported - why?

Post by toTOW »

What does the log say at client startup ?

It might be a bug in v8 which is mostly an alpha release ... try v7 instead.
Image

Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.
Foliant
Posts: 104
Joined: Wed May 13, 2020 4:39 pm
Location: Bavaria

Re: Specific GM107 is unsupported - why?

Post by Foliant »

Gnah, I forgot to add 0x for searching the file.
Let me finish (17 hours) and pause, at the moment theres a 950 in the slot.
24/7
1x i5 3470 @2Cores
1x GTX750 (GM107)
2x GTX750Ti (GM107)
Foliant
Posts: 104
Joined: Wed May 13, 2020 4:39 pm
Location: Bavaria

Re: Specific GM107 is unsupported - why?

Post by Foliant »

So this is my prepared text from before I pluged the Manli back again:
FAHControl (even the Phython 3 Beta "python3-fahcontrol_7.7.0-1_all.deb") iss not working in todays version of Linux Mint 21.3. But the terminal will be enough to tell if there is a difference between 7.x and 8.x

I puted the Manli-card in a different machine using

Code: Select all

19:51:13:        Version: 7.6.21
and get it working:

Code: Select all

19:51:13:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:4 GM107 [GeForce GTX 750 Ti] 1389
19:51:13:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:5.0 Driver:12.2
19:51:13:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:3.0 Driver:535.154
[...]
19:51:13:FS01:Initialized folding slot 01: gpu:1:0 GM107 [GeForce GTX 750 Ti] 1389
[...]
19:52:15:WU01:FS01:Requesting new work unit for slot 01: gpu:1:0 GM107 [GeForce GTX 750 Ti] 1389 from 128.174.73.74
But the above text is not necessary anymore, because 8.3.4 is recognizing the card now.
Im sure, there was no update in between. Not driver, not system.
Image

And to make it even worse: The 750Ti that worked before has also the Device ID 0x1380

Image

Code: Select all

*********************** Log Started 2024-02-12T00:08:29Z ***********************
00:08:29:I1:*********************** Folding@home Client ***********************
00:08:29:I1: Version: 8.3.4
00:08:29:I1: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
00:08:29:I1: Org: foldingathome.org
00:08:29:I1: Copyright: 2023-2024, foldingathome.org
00:08:29:I1: Homepage: https://foldingathome.org/
00:08:29:I1: License: GPL-3.0-or-later
00:08:29:I1: URL: https://beta.foldingathome.org/
00:08:29:I1: Date: Feb 7 2024
00:08:29:I1: Time: 10:49:14
00:08:29:I1: Revision: 432ec23c0cad21b0d889fe6cfabfb694fa6440e3
00:08:29:I1: Branch: master
00:08:29:I1: Compiler: GNU 8.3.0
00:08:29:I1: Options: -faligned-new -std=c++17 -fsigned-char -ffunction-sections
00:08:29:I1: -fdata-sections -O3 -funroll-loops -fno-pie
00:08:29:I1: Platform: linux 4.19.0-26-cloud-amd64
00:08:29:I1: Bits: 64
00:08:29:I1: Mode: Release
00:08:29:I1: Args: --config=/etc/fah-client/config.xml
00:08:29:I1: --log=/var/log/fah-client/log.txt
00:08:29:I1: --log-rotate-dir=/var/log/fah-client/
00:08:29:I1: Config: /etc/fah-client/config.xml
00:08:29:I1:****************************** CBang ******************************
00:08:29:I1: Version: 1.7.2
00:08:29:I1: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
00:08:29:I1: Org: Cauldron Development LLC
00:08:29:I1: Copyright: Cauldron Development LLC, 2003-2024
00:08:29:I1: Homepage: https://cauldrondevelopment.com/
00:08:29:I1: License: LGPL-2.1-or-later
00:08:29:I1: Date: Feb 7 2024
00:08:29:I1: Time: 10:48:51
00:08:29:I1: Revision: f07e7b0ea470bfa8c73d253164056ce63d3d3bca
00:08:29:I1: Branch: master
00:08:29:I1: Compiler: GNU 8.3.0
00:08:29:I1: Options: -faligned-new -std=c++17 -fsigned-char -ffunction-sections
00:08:29:I1: -fdata-sections -O3 -funroll-loops -fno-pie -fPIC
00:08:29:I1: Platform: linux 4.19.0-26-cloud-amd64
00:08:29:I1: Bits: 64
00:08:29:I1: Mode: Release
00:08:29:I1:***************************** System ******************************
00:08:29:I1: CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
00:08:29:I1: CPU ID: GenuineIntel Family 6 Model 58 Stepping 9
00:08:29:I1: CPUs: 4
00:08:29:I1: Memory: 7.64GiB
00:08:29:I1:Free Memory: 7.15GiB
00:08:29:I1: OS Version: 5.15
00:08:29:I1:Has Battery: false
00:08:29:I1: On Battery: false
00:08:29:I1: Hostname: i5-3470
00:08:29:I1: UTC Offset: 1
00:08:29:I1: PID: 914
00:08:29:I1: CWD: /var/lib/fah-client
00:08:29:I1: Exec: /usr/bin/fah-client
00:08:29:I1:*******************************************************************
00:08:29:I2:<config/>
00:08:29:I1:Opening Database
00:08:29:I1:F@H ID = KHje1ZFA8X3qPez_74YhNZK0Oy9ZArfGCOQfhdCofHM
00:08:29:I3:Loading default group
00:08:29:I3:Loading default resource group
00:08:29:I1:Listening for HTTP on 127.0.0.1:7396
00:08:29:I3:Loaded 0 wus.
00:08:29:E :OpenCL not supported: Failed to open dynamic library 'libOpenCL.so': libOpenCL.so: cannot open shared object file: No such file or directory
00:08:29:I3:gpus = {
00:08:29:I3: "gpu:01:00:00": {
00:08:29:I3: "vendor": 4318,
00:08:29:I3: "type": "nvidia",
00:08:29:I3: "description": "NVIDIA GeForce GTX 750",
00:08:29:I3: "uuid": "b61c7bd7-ae10-fe27-6a22-f1bf3a18d3b1",
00:08:29:I3: "cuda": {"platform": 0, "device": 2, "compute": "5.0", "driver": "12.2"},
00:08:29:I3: "device": 4993,
00:08:29:I3: "supported": true
00:08:29:I3: },
00:08:29:I3: "gpu:03:00:00": {
00:08:29:I3: "vendor": 4318,
00:08:29:I3: "type": "nvidia",
00:08:29:I3: "description": "NVIDIA GeForce GTX 750 Ti",
00:08:29:I3: "uuid": "6aa169ae-cb43-6527-eb07-16a0c290cf60",
00:08:29:I3: "cuda": {"platform": 0, "device": 0, "compute": "5.0", "driver": "12.2"},
00:08:29:I3: "device": 4992,
00:08:29:I3: "supported": true
00:08:29:I3: },
00:08:29:I3: "gpu:04:00:00": {
00:08:29:I3: "vendor": 4318,
00:08:29:I3: "type": "nvidia",
00:08:29:I3: "description": "NVIDIA GeForce GTX 750 Ti",
00:08:29:I3: "uuid": "fe1572f3-3f0b-bf88-0ab5-5f69f792aed6",
00:08:29:I3: "cuda": {"platform": 0, "device": 1, "compute": "5.0", "driver": "12.2"},
00:08:29:I3: "device": 4992,
00:08:29:I3: "supported": true
00:08:29:I3: }
00:08:29:I3:}
00:10:23:I1:REQ3:< GET / HTTP/1.1
00:10:23:I1:REQ3:> HTTP/1.1 307 HTTP_TEMPORARY_REDIRECT
After this log, i now did install "ocl-icd-opencl-dev" to get rid of the red message.

There is now nothing more to do, beside caling it strange.
24/7
1x i5 3470 @2Cores
1x GTX750 (GM107)
2x GTX750Ti (GM107)
Post Reply