Windows XP, GTX460 dropping to 2D clocks [solved]

If you think it might be a driver problem, see viewforum.php?f=79

Moderators: slegrand, Site Moderators, PandeGroup

Windows XP, GTX460 dropping to 2D clocks [solved]

Postby rhavern » Sun Dec 04, 2011 1:30 pm

I wanted to pass on my experience with a box I recently had to rebuild. One of our cats decided to urinate into a box acting as a file server, prompting an unscheduled shutdown. FWIW, bleach based cleaning products are the only thing that will get rid of the smell. Anyway, enough of the humor, on with the lessons learned.

This box had been running for months/close to years with a Zotac GTX460 prior to this incident. I have a second-hand EVGA GTX460 that refuses to play nicely with other GPUs and fold, so I thought this would be a good opportunity to swap the EVGA into the file server, which only has one PCIE slot. I have other dedicated folding rigs with 3x PCIE x16 slots.

Now as we all know (if not, you will), there is one folding critical setting in nvidia control panel that is absent in Windows XP, Prefer Maximum Performance. Without this setting, XP is a fickle thing and tends to allow the GPU to downclock out of 3D, right down to 101MHz. Clearly this is the opposite of what is desired for maximum PPD. Now you may be wondering, why am I using XP? Why not use something newer or different? Well here's why:

  • This copy of XP is paid for and I can't justify a Windows upgrade for a headless file server.
  • Starting in Vista and above, you can't run the GPU client as a service. Thanks for that. <grumble>
  • The FAH GPU client does not currently support Linux natively. <Yes please!>

After all the post-SP3 MS hotfixes, I installed the current non-beta nvidia 285.58, MSI Afterburner 2.10 and FAH GPU console 6.41r2. Folding took off fine; note at this time I had a keyboard and monitor connected while testing. I was watching it quite closely and it all seemed to be working fine. So I left it longer. Downclock, drat. As soon as I logged back in, it jumped back to 3D. Hmm. I did a bit of searching, someone suggested setting the 2D profile to be the same as the 3D profile. Seems plausible, so I set it up. No change. More searching. Another suggestion was that newer drivers downclocked more aggressively, stick with 266.58. Also seems plausible, most of my dedicated rigs are still running 266.58, but the rigs with Fermi cards are also running Windows 7. Worth a try. No change.

Now I'm getting a bit frantic as the wisdom of the internet is getting rather thin for additional ideas. I stumbled across another poster that in addition to recommending 266.58, said to disable the screen saver completely. Huh, seems a bit of a stretch, but I'm grasping at straws now, so what the heck? Lo and behold! The 3D clocks stayed put! Huzzah!

So with that, this box has been folding at 3D clocks for several days continuously now. I thought it might be best to document this caveat in order to assist anyone else out there with this issue as it took me quite a bit of digging to put all the pieces together.

Good luck and fold on.
Folding since 1 WU=1 point
ImageImage
User avatar
rhavern
 
Posts: 479
Joined: Mon Dec 03, 2007 8:45 am
Location: UK

Re: Windows XP, GTX460 dropping to 2D clocks [solved]

Postby domboy » Thu Dec 08, 2011 1:25 pm

Well I'll be darned. Disabling the screen saver does the trick on XP 64-bit too. I just recently got a Zotac GT 430 PCI, and I didn't even realize I had a problem considering the GPU was running at 99% while folding. I did think that the PPD seemed a little low (~1600 PPD), especially since my GT 220 was out folding it (~2200 PPD). I thought maybe it was a GPU2 vs. GPU3 thing, or a PCI bus limitation, or something. But after I read this post I looked more closely at the clock speeds GPU-Z reported, and sure enough, they were all running 1/2 to 2/3 was what they should be. This little GPU has now gone from ~1600 PPD before the fix to ~2600 PPD... not too shabby! Thanks for posting this solution!!

Update:
I finally remembered to check my driver version: 280.26.
Last edited by domboy on Thu Dec 29, 2011 6:11 pm, edited 1 time in total.
domboy
 
Posts: 138
Joined: Thu Oct 02, 2008 1:42 pm
Location: Wilmington NC

Re: Windows XP, GTX460 dropping to 2D clocks [solved]

Postby rhavern » Thu Dec 08, 2011 1:40 pm

Excellent. That I was able to assist someone else makes the time posting worthwhile. Thanks for the feedback.
User avatar
rhavern
 
Posts: 479
Joined: Mon Dec 03, 2007 8:45 am
Location: UK

Re: Windows XP, GTX460 dropping to 2D clocks [solved]

Postby rhavern » Sun Dec 18, 2011 12:00 pm

In order to determine what was the critical component, driver version and/or disabling the screen saver, I upgraded to the current WHQL driver 285.58 and changed nothing else. The GPU is still staying at 3D clocks with this driver version. I can't comment on any other version other than the two I have tested, but at least it is another data point.

Regards
User avatar
rhavern
 
Posts: 479
Joined: Mon Dec 03, 2007 8:45 am
Location: UK

Re: Windows XP, GTX460 dropping to 2D clocks [solved]

Postby raytunny » Wed Jan 11, 2012 2:26 pm

Thanks for this info, I was flumoxed with my GTX460 getting less than my older graphics card (GT8800) after an upgrade. I was getting awful results much worse than the GT8800 had previously been getting and couldn't understand why, I hadn't realised the screen saver was on as when I leave the computer I turn off the monitor. I'm now using the GPU3 client on it and the SMP client on the Q6600 CPU and now doing 90,000 points p/w, a much better return for the electric used. I'm now on the 285.58 driver which is supposed to be better for Fermi, although I personally haven't noticed any difference. Thanks again for bringing this to our notice, it's the only article I found that even mentioned the screen saver. I'm now zooming up the MicroMart Team stats list, thanks to you :D
raytunny
 
Posts: 20
Joined: Wed Jun 18, 2008 1:05 am
Location: Great Harwood, Near Blackburn, Lancashire, England

Re: Windows XP, GTX460 dropping to 2D clocks [solved]

Postby rhavern » Wed Jan 11, 2012 3:12 pm

Brilliant, glad you found what worked for you. Thanks for the report.
User avatar
rhavern
 
Posts: 479
Joined: Mon Dec 03, 2007 8:45 am
Location: UK


Return to V6 GPU3 beta (including Fermi) OpenMM

Who is online

Users browsing this forum: No registered users and 0 guests